Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge perl fails - kernel versions don't match? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
immudium
Guru
Guru


Joined: 12 Oct 2004
Posts: 332
Location: Utah

PostPosted: Fri Mar 11, 2005 6:17 pm    Post subject: emerge perl fails - kernel versions don't match? [SOLVED] Reply with quote

* EDIT - According to the bug noted below, a fix should be in portage shortly or you can use the temporary workaround of editing Errno.pm *

I'm having a hard time figuring out why I can't update perl when doing an emerge -uDav world. I think the relevant error is this one:
Code:
Errno architecture (i686-linux-thread-multi-2.6.10-gentoo-r7) does not match executable architecture (i686-linux-thread-multi-2.6.11-gentoo-r2) at /usr/lib/perl5/5.8.6/i686-linux-thread-multi/Errno.pm line 11.

I'm pretty sure my kernel version is all set up and linked correctly.
Code:

#ls -la /usr/src/linux
lrwxrwxrwx  1 root root 31 Mar  8 12:41 /usr/src/linux -> /usr/src/linux-2.6.11-gentoo-r2
#uname -r
2.6.11-gentoo-r2


So am I missing something in my kernel setup? It looks like I might need to recompile something so that it uses the newer 2.6.11 kernel, but I can't see what that would be. I've tried
Code:
emerge -aev --oneshot --nodeps linux26-headers =sys-libs/db-4.2.52_p2 groff libperl

which didn't help.

A More complete error report is below. Let me know if I need to include any other info and thanks for any help.

Code:
pp_sort.c: In function `S_mergesortsv':
pp_sort.c:368: warning: 'savecmp' might be used uninitialized in this function
rm -f libperl.a
/usr/bin/ar rcu libperl.a perl.o  gv.o toke.o perly.o op.o pad.o regcomp.o dump.o util.o mg.o reentr.o hv.o av.o run.o pp_hot.o sv.o pp.o scope.o pp_ctl.o pp_sys.o doop.o doio.o regexec.o utf8.o taint.o deb.o universal.o xsutils.o globals.o perlio.o perlapi.o numeric.o locale.o pp_pack.o pp_sort.o
`sh  cflags "optimize='-O3 -march=pentium4 -mtune=pentium4 -fforce-addr -momit-leaf-frame-pointer -fomit-frame-pointer -ftracer -pipe'" opmini.o` -fPIC -DPERL_EXTERNAL_GLOB opmini.c
     CCCMD =  gcc -DPERL_CORE -c -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -fno-strict-aliasing -pipe -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O3 -march=pentium4 -mtune=pentium4 -fforce-addr -momit-leaf-frame-pointer -fomit-frame-pointer -ftracer -pipe  -Wall
gcc -L/usr/local/lib -o miniperl \
    miniperlmain.o opmini.o libperl.a -lpthread -lnsl -ldl -lm -lcrypt -lutil -lc
./miniperl -w -Ilib -MExporter -e '<?>' || make minitest
make: [extra.pods] Error 1 (ignored)
./miniperl -Ilib configpm configpm.tmp
sh mv-if-diff configpm.tmp lib/Config.pm
./miniperl -Ilib lib/lib_pm.PL
Extracting lib.pm (with variable substitutions)
   AutoSplitting perl library
./miniperl -Ilib -e 'use AutoSplit; \
autosplit_lib_modules(@ARGV)' lib/*.pm
Errno architecture (i686-linux-thread-multi-2.6.10-gentoo-r7) does not match executable architecture (i686-linux-thread-multi-2.6.11-gentoo-r2) at /usr/lib/perl5/5.8.6/i686-linux-thread-multi/Errno.pm line 11.
Compilation failed in require at lib/File/Path.pm line 166.
BEGIN failed--compilation aborted at lib/File/Path.pm line 166.
Compilation failed in require at lib/AutoSplit.pm line 8.
BEGIN failed--compilation aborted at lib/AutoSplit.pm line 8.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
make: *** [preplibrary] Error 9

!!! ERROR: dev-lang/perl-5.8.6-r4 failed.
!!! Function src_compile, Line 249, Exitcode 2
!!! Unable to make
!!! If you need support, post the topmost build error, NOT this status message.


Last edited by immudium on Sat Mar 12, 2005 12:18 am; edited 2 times in total
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3707
Location: Hamburg

PostPosted: Fri Mar 11, 2005 6:22 pm    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=84868
Back to top
View user's profile Send private message
immudium
Guru
Guru


Joined: 12 Oct 2004
Posts: 332
Location: Utah

PostPosted: Fri Mar 11, 2005 6:27 pm    Post subject: Reply with quote

Ah, thanks, I'll sit tight then and see if a fix or patch shows up. I should have looked at the bug list first, but I had convinced myself that I had screwed up my kernel somewhere. My bad. :oops:
Back to top
View user's profile Send private message
sunoterra
n00b
n00b


Joined: 04 Jun 2004
Posts: 43
Location: Michigan

PostPosted: Fri Mar 11, 2005 6:51 pm    Post subject: Reply with quote

toralf wrote:
https://bugs.gentoo.org/show_bug.cgi?id=84868


nice. thanks.

I was experiencing the same issue. The kernel architecure that it was complaining about isn't even install on my box anymore.

ah well... such is life...

:)
_________________
l33t/n00b
Back to top
View user's profile Send private message
Slayer2004
n00b
n00b


Joined: 06 Apr 2004
Posts: 37

PostPosted: Fri Mar 11, 2005 7:15 pm    Post subject: Reply with quote

Same Prob. here:

Errno architecture (i686-linux-2.6.9-gentoo-r13) does not match executable architecture (i686-linux-2.6.10-gentoo-r6) at /usr/lib/perl5/5.8.5/i686-linux/Errno.pm line 11.
Compilation failed in require at lib/File/Path.pm line 166.
BEGIN failed--compilation aborted at lib/File/Path.pm line 166.
Compilation failed in require at lib/AutoSplit.pm line 8.
BEGIN failed--compilation aborted at lib/AutoSplit.pm line 8.
Compilation failed in require at -e line 1.
BEGIN failed--compilation aborted at -e line 1.
make: *** [preplibrary] Error 9

!!! ERROR: dev-lang/perl-5.8.5-r5 failed.
!!! Function src_compile, Line 246, Exitcode 2
!!! Unable to make
!!! If you need support, post the topmost build error, NOT this status message.
_________________
Linux ist wie Urlaub von Windows.

NEIN! zu Softwarepatenten in Europa !!!
Bitte helft mit diesen Schwachsinn zu verhindern
Back to top
View user's profile Send private message
immudium
Guru
Guru


Joined: 12 Oct 2004
Posts: 332
Location: Utah

PostPosted: Fri Mar 11, 2005 9:28 pm    Post subject: Reply with quote

As noted in the bug thread above, it appears that directly editing the Errno.pm to your current kernel version will get you around the road block of compiling the perl update. At least it did for me anyway. I'm sure a cleaner fix is on the way...
Back to top
View user's profile Send private message
slam_head
Guru
Guru


Joined: 06 Jan 2003
Posts: 449
Location: New York City

PostPosted: Fri Mar 11, 2005 10:38 pm    Post subject: Reply with quote

I had this same problem. Editting my Errno.pm did seem to fix the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum