Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge world] Message d'erreur lors d'un update (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
papedre
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 178

PostPosted: Tue Mar 08, 2005 9:49 pm    Post subject: [emerge world] Message d'erreur lors d'un update (Résolu) Reply with quote

Salut à tous ,
Je viens de constater un comportement étrange lors de la vérification des nouveaux packets disponibles :
Code:
root@Gentoo juan # emerge -pvuD world

These are the packages that I would merge, in order:

Calculating world dependencies -
!!! All ebuilds that could satisfy "=media-libs/gst-plugins-0.8.7*" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/gst-plugins-0.8.7 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "media-plugins/gst-plugins-mad-0.8.7" [ebuild])


!!! Problem with ebuild media-video/totem-0.100-r2
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.


Je trouve ce message bizarre car j'ai rien installer hier ( et hier cette commande focntionnait correctemetn en me proposant des nouveux packages que je n'avais pas installer).

Donc, je regarde quelle version j'ai d'installer de 'gst-plugin' (extrait)
Code:
 emerge -s gst-plugins
*  media-libs/gst-plugins
      Latest version available: 0.8.5-r1
      Latest version installed: 0.8.5-r1
      Size of downloaded files: 1,984 kB
      Homepage:    http://gstreamer.net/
      Description: Basepack of plugins for gstreamer
      License:     GPL-2

*  media-plugins/gst-plugins-mad
      Latest version available: 0.8.7
      Latest version installed: 0.8.5
      Size of downloaded files: 2,084 kB
      Homepage:    http://gstreamer.freedesktop.org/modules/gst-plugins.html
      Description: plugin for gstreamer
      License:     GPL-2

+...


Je suis presque toujours rester en branche stable (sauf pour le Java).
Et donc cela me semble ressembler à un bug par rapport à une nouvelle version d'un Ebuild (d'autant plus que gst-plugin à été mis à jours hier ).

Ma question est :
- Avez vous le meme Pb ???
- Comment savoir si ce problème est déjà repertorié.

Merci d'avance.
A+


Last edited by papedre on Tue Mar 08, 2005 10:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
manu.acl
Guru
Guru


Joined: 29 Jan 2005
Posts: 426
Location: Paris

PostPosted: Tue Mar 08, 2005 9:52 pm    Post subject: Reply with quote

c'est media-plugins/gst-plugins-mad-0.8.7 qui a besoin de media-libs/gst-plugins-0.8.7 qui est masqué.
Back to top
View user's profile Send private message
papedre
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 178

PostPosted: Tue Mar 08, 2005 9:54 pm    Post subject: Reply with quote

Oui, mais comment cela se fait en restant dans une branche stable, que l'on me demande une dependance vers un packet masqué
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue Mar 08, 2005 9:55 pm    Post subject: Reply with quote

probable que ce soit un bug ... enfin, je pense que ton sync a ete effectue pendant que quelqu'un modifiait ces fichiers (un dev a passé media-plugins/gst-plugins-mad-0.8.7 en stable, et t'as fais un sync avait qu'il ait modifie media-libs/gst-plugins-0.8.7 ... enfin c'est que une hypothese !! .. ou bien il a simplement oublie :) )

si tu veux y remedier tout de suite, fais :

Code:
echo "=media-libs/gst-plugins-0.8.7 ~x86" >> /etc/portage/package.keywords

_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
papedre
Apprentice
Apprentice


Joined: 02 Mar 2005
Posts: 178

PostPosted: Tue Mar 08, 2005 10:02 pm    Post subject: Reply with quote

Bon, bien vu Kernel_sensei.

Je viens de refaire un emerge --sync. Et maintenant, tout fonctionne correctement.

Trop fort ..... ( Réponse en moins de 5 minutes, mais comment il fait ???)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum