Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mesa-glu & kopete masked; ircp absent; php not functioni
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Pasha
n00b
n00b


Joined: 02 Mar 2005
Posts: 33
Location: Derbyshire, UK

PostPosted: Tue Mar 08, 2005 3:06 pm    Post subject: mesa-glu & kopete masked; ircp absent; php not functioni Reply with quote

Hi. I've recently switched from Debian to Gentoo to check it out.
Using ACCEPT_KEYWORDS="~x86" (it's like tesing/unstable in Debian, isn't it?)

So. First thing I miss is ircp (copying files between say a mobile phone and the computer via infrared beams). Is there an ebuild for it?

Secondly, I like OpenGL :-P and it is therefore enabled as the USE flag. However I cannot do proper 'emerge world' because some soft requires gtkglarea, which does not want to compile due to lack of mesa-glu package. But emerge mesa-glu gives...
Code:
lnx ~ # emerge mesa-glu
Calculating dependencies
!!! All ebuilds that could satisfy "mesa-glu" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/mesa-glu-3.5 (masked by: package.mask)
# Only use the mesa and mesa-glu provided with x11-base/xfree,
# as the external ones gives problems in most cases with DRI/DRM.
# Nvidia users do not use it anyhow, and tdfx users report that
# it works fine with the mesa included with xfree.  If you do
# unmask these, make sure that you know what you are doing, and
# know that if anything breaks, then you get to keep the pieces.
#
# azarah (26 May 2002)

But I cannot emerge x11-base/xfree blah-blah-blah because there's no such directory in the portage tree. So what shall I do with MESA? And why is the comment made two and a half years ago?

Kopete does not compile because some kde libraries are missing (investigated by adding some packages to package.unmask file)

And the last problem. I have apache2 and php5 (php and mod_php) emerged.
It compiled ok, but I cannot make PHP work...
In httpd.conf:
Code:
Include conf/modules.d/*.conf

In /usr/lib/apache2/conf/modules.d/70_mod_php5.conf:
Code:
<IfDefine PHP5>

        # Load the module first
        <IfModule !sapi_apache2.c>
                LoadModule php5_module    modules/libphp5.so
        </IfModule>

        # Set it to handle the files
        <IfModule mod_mime.c>
                AddType application/x-httpd-php .php
                AddType application/x-httpd-php .phtml
                AddType application/x-httpd-php .php3
                AddType application/x-httpd-php .php4
                AddType application/x-httpd-php .php5
                AddType application/x-httpd-php-source .phps
        </IfModule>

</IfDefine>


But PHP Scripts are simply not handled by the webserver. What do I need to do? :roll:
Back to top
View user's profile Send private message
Pasha
n00b
n00b


Joined: 02 Mar 2005
Posts: 33
Location: Derbyshire, UK

PostPosted: Wed Mar 09, 2005 8:20 am    Post subject: Reply with quote

Apache shows no error messages in the log file... So does anyone know what to do? :/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum