Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sylpheed-claws with pspell installation
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
stimpy
n00b
n00b


Joined: 18 Apr 2002
Posts: 49
Location: NZ

PostPosted: Wed May 22, 2002 2:50 am    Post subject: sylpheed-claws with pspell installation Reply with quote

Anyone had any success getting the install of sylpheed-claws to work with pspell enabled?

When configure tries to compile its pspell test program it fails to link due to unresolved symbols - because pspell is a c++ library and needs to link against libstc++. (I've read something sonewhere that it is some kind of problem in libtool... that's way beyond me in bug tracking and fixing. :? Might it be the information stored in libpspell.la not including stdc++?)

There's nothing actually wrong with my pspell lib( as far as I can tell), and yes this is on all the recent versions. (If I manually try the same thing configure does, but with -lstdc++ added, the test compile works fine.)

Any suggestions (other than not worrying about my spelling in email or changing mail clients?)

(I recall I had similar problems getting it to be added in my Redhat 7.2 distro, but that was just getting the "--enable-pspell" option passed to configure when I was rpm'ing. It however doesn't seem to have the same linking probelems on the test. Maybe this is a gentoo libtool problem - or similar...)
Back to top
View user's profile Send private message
BackSeat
Apprentice
Apprentice


Joined: 12 Apr 2002
Posts: 242
Location: Reading, UK

PostPosted: Wed May 22, 2002 9:14 am    Post subject: Reply with quote

I'm getting the same error, and have logged it in the bug database (bug 2907).

BS
Back to top
View user's profile Send private message
ronmon
Veteran
Veteran


Joined: 15 Apr 2002
Posts: 1043
Location: Key West, FL

PostPosted: Fri May 24, 2002 11:56 am    Post subject: Reply with quote

I stumbled across the answer to this problem just now while perusing the package.mask file. The solution involved doing an "emerge -u" on pspell and aspell, then emerge pspell-ispell. Then, I rebuilt sylpheed-claws and selected the en-american-ispell dictionary in my configuration menu. It works!
Back to top
View user's profile Send private message
stimpy
n00b
n00b


Joined: 18 Apr 2002
Posts: 49
Location: NZ

PostPosted: Tue May 28, 2002 5:27 am    Post subject: pspell-ispell dictionary hashes Reply with quote

Having just tried out the ebuild workaround from the 2907 bug: before the configure add-
Code:
for j in ac/pspell.m4 aclocal.m4 configure ; do
        cp $j ${j}.orig
        sed "s/-lpspell/-lpspell -lstdc++/" < ${j}.orig > ${j}
    done

I found that sylpheed kept "aborting" when I went to email.

Having also "stumbled across" pspell-ispell, I found that selecting these new dictionaries made if work. There's obviously something different in the interfaces of the two (am I right to call them the hashes into the actual dictionary?)

Ahhh... the beauty of gentoo (and linux) - stumbling across solutions :)

BTW the other workaround that could be used is to use the "--disable-pspelltest" option to configure - if you were sure that your pspell config was right...
Back to top
View user's profile Send private message
lx
Veteran
Veteran


Joined: 28 May 2002
Posts: 1012
Location: Netherlands

PostPosted: Tue May 28, 2002 12:06 pm    Post subject: Reply with quote

If you fix it sylpheed-claws will still crash when you turn on spell-checking. I already found out with 0.7.4 and now with 0.7.6 it still doesn't work. In debian it works, but well I'm going to try the pspell-ispell hope this works and else well who cares.

Thkx lX
_________________
"Remember there's a big difference between kneeling down and bending over.", Frank Zappa
Back to top
View user's profile Send private message
ronmon
Veteran
Veteran


Joined: 15 Apr 2002
Posts: 1043
Location: Key West, FL

PostPosted: Tue May 28, 2002 2:54 pm    Post subject: Reply with quote

My spell checking works fine now by doing what I outlined above. I did not have to edit the ebuild file, just change the spell packages around a little.

Now to figure out why line wrapping is broken...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum