Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.11-rc5-nitro0: Fear And Loathing In intermodule.c
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Tue Mar 01, 2005 2:44 am    Post subject: Reply with quote

Code:
patch -p1 --dry-run < patch-2.6.11-rc5-nitro0-rt  (/usr/src/linux)
patching file Documentation/Changes
Reversed (or previously applied) patch detected!  Assume -R? [n]


That's not the problem. The patch is just b0rked somehow...
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
mcspiff
Tux's lil' helper
Tux's lil' helper


Joined: 24 Oct 2004
Posts: 109

PostPosted: Tue Mar 01, 2005 3:07 am    Post subject: Reply with quote

Rainmaker wrote:
Code:
patch -p1 --dry-run < patch-2.6.11-rc5-nitro0-rt  (/usr/src/linux)
patching file Documentation/Changes
Reversed (or previously applied) patch detected!  Assume -R? [n]


That's not the problem. The patch is just b0rked somehow...


Too bad we can never tell where it came from with these guys...
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2099
Location: 127.0.0.1

PostPosted: Tue Mar 01, 2005 6:25 am    Post subject: Reply with quote

works for me so far so good :)
_________________
John5788
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 6:45 am    Post subject: Reply with quote

Ok guys, i don't know what this ebuild error is about, i sent the rt patchs to darckness, then he added two patches i forgot and diffed it again.....
Ill talk to him again today and try to figure it out together.

PS: its worth to wait, as i probably figured out whats the problem with framebuffer in rt, so it'll probably work in the updated patch too.

Just some patience... it might be the cause that darckness diffed it against nitro stable or something,

sorry , i cant tell before darckness is available again....

cheers,

T

PS: Sorry for that N*L shit again, it won't happen again, we had some bad day yesterday.....

EDIT: so, the framebuffer is definitely solved for 2.6.11-nitro0-rt
I'd appreciate an update about if the patch/ebuild online work now, darckness did some fixes yesterday.
rt release also has working sk98lin, i use it myself.... network connection is also slightly faster than usually, like all
other things,
probably because of the realtime-patches. this release also includes sched-iso from con, if someone uses the
schedtool for launching tasks....
_________________
Retired gentoo user
Back to top
View user's profile Send private message
fallow
Bodhisattva
Bodhisattva


Joined: 08 Jan 2004
Posts: 2206
Location: Poland

PostPosted: Tue Mar 01, 2005 7:13 am    Post subject: Reply with quote

on which cpu scheduler is based nitro-rt version ? (I`m fast looking at the rt version patchlist but can`t find staircase here ) - so : Ingo`s RTP and O(1) ?

cheers
_________________
"Time is a companion that goes with us on a journey. It reminds us to cherish each moment, because it will never come again. What we leave behind is not as important as how we have lived" J-L. Picard ;)
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 7:16 am    Post subject: Reply with quote

hey fallow, first of all: sorry for all the shit from yesterday and stuff i was talking about you recently.

Realtime-Preempt patches from ingo is the base for this patchset.
It is only compatible with O(1) as ingo did it as extension to his O(1) scheduler.
It also includes sched-iso from con.

cheers,

T

EDIT: although, the rt version includes about 200 patches total, so also some little fixes for sched i grabbed from lkml, kernel-traffic and
via email from kernel-maintainers.

EDIT2: ok, i checked the patch itself, the rt is fixed now, as far as the patch itself is concerned, apply against rc5,
ebuild is most probably also fixed.
Frambuffer fix will be added later today, i don't have access to the server. Cheers.
_________________
Retired gentoo user
Back to top
View user's profile Send private message
pifactorial
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2004
Posts: 77
Location: 3<x<4 on the gamma function

PostPosted: Tue Mar 01, 2005 7:49 am    Post subject: Reply with quote

WHA?!? I was about to make a post confirming that rt emerge does work, but it doesn't! I re-downloaded the patch and ebuild from the first post, but I still get:
Code:
nitro-sources # emerge nitro-sources
Calculating dependencies ...done!
>>> emerge (1 of 1) sys-kernel/nitro-sources-2.6.11_rc5-r0 to /
>>> md5 src_uri ;-) patch-2.6.11-rc5.bz2
>>> md5 src_uri ;-) linux-2.6.10.tar.bz2
>>> md5 src_uri ;-) patch-2.6.11-rc5-nitro0-rt.bz2
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-2.6.10.tar.bz2 to /var/tmp/portage/nitro-sources-2.6.11_rc5-r0/work
 * Applying patch-2.6.11-rc5.patch (-p0+) ...                                                                     [ ok ]
 * Applying patch-2.6.11-rc5-nitro0-rt.patch (-p0+) ...
patch: pch.c:621: intuit_diff_type: Assertion `i0 != NONE' failed.                                                [ !! ]
 * Please attach /var/tmp/portage/nitro-sources-2.6.11_rc5-r0/temp/patch-2.6.11-rc5-nitro0-rt.err to any bug you may post.

!!! ERROR: sys-kernel/nitro-sources-2.6.11_rc5-r0 failed.
!!! Function unipatch, Line 570, Exitcode 0
!!! Unable to dry-run patch.
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 8:38 am    Post subject: Reply with quote

i just tested it, cant be.

Another thing: the initial release of rc5 on kernel.org was broken, so redownloading from kernel org might help...

Anyway, i put the patchs in the same dir as the dir with rc5 is in, and do patch -p1 -i ../patch-2.6.11-nitro0-rt from within the rc5
directory.

And it worked 30 minutes ago, so try the manual way, i dont know much about emerging and ebuilds, i dont use gentoo.

Cheers,

T

EDIT: most probably the ebuild is still broken, or whatever....... Got to bug darckness when he wakes up... oh man...
_________________
Retired gentoo user
Back to top
View user's profile Send private message
super-lupo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jun 2004
Posts: 92
Location: Germany / Berlin

PostPosted: Tue Mar 01, 2005 1:03 pm    Post subject: Reply with quote

Thanks for your hard work Tiger.
Will try it again when I´m home.
And never mind about yesterday. Shit happens.


Greetings,
Lupo
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Tue Mar 01, 2005 2:23 pm    Post subject: Reply with quote

I get the same error as pifactorial and the others but I can confirm that the patch works if you apply it manually with patch -p1. I think there still are some problems with the ebuild.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 2:27 pm    Post subject: Reply with quote

Thanks for the feedback!!!!!!!!
Now we only need darckness to get his a*s around ( LOL ;) ) and fix the ebuild.
I dont use gentoo + i dont have the access to the online nitro repo.

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
super-lupo
Tux's lil' helper
Tux's lil' helper


Joined: 29 Jun 2004
Posts: 92
Location: Germany / Berlin

PostPosted: Tue Mar 01, 2005 2:32 pm    Post subject: Reply with quote

Quote:
I dont use gentoo


Shame on you... :mrgreen:



Greetings,
Lupo
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 2:34 pm    Post subject: Reply with quote

Yeah, shame on me :roll: , i use lfs instead.... 8)

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Tue Mar 01, 2005 3:07 pm    Post subject: Reply with quote

Sorry, but the rt patch still doesn't work... Is it supposed to apply on top of nitro or plain 2.6.11-r5 ?

PS LFS? Why on earth would you want to figure out your own dependencies when portage can do it all for you?? 8)
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 3:10 pm    Post subject: Reply with quote

Because i dont only want to know IF something works, but also HOW it works.

PS: patch it with -p1 and ontop of plain 2.6.11-rc5 , that would be:

grab 2.6.10 from kernel.org
patch with -p1 against 2.6.11-rc5
patch with -p1 against 2.6.11-rc5-nitro0-rt

cheers,

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Tue Mar 01, 2005 3:10 pm    Post subject: Reply with quote

I've just compiled and tested the new nitro-rt kernel. I get kernel panic ... what a shame :(
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 3:17 pm    Post subject: Reply with quote

what is your system setup, + i see you use reiser4, and it MIGHT have something to do with it,

AND don't forget, the version currently online HAS B0RKED FRAMEBUFFER!!! dont use framebuffer and dont use vesafb-tng,
this WILL result in a panic OR just a plain silent lockup at boot!!.
i have the patch to fix it here, but still waiting for darckness to update the patch that is still online and fix the ebuild.

Also make sure about 8 K stacks and not to go too far with cflags,
although on my system it runs freakin well with
O3 -march=athlon-xp -mtune=athlon-xp -mmmx -msse -m3dnow -pipe -fomit-frame-pointer -momit-leaf-frame-pointer -fprefetch-loop-arrays -mfpmath=sse -fbranch-target-load-optimize2 -ftracer -falign-functions=32,

although someone claimed in love thread that nitro kernels cant handle such cflags ;)

cheers,

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
seppe
Guru
Guru


Joined: 01 Sep 2003
Posts: 431
Location: Hove, Antwerp, Belgium

PostPosted: Tue Mar 01, 2005 3:19 pm    Post subject: Reply with quote

realtime b0rks here as well. I get "loading reiser4 bitmap" or something, and then a bunch of weird stuff and that's it. Too bad, I really wanted to play with Realtime Preemption :(

I'm thinking of going back to reiser3 .. because I want to check out beagle as well, which won't work with reiser4.
_________________
nitro-sources, because between stable and experimental there exists only speed

Latest release I made: 2.6.13.2-nitro1
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Tue Mar 01, 2005 3:35 pm    Post subject: Reply with quote

Tiger683 wrote:
Because i dont only want to know IF something works, but also HOW it works.

PS: patch it with -p1 and ontop of plain 2.6.11-rc5 , that would be:

grab 2.6.10 from kernel.org
patch with -p1 against 2.6.11-rc5
patch with -p1 against 2.6.11-rc5-nitro0-rt

cheers,

T


Confirmed, it applies cleanly on top op 2.6.11-r5. Ebuild doesn't work though... I'm gonna try and see if this is even faster then non-rt nitro :)
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 3:37 pm    Post subject: Reply with quote

Update: darckness is currently fixing the ebuild, so should work asap.

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 3:41 pm    Post subject: Reply with quote

@ seppe and all:

well, sorry guys, i run reiser3 and darckness has no reiser 4 either, ill make me a little reiser4 partition for testing for the next release...
for now, big big sorry, + reiser 3.6 is at least compatible with just about everything, so consider....

T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Tue Mar 01, 2005 3:41 pm    Post subject: Reply with quote

I'm using 8KB stacks, I haven't touched the CFLAGS (I had a bad experience with them ...) nor do I have vesa-tng or framebuffer support.

My CPU is Athlon XP 1800+.
Back to top
View user's profile Send private message
Tiger683
Veteran
Veteran


Joined: 08 Jan 2005
Posts: 1347
Location: Heffner's House

PostPosted: Tue Mar 01, 2005 3:46 pm    Post subject: Reply with quote

ok, i fugure its MOST likely reiser4.
although i have an idea how we might be able to fix it.
if someone feels like trying it with reiser4 AGAIN, raise your hand, i want to know if its worth the effort to bother darckness about updating the whole patch with this too and uploading...

cheers,
T
_________________
Retired gentoo user
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Tue Mar 01, 2005 3:54 pm    Post subject: Reply with quote

Whew. Sorry that stuff has gone to hell, but I suppose that's what happens when I get a massive fever and am clinically dead for 15 hours.

I just fixed the rt patch so that framebuffer works. Woo! As for the error that some of you are experiencing, it isn't caused by the patch. It's a bug in portage. If you google for "intuit_diff_type", you'll see that it has shown up in several versions of various patchsets. Basically, there's two solutions. It might just randomly decide to work, or I can make another patch to deal with portage's screwiness.

I'm currently doing my part.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.


Last edited by discomfitor on Tue Mar 01, 2005 3:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
a13x
Apprentice
Apprentice


Joined: 05 Jan 2005
Posts: 215

PostPosted: Tue Mar 01, 2005 3:54 pm    Post subject: Reply with quote

If you want I can help you by providing the output of the kernel panic. Of course it's a pain in the ass to copy all those hex numbers.

Here's how it roughly looks:

Code:

Process swapper (pid: 1, thread info=cffc0000 task=c127f7f0)
Stack: ---lots of hex---

Call trace:

some_hex_number         buffered_rmqueue
another_hex_number     _spin_lock
another_hex_number     search_binary_handler
.............................................................................
hex_number                    kernel_thread_helper

Code: --lots of 2 digit hex--

<0> Kernel panic - not syncing: Attempted to kill init !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 3 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum