Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PHPmyadmin login problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Fri Feb 25, 2005 9:36 am    Post subject: PHPmyadmin login problems Reply with quote

Hi,


I have emerged phpmyadmin, but i kan not login as, root or as any other users that i have made in mysql. I have emerged php again, like this USE="mysql" emerge mod_php, and stil i kant not login.

I get

Quote:

wrong username/password. Acces denied


I folowd this howto https://forums.gentoo.org/viewtopic-t-204396-highlight-howto+phpmyadmin.html , to install phpmyadmin. I also made a user with no password, and stil same probleem. Do i have to change somethink in configuration file in phpmyadmin?

Has anyone other ideas, to solve this probleem.


Greets ,


Azerix
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Fri Feb 25, 2005 9:42 am    Post subject: Reply with quote

perhaps the answer is here:
https://forums.gentoo.org/viewtopic-t-296325-highlight-phpmyadmin+login.html
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Fri Feb 25, 2005 10:06 am    Post subject: Reply with quote

So you want me change this settings in /var/www/localhost/htdocs/phpmyadmin/config.inc.php ? Couse i did that too, the only think that changed in config.inc.php is controluser and controlpass, both i set it to pma, but did not workt.

Shal i change this settings in config.inc.php like this configuration ?

Quote:

$cfg['PmaAbsoluteUri'] = 'http://www.example.com/phpmyadmin';
$cfg['PmaAbsoluteUri_DisableWarning'] = FALSE;
$cfg['blowfish_secret'] = '12345678901234567890';
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'socket'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension'] = 'mysql'; // The php MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = ''; // MySQL user
$cfg['Servers'][$i]['password'] = ''; // MySQL password (only needed
// with 'config' auth_type)
$cfg['Servers'][$i]['only_db'] = ''; // If set to a db-name, only
// this db is displayed in left frame
// It may also be an array of db-names, where sorting order is relevant.
$cfg['Servers'][$i]['verbose'] = ''; // Verbose name for this host - leave blank to show the hostname

/**
* set these only if you are actually using PMA
* not needed
* leave all other at default settings
** /
$cfg['Servers'][$i]['controluser'] = 'pma'; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = 's0mep4ssh3r3';
$cfg['Servers'][$i]['pmadb'] = 'pmadb'; // Database used for Relation, Bookmark and PDF Features
// (see scripts/create_tables.sql)
Back to top
View user's profile Send private message
Azerix
Guru
Guru


Joined: 19 Dec 2004
Posts: 346
Location: NL

PostPosted: Fri Feb 25, 2005 7:00 pm    Post subject: Reply with quote

I just changed the hole confiiguration just like this topic describes https://forums.gentoo.org/viewtopic-t-296325-highlight-phpmyadmin+login.html . But i stil kan not login.

Kan any one help? I get this error
Quote:

#2013 - Lost connection to MySQL server during query
Back to top
View user's profile Send private message
mc_barron
Apprentice
Apprentice


Joined: 28 Aug 2003
Posts: 230
Location: Chicago, IL

PostPosted: Sun Mar 13, 2005 7:47 pm    Post subject: Reply with quote

You mjight want to try adding the following like to /etc/hosts.allow :
mysqld: ALL

This will allow ALL incoming IPs to connect to your mysql database (so you probalby want to change ALL to only a select few IPs that you use)
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Tue Mar 15, 2005 6:15 pm    Post subject: Reply with quote

'xcuse me, but normally everyone would like to let his hosts.allow all by itsef, no? 8O
i install phpmyadmin on my own, and never have such problems (no, i do not use webapp)
Back to top
View user's profile Send private message
mc_barron
Apprentice
Apprentice


Joined: 28 Aug 2003
Posts: 230
Location: Chicago, IL

PostPosted: Tue Mar 15, 2005 6:27 pm    Post subject: Reply with quote

hds wrote:
'xcuse me, but normally everyone would like to let his hosts.allow all by itsef, no? 8O
i install phpmyadmin on my own, and never have such problems (no, i do not use webapp)

I assume you are saying that he should not touch the /etc/hosts.allow file? If you used "localhost" instead of "xxx.xxx.xxx.xxx" as the mysql server address then yes, you do not need to modify hosts.allow since it is using unix sockets (not tcp/ip). Why is it dangerous to modify the hosts.allow file?
Back to top
View user's profile Send private message
hds
Advocate
Advocate


Joined: 21 Aug 2004
Posts: 2629
Location: Sprockhoevel [GER]

PostPosted: Tue Mar 15, 2005 10:35 pm    Post subject: Reply with quote

mc_barron wrote:
Why is it dangerous to modify the hosts.allow file?

where did i say it would be dangerous 8O
mind quoting me on that?
is it full moon over this whole f*cking week, or whats going on in this forum?

editing hosts.allow will get you in trouble with your webserver and whatever services you might run. and it is not needed to play with this file.
danger? no - i didnt mention this at all.
Back to top
View user's profile Send private message
mc_barron
Apprentice
Apprentice


Joined: 28 Aug 2003
Posts: 230
Location: Chicago, IL

PostPosted: Tue Mar 15, 2005 11:10 pm    Post subject: Reply with quote

hds wrote:
mc_barron wrote:
Why is it dangerous to modify the hosts.allow file?

where did i say it would be dangerous 8O
mind quoting me on that?


You said:
hds wrote:
'xcuse me, but normally everyone would like to let his hosts.allow all by itsef, no?

...and then followed it with a "shocked" smiley face. Generally speaking, when someone begins an english sentence with "excuse me" it is sarcastic in nature and intended to infer shock or disdain at the idea you are responding to. The 'shocked' smiley face seemed to support this interpretation. Since I only suggested that he edit the /etc/hosts.allow file I was left to conclude that you disagreed with my suggestion.

Even if I ignore the "excuse me" part, you (in broken english, which is understandable since you appear to be a native german speaker) say "but normally everyone would like to let his hosts.allow all by itself". I interpreted this to be equivalent to the english sentence "but usually people would like to leave their hosts.allow file untouched".

Ok, so you see now that I thought you disagreed with my idea. There are two reasons to disagree with a suggestion in these forums: (1) it is dangerous or (2) it is not elegant. Since you seemed shocked at my suggestion I concluded that you thought that editing the /etc/hosts.allow file could cause possible harm (option #1).

I would suggest you reconsider your use of inflamatory language (such as "f*cking") in these forums, particularly in topics that are asking for help or advice. Language like that has it's place in several places in this forum ("Off the Wall" comes to mind, where frank conversation is the norm), but not in threads that are seeking help. The original poster is not looking for a flame war, just some good advice that will help them find a solution to their problem.
Back to top
View user's profile Send private message
omnicloud
Guru
Guru


Joined: 10 Mar 2005
Posts: 550
Location: California

PostPosted: Wed Mar 16, 2005 12:02 am    Post subject: Reply with quote

Change your auth method to cookie, login as root, then do an sql query with this, being sure to change pmapass and pma to your pma user and password

Code:

GRANT USAGE ON mysql.* TO 'pma'@'localhost' IDENTIFIED BY 'pmapass';
GRANT SELECT (
    Host, User, Select_priv, Insert_priv, Update_priv, Delete_priv,
    Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv,
    File_priv, Grant_priv, References_priv, Index_priv, Alter_priv,
    Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv,
    Execute_priv, Repl_slave_priv, Repl_client_priv
    ) ON mysql.user TO 'pma'@'localhost';
GRANT SELECT ON mysql.db TO 'pma'@'localhost';
GRANT SELECT ON mysql.host TO 'pma'@'localhost';
GRANT SELECT (Host, Db, User, Table_name, Table_priv, Column_priv)
    ON mysql.tables_priv TO 'pma'@'localhost';
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum