Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openssl-0.9.6d error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
mcdeth
n00b
n00b


Joined: 16 May 2002
Posts: 3

PostPosted: Tue May 21, 2002 5:17 pm    Post subject: openssl-0.9.6d error Reply with quote

Hi!

I have tried installing gentoo on ultra sparc 10 workstation,
everytime install fails on emerge system everything prior that goes
as documented. Has anyone noticed any problems with openssl-0.9.6d?
Seems to me that emerge misses openssl.so.0.9.6 file or what does
this error message mean? Even if it says (no error message) still
my installation drops dead.

+ gcc .so.0.9.6 -shared -o libcrypto.so.0.9.6 -Wl,-soname=libcrypto.so.0.9.6 -Wl,-Bsymbolic -Wl,--whole-archive libcrypto.a -Wl,--no-whole-archive -L. -lc
gcc: .so.0.9.6: No such file or directory
make[2]: *** [do_gnu-shared] Error 1
make[2]: Leaving directory `/var/tmp/portage/openssl-0.9.6d/work/openssl-0.9.6d'
make[1]: *** [libcrypto] Error 2
make[1]: Leaving directory `/var/tmp/portage/openssl-0.9.6d/work/openssl-0.9.6d'
make: *** [sub_all] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 3, Exitcode 2
!!! (no error message)
Back to top
View user's profile Send private message
rgc
n00b
n00b


Joined: 24 Apr 2002
Posts: 13
Location: Switzerland

PostPosted: Thu May 30, 2002 10:47 pm    Post subject: openssl-0.9.6d error Reply with quote

This is a me too I'm afraid. :-(

I really hope someone has a fix for this soon.
Back to top
View user's profile Send private message
hooperman
n00b
n00b


Joined: 29 May 2002
Posts: 3
Location: England

PostPosted: Wed Jun 05, 2002 10:24 am    Post subject: Reply with quote

:roll:
I have the same problem and I am sure it is as problem with openssl0.9.6d as with a bit of poking about openssl0.9.6c will build, I have not managed to fool portage into using 0.9.6c instead of 0.9.6d for any builds.

The Make script in 0.9.6d is broken for Sparc so we probably need to talk to the openssl people.
Back to top
View user's profile Send private message
rgc
n00b
n00b


Joined: 24 Apr 2002
Posts: 13
Location: Switzerland

PostPosted: Thu Jun 06, 2002 10:43 am    Post subject: subject: openssl-0.9.6d error Reply with quote

Ok, as there seems to be no solution for this problem I wanted to
see if the previous openssl version would build. I added:

# problem with openssl
=dev-libs/openssl-0.9.6d

to /usr/portage/profiles/package.mask

emerge system then complained because openssh requires
openssl-0.9.6d. I had to go back 2 versions of openssh by
adding:

# can't use latest openssh due to openssl problem above
>=net-misc/openssh-3.2.2_p1

to package.mask. My emerge system is still underway but it
has gone way passt openssl and openssh. I really do want to
try gentoo sparc. :-)
Back to top
View user's profile Send private message
beezly
n00b
n00b


Joined: 06 Jun 2002
Posts: 1

PostPosted: Thu Jun 06, 2002 5:06 pm    Post subject: Reply with quote

I'm also seeing this problem. There doesn't appear to be anywhere to log Gentoo/Sparc bugs. Is this something which is to be added or am I just missing something?!
Back to top
View user's profile Send private message
hooperman
n00b
n00b


Joined: 29 May 2002
Posts: 3
Location: England

PostPosted: Mon Jun 10, 2002 11:14 am    Post subject: Down grade to OpenSSL0.9.6.c Reply with quote

Good idea to use the package.mask file. I gave it a go but ran into Postfix compile problem where it askes for functions in the OpenSSL library that arn't supported. Has anybody had any luck fixing this??
Back to top
View user's profile Send private message
squash
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jun 2002
Posts: 79

PostPosted: Mon Jun 24, 2002 3:27 pm    Post subject: Work around for bug Reply with quote

Sorry, this post used to contain directions for working around the openssl error, but they turned out to not actually work!
I was able to compile and install openssl 09.7 beta2, and am now recompiling kdebase to see if konqueror can view ssl pages!
I'll post an update when it is finished.
Back to top
View user's profile Send private message
jjacocks
n00b
n00b


Joined: 26 Jun 2002
Posts: 28

PostPosted: Wed Jul 03, 2002 8:46 pm    Post subject: Re: Work around for bug Reply with quote

squash wrote:
Sorry, this post used to contain directions for working around the openssl error, but they turned out to not actually work!
I was able to compile and install openssl 09.7 beta2, and am now recompiling kdebase to see if konqueror can view ssl pages!
I'll post an update when it is finished.


Actually, they DID work for me...Would you please post them, at least for revision?
Back to top
View user's profile Send private message
sroethig
n00b
n00b


Joined: 04 Jul 2002
Posts: 2

PostPosted: Thu Jul 04, 2002 9:52 am    Post subject: Re: subject: openssl-0.9.6d error Reply with quote

i´ve compiled the system with the following changes to "packages"


*>=dev-libs/openssl-0.9.6
*>=net-misc/openssh-3.1_p1


Sven
Back to top
View user's profile Send private message
thalavoy
n00b
n00b


Joined: 03 Jul 2002
Posts: 2

PostPosted: Fri Jul 05, 2002 6:43 am    Post subject: Reply with quote

This is what I did. (approximated but you will know what needs to be changed)

After getting openssl*gz file and after unpacking it, I stopped (^Z) the 'emerge system' process.
Then I cd to /var/tmp/portage/openssl*/work
Then I edited the Makefile, to change the LD*EXTS to have the value of the one in LD*FLAGS, some where in the Makefile.
(as it is over now, i dont have the exact procedure).
Now resume (fg) the emerge system process. Now all is fine.
I am having trouble with ypbind. It is not able to bind to a Solaris NIS network.

:-Siva
Back to top
View user's profile Send private message
hooperman
n00b
n00b


Joined: 29 May 2002
Posts: 3
Location: England

PostPosted: Wed Jul 24, 2002 8:30 am    Post subject: OpenSSL Reply with quote

You will all be pleased to hear that this problem has been fixed in the latest ebuild, see the ChangeLog.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum