Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
smartlink soft modem and wvdial not working [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Double
Apprentice
Apprentice


Joined: 23 Apr 2004
Posts: 250
Location: Kislovodsk, Russia

PostPosted: Mon Feb 21, 2005 12:20 pm    Post subject: smartlink soft modem and wvdial not working [SOLVED] Reply with quote

господа есть проблема с настройкой внутреннего модема
имеем ноутбук toshiba SP30 и внутренний модем который minicom видит и сам модем на AT-команды отвечает нармально но wvdial этот модем видеть в упор отказывается

1. находим модем:

Code:
double / # lspci -vv | less
000:00:1f.6 Modem: Intel Corporation
82801DB/DBL/DBM(ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03) (prog-if 00 [Generic])
    Subsystem: Toshiba America Info Systems: Unknown device 0001
    Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
    Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
    Interrupt: pin B routed to IRQ 4
    Region 0: I/O ports at 2400
    Region 1: I/O ports at 2000 [size=128]
    Capabilities: [50] Power Management version 2
            Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
            Status: D0 PME-Enable- DSel=0 DScale=0 PME-


2. выясняем что это на самом деле SmartLink Soft Modem
3. устанавливаем драйвер

Code:
emerge slmodem


4. правим /etc/conf.d/slmodem под себя

Code:
double / # cat /etc/conf.d/slmodem | grep -v "\#"
DEV=/dev/ttySL0
COUNTRY=RUSSIA
GROUP=dialout
LN_DEV=/dev/modem
NICE=-6
MODULE=slamr
double / #


5. запускаем програму slmodem_test

Code:
slmodem_test
SmartLink Soft Modem: version 2.9.9 Feb 19 2005 15:07:20
<464.430274> SmartLink Soft Modem: version 2.9.9 Feb 19 2005 15:07:20
<464.430363> modemA: startup modem...
<464.430375> modemA: update termios...
main: created modemA: /dev/pts/2
SmartLink Soft Modem: version 2.9.9 Feb 19 2005 15:07:20
<464.430442> SmartLink Soft Modem: version 2.9.9 Feb 19 2005 15:07:20
<464.430483> modemB: startup modem...
<464.430494> modemB: update termios...
main: created modemB: /dev/pts/3


и так пока не нажать "Ctrl+C"

Code:
main: signal 2: mark termination.
<913.481174> modemA: modem_delete...
<913.481211> modemB: modem_delete...


(я так понимаю это просто тестовое/проверчное создание устройства)

6. загруженные модули до запуска slmodemd

Code:
double root # lsmod
Module                  Size  Used by
toshiba_acpi            5012  0
toshiba                 4248  0
serport                 3328  0
parport_pc             22468  0
parport                20800  1 parport_pc
psmouse                20104  0
firmware_class          7808  0
e100                   32640  0
nvidia               3463420  0
snd_intel8x0           29088  0
snd_ac97_codec         74464  1 snd_intel8x0
double root #


6. запускаем ct/etc/init.d/slmodem

Code:
double root # /etc/init.d/slmodem start
* Waiting for slamr modem driver initialisation
                 [ ok ]
* Starting slmodemd for /dev/ttySL0...
                 [ ok ]


проверяем нормально ли подгрузился модуль

Code:
double root # lsmod
Module                  Size  Used by
slamr                 373700  2
toshiba_acpi            5012  0
toshiba                 4248  0
serport                 3328  0
parport_pc             22468  0
parport                20800  1 parport_pc
psmouse                20104  0
firmware_class          7808  0
e100                   32640  0
nvidia               3463420  0
snd_intel8x0           29088  0
snd_ac97_codec         74464  1 snd_intel8x0


проверяем правильность создания ссылок

Code:
double root #ls -la /dev/modem
lrwxrwxrwx  1 root root 11 Фев 19 15:48 /dev/modem -> /dev/ttySL0
double dev # ls -la /dev/ttySL0
lrwxrwxrwx  1 root root 10 Фев 19 15:48 /dev/ttySL0 -> /dev/pts/2
double dev # ls -la /dev/pt
double dev # ls -la /dev/pts/2
crw-rw----  1 root dialout 136, 2 Фев 19 15:48 /dev/pts/2
double dev #


вроде все нормально модуль подгрузился устройство создалось слыка /dev/modem указывает правильно

7. запускаем minicom и указываем порт

Code:
double dev # cat /etc/minicom/minirc.dfl | grep -v "\#"
pr port             /dev/modem
pu baudrate         115200
pu minit
pu downdir          /home/double/download
pu backspace        DEL
double dev #


8. посылаем модему AT-команды и смотрим как он на енто эрагирует:

Code:
atz
OK
ati0
SmartLink Soft Modem
OK
ati1
SmartLink Soft Modem, 2.9.9
Smart Link Ltd.
OK
ati3
/dev/slamr0
modemap driver
OK
ati4
s00=000 s01=000 s02=043 s03=013 s04=010 s05=008 s06=002 s07=060
s08=002 s09=006 s10=007 s11=100 s12=050 s13=001 s14=000 s15=001
s16=001 s17=000 s18=000 s19=000 s20=000 s21=000 s22=000 s23=000

OK
ati7
Country: RUSSIA


9. устанавливаем wvdial и запускаем wvdialconf

Code:
double double # wvdialconf /etc/wvdial.conf
Scanning your serial ports for a modem.

Port Scan<*1>: S0   S1   S2   S3   S4   S5   S6   S7
ttySL0<Info>: Cannot get information for serial port.
Port Scan<*1>: SL0

Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wvdial/

If you still have problems, send mail to wvdial-list@lists.nit.ca.
double double #


и вот тут непонятно то ли лыжи не едут толи одно из двух
почему minicom модем видит нармаль а wvdial нет?
что можно сделать чтобы все таки запустиь wvdial?
ваабще есть какие нить здравые идеи?


Last edited by Double on Thu Mar 17, 2005 3:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
motaboy
Developer
Developer


Joined: 15 Dec 2003
Posts: 1483

PostPosted: Sat Mar 05, 2005 5:41 pm    Post subject: Reply with quote

It should be already fixed with wvstreams-4.0.1-r1.ebuild
Look also at bugs #79897 and #79913.
_________________
...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum