Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wine amd64 ebuild
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11  
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
ar3ac
n00b
n00b


Joined: 30 Nov 2004
Posts: 25

PostPosted: Mon Jan 30, 2006 6:35 pm    Post subject: Reply with quote

Hi there ,
i have installed wine 0.9.5 with the ebuild on portage , when i try to run an application the message is this :

This program tried to use a DOMDocument object, but
libxml2 support was not present at compile time.

so someone can help me ?

bye

ar3ac
Back to top
View user's profile Send private message
ttuegel
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 176
Location: Illinois, USA

PostPosted: Mon Jan 30, 2006 10:59 pm    Post subject: Reply with quote

ar3ac wrote:
Hi there ,
i have installed wine 0.9.5 with the ebuild on portage , when i try to run an application the message is this :

This program tried to use a DOMDocument object, but
libxml2 support was not present at compile time.


Make sure you compiled wine with the "xml2" USE flag set.
Back to top
View user's profile Send private message
ar3ac
n00b
n00b


Joined: 30 Nov 2004
Posts: 25

PostPosted: Tue Jan 31, 2006 4:31 pm    Post subject: Reply with quote

ttuegel wrote:

Make sure you compiled wine with the "xml2" USE flag set.


Code:

# equery u wine
[ Searching for packages matching wine... ]
[ Colour Code : set unset ]
[ Legend        : Left column  (U) - USE flags from make.conf  ]
[                  : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for app-emulation/wine-0.9.5-r1 ]
 U I
 + + X        : Adds support for X11
 + + alsa     : Adds support for media-libs/alsa-lib (Advanced Linux Sound Architecture)
 - - arts     : Adds support for aRts: the KDE sound daemon
 + + cups     : Add support for CUPS (Common Unix Printing System)
 - - debug    : Tells configure and the makefiles to build for debugging. Effects vary across packages, but generally it will at least add -g to CFLAGS. Remember to set FEATURES=nostrip too
 + + esd      : Adds support for media-sound/esound (Enlightened Sound Daemon)
 + + gif      : Adds GIF image support
 + + glut     : Build an OpenGL plugin using the GLUT library
 - - jack     : Adds support for the JACK Audio Connection Kit
 + + jpeg     : Adds JPEG image support
 + + lcms     : Adds lcms support (color management engine)
 + + ldap     : Adds LDAP support (Lightweight Directory Access Protocol)
 - - nas      : Adds support for network audio sound
 + + ncurses  : Adds ncurses support (console display library)
 + + opengl   : Adds support for OpenGL
 + + oss      : Adds support for OSS (Open Sound System)
 + + scanner  : Adds support for scanner hardware (e.g. build the sane frontend in kdegraphics)
 + + truetype : Adds support for FreeType and/or FreeType2 fonts
 + + xml2     : Check/Support flag for XML library (version 2)



so ?

bye

ar3ac
Back to top
View user's profile Send private message
user
Apprentice
Apprentice


Joined: 08 Feb 2004
Posts: 150

PostPosted: Mon Feb 13, 2006 12:11 am    Post subject: Reply with quote

hi,
i tried wine-0.9.7.ebuild but failed with this error:

Code:

...
make[3]: Leaving directory `/var/tmp/portage/wine-0.9.7/work/wine-0.9.7/dlls/ddraw/tests'
../../tools/winegcc/winegcc -B../../tools/winebuild -shared ./ddraw.spec    d3d_utils.o device_main.o device_opengl.o direct3d_main.o direct3d_opengl.o executebuffer.o light.o material.o opengl_u
tils.o texture.o vertexbuffer.o viewport.o clipper.o ddraw_hal.o ddraw_main.o ddraw_thunks.o ddraw_user.o ddraw_utils.o main.o palette_hal.o palette_main.o regsvr.o surface_dib.o surface_fakezbuf
fer.o surface_gamma.o surface_hal.o surface_main.o surface_thunks.o surface_user.o surface_wndproc.o  version.res   -o ddraw.dll.so -L../../dlls -L../../dlls/ole32 -L../../dlls/user32 -L../../dll
s/gdi32 -L../../dlls/advapi32 -L../../dlls/kernel32 -L../../dlls/ntdll -lole32 -luser32 -lgdi32 -ladvapi32 -lkernel32 -lntdll  -L../../libs/wine -lwine -ldxguid -luuid  -L/usr/lib64  -lSM -lICE -
lXxf86dga -lXxf86vm -lXext -lX11   -L../../libs/port -lwine_port 
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libm.so when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libm.a when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libc.a when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.4/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libc.a when searching for -lc
opengl_utils.o: In function `upload_surface_to_tex_memory_init':
/var/tmp/portage/wine-0.9.7/work/wine-0.9.7/dlls/ddraw/opengl_utils.c:909: undefined reference to `__wine_dbg_get_channel_flags'
collect2: ld returned 1 exit status
winegcc: x86_64-pc-linux-gnu-gcc failed.
make[2]: *** [ddraw.dll.so] Error 2
make[2]: Leaving directory `/var/tmp/portage/wine-0.9.7/work/wine-0.9.7/dlls/ddraw'
make[1]: *** [ddraw] Error 2
make[1]: *** Waiting for unfinished jobs....
...


so, i patch wine-0.9.7.ebuild like this:

Code:

--- wine-0.9.7.ebuild.old       2006-02-05 15:05:22.000000000 +0100
+++ wine-0.9.7.ebuild.new       2006-02-13 00:11:35.000000000 +0100
@@ -59,7 +59,10 @@
        sys-devel/flex"
 
 pkg_setup() {
+       export XLIBRARIES=
        use amd64 && has_multilib_profile && export ABI=x86
+       use amd64 && has_multilib_profile && append-ldflags -m32
+       use amd64 && has_multilib_profile && export XLIBRARIES="--x-libraries=/emul/linux/x86/usr/lib32"
 }
 
 src_unpack() {
@@ -109,6 +112,7 @@
        econf \
                CC=$(tc-getCC) \
                --sysconfdir=/etc/wine \
+               ${XLIBRARIES} \
                $(use_with ncurses curses) \
                $(use_with opengl) \
                $(use_with X x) \


and now i have 32bit wine under 64bit
Code:

$ uname -srvmiop
Linux 2.6.15-ck4 #1 Sun Feb 12 00:45:35 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3500+ AuthenticAMD GNU/Linux
$ ll /usr/bin/wine*
-rwxr-xr-x   1 root root   4980 Feb 13 07:44 /usr/bin/wine
-rwxr-xr-x   1 root root  18716 Feb 13 07:44 /usr/bin/wine-kthread
-rwxr-xr-x   1 root root   9604 Feb 13 07:44 /usr/bin/wine-preloader
-rwxr-xr-x   1 root root   6840 Feb 13 07:44 /usr/bin/wine-pthread
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/wineboot
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/winebrowser
-rwxr-xr-x   1 root root  93052 Feb 13 07:44 /usr/bin/winebuild
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/winecfg
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/wineconsole
lrwxrwxrwx   1 root root      7 Feb 13 07:44 /usr/bin/winecpp -> winegcc
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/winedbg
-rwxr-xr-x   1 root root  89404 Feb 13 07:44 /usr/bin/winedump
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/winefile
lrwxrwxrwx   1 root root      7 Feb 13 07:44 /usr/bin/wineg++ -> winegcc
-rwxr-xr-x   1 root root  23140 Feb 13 07:44 /usr/bin/winegcc
-rwxr-xr-x   1 root root  17736 Feb 13 07:44 /usr/bin/winelauncher
-rwxr-xr-x   1 root root  58999 Feb 13 07:44 /usr/bin/winemaker
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/winemine
-rwxr-xr-x  16 root root   1582 Feb 13 07:44 /usr/bin/winepath
-rwxr-xr-x   1 root root   5609 Feb 13 07:44 /usr/bin/wineprefixcreate
-rwxr-xr-x   1 root root 267552 Feb 13 07:44 /usr/bin/wineserver
-rwxr-xr-x   1 root root   6073 Feb 13 07:44 /usr/bin/wineshelllink
$ file /usr/bin/wine
/usr/bin/wine: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.4.1, dynamically linked (uses shared libs), stripped
$ file /usr/bin/wineserver
/usr/bin/wineserver: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), for GNU/Linux 2.4.1, dynamically linked (uses shared libs), stripped
$ ldd /usr/bin/wine     
        linux-gate.so.1 =>  (0xffffe000)
        libwine.so.1 => /usr/lib32/libwine.so.1 (0x55583000)
        libpthread.so.0 => /lib32/tls/libpthread.so.0 (0x5559d000)
        libc.so.6 => /lib32/tls/libc.so.6 (0x555af000)
        libdl.so.2 => /lib32/libdl.so.2 (0x556c6000)
        /lib/ld-linux.so.2 (0x55555000)
$ ldd /usr/bin/wineserver
        linux-gate.so.1 =>  (0xffffe000)
        libwine.so.1 => /usr/lib32/libwine.so.1 (0x55583000)
        libwine_unicode.so.1 => /usr/lib32/libwine_unicode.so.1 (0x5559d000)
        libc.so.6 => /lib32/tls/libc.so.6 (0x55693000)
        libdl.so.2 => /lib32/libdl.so.2 (0x557aa000)
        /lib/ld-linux.so.2 (0x55555000)
$ /usr/bin/wine --version
Wine 0.9.7
$
Back to top
View user's profile Send private message
RaZoR1394
Guru
Guru


Joined: 09 Jan 2005
Posts: 356

PostPosted: Sat Mar 04, 2006 3:26 pm    Post subject: Reply with quote

ttuegel wrote:
RaZoR1394 wrote:
Yeah, I had a major problem but it was not because of a profile change but rather a change from stable amd64 to testing amd64 (~amd64) and probably also a gcc upgrade. It was a major process to fix it by following several guides and using my own tricks but I finally did it and haven't experienced any problems since. Obviously one or more problems still persist like the wine one. I would probably reinstall if there was something like Jackass. Maybe another profile upgrade could fix it (to 2005.1)?


This isn't an ~amd64 problem. I've been ~amd64 all along and my fresh install was, too.

I don't know that anything would get fixed in the 2005.0->2005.1 upgrade, though. I did my fresh install with 2005.1-r1, however, and it seems to work. I'm convinced that the problem occured when I did the big profile upgrade, because this seems to be library related (the problem is gcc linking against the wrong type of library). I had to do it manually because the automatic script didn't work, which may be an indication that my machine was set up incorrectly to begin with.

I say "it seems to work" because I haven't tested wine; I don't have all the other critical pieces of software installed on my machine yet, which is my top priority right now. However, it compiles cleanly, which suggests to me that it will run at least as well as it ever did before.


Yes I know It isn't an ~amd64 issue but the thing is that when moving to ~amd64 I had to perform several steps including some from the profile upgrade guide to fix my problems.

Anyway, I see that one of your patches have made into portage but I'm still having the same problem and I'm not so keen on reinstalling :(. I did however move to 2006.0 yesterday.

edit:

They removed the patch after 0.9.6. It's no longer present in versions after that one. But I think that they should also have followed your modifications in the ebuild. The other one of your patch applies to the newest wine-0.9.9 but it fails compiling. I'll look into that now.

edit2:

Just applied the changes from your previous ebuilds and used your second patch. Works perfectly now.

I put it here for those who still need it.
_________________
http://en.wikipedia.org/wiki/Cell_(microprocessor)


Last edited by RaZoR1394 on Sat Mar 04, 2006 4:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jimmy Jazz
Guru
Guru


Joined: 04 Oct 2004
Posts: 302
Location: Strasbourg

PostPosted: Sat Mar 04, 2006 4:14 pm    Post subject: Reply with quote

Hello,

Have anybody managed to get their network (cups) printer working with wine 0.9.9 ?

I cannot make it work anymore even if i modify manually the wine registries :(

I have cups 32bits libraries in the /usr/lib32 directory.

Code:

libcupsimage.so -> libcupsimage.so.2
libcups.so -> libcups.so.2
libcups.so
libcupsimage.so


That is really a pity... What is more important than printing after games :)

Jj
_________________
« La seule condition au triomphe du mal, c'est l'inaction des gens de bien » E.Burke
Code:

+----+----+----+
|    |::::|    |
|    |::::|    |
+----+----+----+

motto: WeLCRO
WritE Less Code, Repeat Often
Back to top
View user's profile Send private message
micko
Tux's lil' helper
Tux's lil' helper


Joined: 16 Dec 2004
Posts: 121
Location: Finland / Turku

PostPosted: Fri Mar 10, 2006 8:25 am    Post subject: Reply with quote

Err... This is perhaps a stupid question, but do 32bit Windows progs run under 64bit Wine?
Back to top
View user's profile Send private message
SoTired
Apprentice
Apprentice


Joined: 19 May 2004
Posts: 174

PostPosted: Fri Mar 10, 2006 8:34 am    Post subject: Reply with quote

micko wrote:
Err... This is perhaps a stupid question, but do 32bit Windows progs run under 64bit Wine?


Yes.
Back to top
View user's profile Send private message
stobbsm
Guru
Guru


Joined: 23 May 2004
Posts: 452

PostPosted: Fri Mar 10, 2006 2:28 pm    Post subject: Reply with quote

I'm compiling wine 0.98-r1 as we speak, and can't wait to see if it play's WOW with the new patch without problems. If that's the case, I can stop paying for Cedega.
_________________
Sysadmin of Ubuntu systems and servers....
Although my own server is gentoo....
Back to top
View user's profile Send private message
ttuegel
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 176
Location: Illinois, USA

PostPosted: Fri Mar 10, 2006 3:37 pm    Post subject: Reply with quote

micko wrote:
Err... This is perhaps a stupid question, but do 32bit Windows progs run under 64bit Wine?


Keep in mind that even on an amd64 system, the wine ebuild still only compiles a 32-bit version of Wine. There will eventually be a 64-bit version of Wine which is compatible with the 64-bit version of Windows, but not yet.
Back to top
View user's profile Send private message
joker
l33t
l33t


Joined: 03 May 2003
Posts: 681
Location: www

PostPosted: Sat Mar 11, 2006 6:32 pm    Post subject: Reply with quote

stobbsm wrote:
I'm compiling wine 0.98-r1 as we speak, and can't wait to see if it play's WOW with the new patch without problems. If that's the case, I can stop paying for Cedega.


I'm using wine 0.9.5 for WoW, if you get WoW working on 0.9.8 or 0.9.9, let us know :)
_________________
http://amarok.org.pl | http://koffice.org.pl | http://kde.org.pl
Back to top
View user's profile Send private message
Plouj
n00b
n00b


Joined: 01 Mar 2005
Posts: 12

PostPosted: Tue Apr 25, 2006 3:40 am    Post subject: Reply with quote

I didn't bother checking the whole 11 pages of this thread if this was stated already, but wine is pretty easy to get working without an ebuild with just the source code.

First, you obtain the code from wine's download links (http://sourceforge.net/project/showfiles.php?group_id=6241&package_id=77449) or from wine's CVS (http://winehq.com/site/cvs)
then, you build it according to this: http://wiki.winehq.org/WineOn64bit?highlight=Gentoo
Wine is able to run from the source directory by using a wrapper script. If you compiled your wine like me in ~/apps/wine-0.9.12/ then you can run your win32 apps like
Code:
~/apps/wine-0.9.12/wine <appname.exe>
Back to top
View user's profile Send private message
ttuegel
Apprentice
Apprentice


Joined: 18 Jan 2005
Posts: 176
Location: Illinois, USA

PostPosted: Tue Apr 25, 2006 4:35 am    Post subject: Reply with quote

Plouj wrote:
I didn't bother checking the whole 11 pages of this thread if this was stated already, but wine is pretty easy to get working without an ebuild with just the source code.


Wine has been easy to get working with the ebuild now, too, at least from the compilation side of things. I haven't had any problems with it recently, and the thread's been pretty inactive. Now, getting wine to compile and run, it should be noted, isn't the same as getting it to run all one's favorite programs well :roll:.
Back to top
View user's profile Send private message
erebus
n00b
n00b


Joined: 17 May 2002
Posts: 49
Location: United Kingdom

PostPosted: Fri Apr 28, 2006 12:52 pm    Post subject: Reply with quote

For some reason World of Warcraft seems to hard locking my machine, I can't even ssh/ping the machine.
I can log in to a character but the game locks as soon as character starts to appear!

I've tried using both wine (0.9.12 + patches from appdb.winehq.com) and cedega (5.1/5.3) and both have the same problem. I've tried downgrading my nvidia drivers (8174 8178 1.0.8756), running the game with out sound (rmmod all the alsa modules) and the problem still remains.
Wine/Cedega both work o.k. with applications such as winamp and mozilla and the native version of Quake3 works just fine.
World of warcraft also works fine on my Windows partition (using exactly the same hardware).

*edit* I've also tried installing Quake3 on Cedega and it works fine with no problems *edit*

After trying all these thing I'm not the wiser as to what the problem is or how to work out whats causing the problem, none of my logs show anything untoward.

As the machine "hard locks" I would have thought a hardware problem, but as Quake3 runs fine in Linux and World of Warcraft works fine in Windows I doubt this is the case.

Can anyone suggest what my next step to diagnosing the problem should be?
Back to top
View user's profile Send private message
arabis
Apprentice
Apprentice


Joined: 11 Apr 2005
Posts: 195
Location: Québec, Canada

PostPosted: Wed May 03, 2006 10:55 pm    Post subject: Reply with quote

I am on amd64, 64 bits with all the emul libraries installed. I have emerged successfully wine-0.9.12, except for one thing: opengl support.
At the beginning of the emerge process, config doesn't find the presence of GL headers
Code:
checking for GL/gl.h... no
checking for GL/glx.h... no
checking for GL/glext.h... no
checking for GL/glu.h... no

But, I have these headers in /usr/include/GL/, but they link to lib64.
and, I have 32bits version of these (except for glu.h) in /emul/linux/x86/usr/lib/opengl/xorg-x11/include/.
How can I correct this and give to the ebuild the right location of headers and
How others amd64 users doesn't have the same issues.
Any idea? :?
_________________
Acer Ferrari 4002 WLMI fr
AMD64, Turion ML-30
ATI Mobility X700
DVDR double couche
Back to top
View user's profile Send private message
_loKi
n00b
n00b


Joined: 30 May 2006
Posts: 16

PostPosted: Tue Jun 13, 2006 6:16 pm    Post subject: Error compiling wine after gcc upgrade Reply with quote

Hi , i upgraded gcc to 4.1 accordingly to the official gentoo.org article but now wine fails to compile. There are two libs from glibc that fail to link or whatever i'm pasting the log from emerge.
Code:
/usr/include/gentoo-multilib/x86/bits/confname.h:575: error: previous definition of '_CS_POSIX_V6_ILP32_OFF32_LINTFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:577: error: redeclaration of enumerator '_CS_POSIX_V6_ILP32_OFFBIG_CFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:577: error: previous definition of '_CS_POSIX_V6_ILP32_OFFBIG_CFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:579: error: redeclaration of enumerator '_CS_POSIX_V6_ILP32_OFFBIG_LDFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:579: error: previous definition of '_CS_POSIX_V6_ILP32_OFFBIG_LDFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:581: error: redeclaration of enumerator '_CS_POSIX_V6_ILP32_OFFBIG_LIBS'
/usr/include/gentoo-multilib/x86/bits/confname.h:581: error: previous definition of '_CS_POSIX_V6_ILP32_OFFBIG_LIBS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:583: error: redeclaration of enumerator '_CS_POSIX_V6_ILP32_OFFBIG_LINTFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:583: error: previous definition of '_CS_POSIX_V6_ILP32_OFFBIG_LINTFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:585: error: redeclaration of enumerator '_CS_POSIX_V6_LP64_OFF64_CFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:585: error: previous definition of '_CS_POSIX_V6_LP64_OFF64_CFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:587: error: redeclaration of enumerator '_CS_POSIX_V6_LP64_OFF64_LDFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:587: error: previous definition of '_CS_POSIX_V6_LP64_OFF64_LDFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:589: error: redeclaration of enumerator '_CS_POSIX_V6_LP64_OFF64_LIBS'
/usr/include/gentoo-multilib/x86/bits/confname.h:589: error: previous definition of '_CS_POSIX_V6_LP64_OFF64_LIBS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:591: error: redeclaration of enumerator '_CS_POSIX_V6_LP64_OFF64_LINTFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:591: error: previous definition of '_CS_POSIX_V6_LP64_OFF64_LINTFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:593: error: redeclaration of enumerator '_CS_POSIX_V6_LPBIG_OFFBIG_CFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:593: error: previous definition of '_CS_POSIX_V6_LPBIG_OFFBIG_CFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:595: error: redeclaration of enumerator '_CS_POSIX_V6_LPBIG_OFFBIG_LDFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:595: error: previous definition of '_CS_POSIX_V6_LPBIG_OFFBIG_LDFLAGS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:597: error: redeclaration of enumerator '_CS_POSIX_V6_LPBIG_OFFBIG_LIBS'
/usr/include/gentoo-multilib/x86/bits/confname.h:597: error: previous definition of '_CS_POSIX_V6_LPBIG_OFFBIG_LIBS' was here
/usr/include/gentoo-multilib/amd64/bits/confname.h:601: error: redeclaration of enumerator '_CS_POSIX_V6_LPBIG_OFFBIG_LINTFLAGS'
/usr/include/gentoo-multilib/x86/bits/confname.h:601: error: previous definition of '_CS_POSIX_V6_LPBIG_OFFBIG_LINTFLAGS' was here
make[2]: *** [ffs.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/wine-0.9.15-r1/work/wine-0.9.15/libs/port'
make[1]: *** [port] Error 2
make[1]: Leaving directory `/var/tmp/portage/wine-0.9.15-r1/work/wine-0.9.15/libs'
make: *** [libs] Error 2

!!! ERROR: app-emulation/wine-0.9.15-r1 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  wine-0.9.15-r1.ebuild, line 120:   Called die

I don't know what is the problem? I tried to recompile gcc or downgrading but it doesnt help. fix_libtool_files.sh didn't help. Someone has advice?[/code]
_________________
loKi(home-server) : 2.6.15-gentoo-r3 , i686 Pentium III (Katmai)
Kathleen(desktop) : 2.6.16-ck10 , x86_64 AMD Athlon(tm) 64 Processor 3000+
You will be compiled. Resistance is futile.
Back to top
View user's profile Send private message
Luper
n00b
n00b


Joined: 28 Apr 2006
Posts: 11

PostPosted: Tue Jun 13, 2006 7:38 pm    Post subject: Reply with quote

Same errors as _loKi here with gcc 4.1.1 (tried both wine-0.9.13 and 0.9.15)

Code:
# emerge --info
Portage 2.1 (default-linux/amd64/2006.0, gcc-4.1.1/amd64-vanilla, glibc-2.3.6-r3, 2.6.16-gentoo-r9 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r9 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.6.14
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ABI="amd64"
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE=""
ALSA_CARDS="intel8x0"
ANT_HOME="/usr/share/ant-core"
ARCH="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-Os -march=athlon64 -fomit-frame-pointer -pipe -mfpmath=sse"
CFLAGS_x86="-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/grass60/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/conf
ig /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/
share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-Os -march=athlon64 -fomit-frame-pointer -pipe -mfpmath=sse"
DCCC_PATH="/usr/lib/distcc/bin"
DEFAULT_ABI="amd64"
DISPLAY=":0.0"
DISTCC_LOG=""
DISTCC_VERBOSE="0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_WARNING_DELAY="10"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -P ${DISTDIR} ${URI}"
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://
mir.zyrianes.net/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/downloa
d/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
GRASS_LD_LIBRARY_PATH="/usr/grass60/lib"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/root"
HOSTNAME="kawa"
HUSHLOGIN="FALSE"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.16.1/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.1/info:/usr/share/gcc-data/x86_64-pc-linu
x-gnu/4.1.1/info"
INPUT_DEVICES="keyboard mouse"
JAVAC="/opt/sun-jdk-1.5.0.06/bin/javac"
JAVA_HOME="/opt/sun-jdk-1.5.0.06"
JDK_HOME="/opt/sun-jdk-1.5.0.06"
KDEDIRS="/usr"
KERNEL="linux"
LANG="fr_FR.UTF-8"
LANGUAGE="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS_x86="-m elf_i386 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_x86="lib32"
LINGUAS="fr"
LOGNAME="root"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:e
x=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;3
1:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;3
5:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01
;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.qt=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;3
5:*.xcf=01;35:*.xwd=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.flac=01;35:*.mp3=01;35:*.mpc=00;36:*.ogg=0
0;36:*.wav=00;36:*.mid=00;36:*.midi=00;36:*.au=00;36:*.flac=00;36:*.aac=00;36:"
MAKEOPTS="-j2"
MANPATH="/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.16.1/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.1/man:/usr/share/gcc-da
ta/x86_64-pc-linux-gnu/4.1.1/man::/opt/sun-jdk-1.5.0.06/man:/usr/qt/3/doc/man:/opt/vmware/workstation/man"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib /usr/lib /usr/kde/*/lib /usr/qt/*/lib /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
OLDPWD="/usr/portage/packages/All"
OPENGL_PROFILE="nvidia"
PAGER="/usr/bin/less"
PATH="/sbin:/bin:/usr/sbin:/usr/bin:~/bin"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc s390 amd64 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa x86"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib/portage/bin"
PORTAGE_CALLER="emerge"
PORTAGE_CONFIGROOT="/"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles
' --exclude='/local' --exclude='/packages'"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
PORT_LOGDIR="/var/log/portage"
PRELINK_PATH=""
PRELINK_PATH_MASK="/usr/NX:/usr/lib/gstreamer-0.10:/usr/lib/gstreamer-0.8"
PWD="/usr/lib32/nsbrowser/plugins"
PYTHONDOCS="/usr/share/doc/python-docs-2.4.2/html"
PYTHONPATH="/home/flupke/local/lib/python2.4/site-packages:/home/flupke/source/lib/python:/home/flupke/local/lib/python2.4/site-packages:/home/flupke/source/lib/python:
/home/flupke/local/lib/python2.4/site-packages:/home/flupke/source/lib/python:/usr/lib/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -P ${DISTDIR} ${URI}"
ROOT="/"
RPMDIR="/usr/portage/rpm"
SEARCH_DIRS_MASK="/usr/NX"
SHELL="/bin/bash"
SHLVL="6"
SSH_AGENT_PID="8654"
SSH_ASKPASS="/usr/bin/gtk2-ssh-askpass"
SSH_AUTH_SOCK="/tmp/ssh-QQTVqf8653/agent.8653"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
TERM="xterm"
USE="amd64 X a52 acl acpi alsa ao apache2 arts audiofile avi bash-completion berkdb bitmap-fonts bluetooth browserplugin bzip2 cairo cdr cli crypt cscope css cups dbus
dri dts dv dvd dvdr dvdread eds emboss encode enscript exif expat exscalibar extrafilters fame ffmpeg fftw fits flac foomaticdb fortran gdbm geos gif gimp glep glitz gm
l gnokii gnome gpm gps grass gsl gstreamer gtk gtk2 hal hdf hdf5 iconv ieee1394 imagemagick imlib iontruetype ipod ipv6 irda isdnlog jai java javascript jce jimi jpeg j
peg2k kde kdeenablefinal lcms lm_sensors lzo lzw lzw-tiff mad mikmod mjpeg mng motif mozilla mp3 mpeg mpm-prefork musepack musicbrainz mysql ncurses net netcdf network
nls nptl nsplugin nvidia ogdi ogg opengl pam pcre pdflib perl png postgres pppd proj python qt quicktime readline reflection sdl session silvercity sms sndfile spell sp
l sqlite ssl svg t1lib tcltk tcpd theora tiff timidity truetype truetype-fonts type1-fonts ucs2 unicode usb userlocales v4l v4l2 vcd vim-pager vim-with-x visualization
vorbis wmf xine xinerama xml xml2 xorg xpm xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_fr userland_GNU video_cards_nv video
_cards_nvidia video_cards_vesa"
USER="root"
USERLAND="GNU"
USE_EXPAND="DVB_CARDS ELIBC FCDSL_CARDS FRITZCAPI_CARDS INPUT_DEVICES KERNEL LINGUAS LIRC_DEVICES USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults"
VIDEO_CARDS="nv nvidia vesa"
WINDOWID="37748751"
XARGS="xargs -r"
XAUTHORITY="/root/.xauthH4ejYr"
XTERM_SHELL="/bin/bash"
XTERM_VERSION="XTerm(207)"
_="/usr/bin/emerge"
Back to top
View user's profile Send private message
_loKi
n00b
n00b


Joined: 30 May 2006
Posts: 16

PostPosted: Tue Jun 13, 2006 7:40 pm    Post subject: Reply with quote

I think i forgot to compile gcc and glibc as the multilib at the fresh start but now on gcc and glibc uselfag multilib has no effect and i heard multilib is enabled by default so this shouldnt be a problem?! I'm really helpless.
_________________
loKi(home-server) : 2.6.15-gentoo-r3 , i686 Pentium III (Katmai)
Kathleen(desktop) : 2.6.16-ck10 , x86_64 AMD Athlon(tm) 64 Processor 3000+
You will be compiled. Resistance is futile.
Back to top
View user's profile Send private message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Tue Jun 13, 2006 8:11 pm    Post subject: Reply with quote

You're not alone:

https://forums.gentoo.org/viewtopic-t-469718-highlight-.html
Back to top
View user's profile Send private message
_loKi
n00b
n00b


Joined: 30 May 2006
Posts: 16

PostPosted: Tue Jun 13, 2006 8:44 pm    Post subject: Reply with quote

Hey , thanks for helping me solved the problem , unmerging eselect-compiler solved it! :)
_________________
loKi(home-server) : 2.6.15-gentoo-r3 , i686 Pentium III (Katmai)
Kathleen(desktop) : 2.6.16-ck10 , x86_64 AMD Athlon(tm) 64 Processor 3000+
You will be compiled. Resistance is futile.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11
Page 11 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum