Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
falla el ping (solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
ebray187
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Sat Sep 09, 2006 7:03 pm    Post subject: falla el ping (solucionado) Reply with quote

Pues eso, me falla el ping. Si pongo ping www.google.cl en la consola me arroja esto:

Code:
# ping www.google.cl
ping: symbol lookup error: /usr/lib/libnss_wins.so.2: undefined symbol: dlopen


Ahora si compruebo mi red no hay problemas

Code:
# ping -c 3 192.168.0.2
PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.
64 bytes from 192.168.0.2: icmp_seq=1 ttl=128 time=0.317 ms
64 bytes from 192.168.0.2: icmp_seq=2 ttl=128 time=0.255 ms
64 bytes from 192.168.0.2: icmp_seq=3 ttl=128 time=0.246 ms

--- 192.168.0.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2012ms
rtt min/avg/max/mdev = 0.246/0.272/0.317/0.036 ms


con un equery vi que esa libreria pertenece a samba, aun reemergiendo samba y iputils no pasa nada. Ultimamente actualize a las gcc-4.1.1, internet funciona correctamente.

No encuentro ayuda en el foro, si alguien me puede ayudar lo agradeceria.

Saludos
_________________
# emerge -C world >> 9/8
A flower?!

www.elipsis.tk


Last edited by ebray187 on Sun Sep 10, 2006 11:24 pm; edited 2 times in total
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2946
Location: Valencia, Spain

PostPosted: Sat Sep 09, 2006 8:29 pm    Post subject: Reply with quote

Si te falta alguna libreria, tal vez revdep-rebuild te lo solucione
Code:
# revdep-rebuild
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1460

PostPosted: Sat Sep 09, 2006 8:32 pm    Post subject: Reply with quote

Posiblemente tu ISP te ha dejado de la mano de Dios.
¿Te ha funcionado antes esa conexion? o está recien creada.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
ebray187
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Sun Sep 10, 2006 3:11 am    Post subject: Reply with quote

Internet y samba funcionan correctamente.
# revdep-rebuild me a desamparado de esta.
No tengo idea que puede estar causando este problema especifico con ping.

Saludos
_________________
# emerge -C world >> 9/8
A flower?!

www.elipsis.tk
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1460

PostPosted: Sun Sep 10, 2006 7:27 am    Post subject: Reply with quote

Quote:
localhost esteban # equery b ping
[ Searching for file(s) ping in *... ]
net-misc/iputils-021109-r3 (/bin/ping)

Reinstala iputils a ver que pasa.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
ebray187
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Sun Sep 10, 2006 5:17 pm    Post subject: Reply with quote

esteban_conde wrote:
Quote:
localhost esteban # equery b ping
[ Searching for file(s) ping in *... ]
net-misc/iputils-021109-r3 (/bin/ping)

Reinstala iputils a ver que pasa.


Pues nada, arroja el mismo mensaje. :(

Saludos y gracias
_________________
# emerge -C world >> 9/8
A flower?!

www.elipsis.tk
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1460

PostPosted: Sun Sep 10, 2006 6:35 pm    Post subject: Reply with quote

averigua la direccion ip de cualquier página y hazle ping, si te da resultado positivo entonces es cosa de tu ordenador que no tiene tablas arp (o algo parecido) con nmap puedes averiguar las IPs simplemente con nmap www.tal_sitio.com.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
kalcetoh
Guru
Guru


Joined: 05 Jun 2005
Posts: 304

PostPosted: Sun Sep 10, 2006 6:51 pm    Post subject: Reply with quote

esteban_conde wrote:
averigua la direccion ip de cualquier página y hazle ping, si te da resultado positivo entonces es cosa de tu ordenador que no tiene tablas arp (o algo parecido) con nmap puedes averiguar las IPs simplemente con nmap www.tal_sitio.com.

Mejor con
Code:
host tal_sitio.com

por si no tienes el nmap.
Back to top
View user's profile Send private message
ebray187
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Sun Sep 10, 2006 7:01 pm    Post subject: Reply with quote

Pues ise lo que sugierieon y funcionó :o...

Code:
eduardo@HAL-9000 ~ $ nmap www.google.com

Starting Nmap 4.01 ( http://www.insecure.org/nmap/ ) at 2006-09-10 14:56 UTC
Interesting ports on 66.102.7.104:
(The 1668 ports scanned but not shown below are in state: filtered)
PORT    STATE  SERVICE
80/tcp  open   http
113/tcp closed auth
179/tcp closed bgp
443/tcp open   https

Nmap finished: 1 IP address (1 host up) scanned in 58.858 seconds

Code:
eduardo@HAL-9000 ~ $ ping -c 3 66.102.7.104
PING 66.102.7.104 (66.102.7.104) 56(84) bytes of data.
64 bytes from 66.102.7.104: icmp_seq=1 ttl=236 time=191 ms
64 bytes from 66.102.7.104: icmp_seq=2 ttl=236 time=171 ms
64 bytes from 66.102.7.104: icmp_seq=3 ttl=236 time=172 ms

--- 66.102.7.104 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1998ms
rtt min/avg/max/mdev = 171.800/178.727/191.845/9.280 ms

Code:
eduardo@HAL-9000 ~ $ ping -c 3 www.google.com
ping: symbol lookup error: /usr/lib/libnss_wins.so.2: undefined symbol: dlopen


Sin embargo sin la direccion ip no. ¿Que es eso de las tablas arp?

Saludos
_________________
# emerge -C world >> 9/8
A flower?!

www.elipsis.tk
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2946
Location: Valencia, Spain

PostPosted: Sun Sep 10, 2006 7:06 pm    Post subject: Reply with quote

ebray187 wrote:
¿Que es eso de las tablas arp?

No te preocupes que no tienen nada que ver con tu problema. Las tablas ARP solo se usan a nivel MAC. Para el ping a máquiinas fuera de tu LAN no se usan (salvo para encontrar la puerta de enlace, pero eso te está funcionando)
Back to top
View user's profile Send private message
kalcetoh
Guru
Guru


Joined: 05 Jun 2005
Posts: 304

PostPosted: Sun Sep 10, 2006 7:14 pm    Post subject: Reply with quote

Mira a ver a que paquete pertenece libnss_wins.so.2, e intenta reinstalarlo,
para ello usa
Code:
equery b /usr/lib/libnss_wins.so.2

equery está en el paquete gentoolkit.

Yo no tengo esa biblioteca pero todas las libnss_* que tengo pertenecen a glibc.
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2946
Location: Valencia, Spain

PostPosted: Sun Sep 10, 2006 7:20 pm    Post subject: Reply with quote

kalcetoh wrote:
Mira a ver a que paquete pertenece libnss_wins.so.2, e intenta reinstalarlo,
para ello usa
Code:
equery b /usr/lib/libnss_wins.so.2

equery está en el paquete gentoolkit.

Yo no tengo esa biblioteca pero todas las libnss_* que tengo pertenecen a glibc.

Segun dijo en el primer mensaje, eso ya está hecho y pertenece a samba. Yo tengo instalado samba y no me aparece esa librería :!:
Back to top
View user's profile Send private message
ebray187
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Sun Sep 10, 2006 10:23 pm    Post subject: Reply with quote

Borre la libreria /usr/lib/libnss_wins.so.2 y funcionó perfecto el ping. Reemergi samba, la volvio a instalar y denuevo el mismo problema. Samba parece funcionar sin ningún contratiempo sin ella así que de momento simplemente la borraré.

Stolz wrote:
Yo tengo instalado samba y no me aparece esa librería :!:


Cuales son tus USE? estos son los mios:
Code:
# emerge -pv samba
[ebuild   R   ] net-fs/samba-3.0.22-r3  USE="pam python readline -acl -async -automount -cups -doc -examples -kerberos -ldap -ldapsam -libclamav -mysql -oav -postgres -quotas -swat -syslog -winbind -xml" 0 kB


Saludos
_________________
# emerge -C world >> 9/8
A flower?!

www.elipsis.tk
Back to top
View user's profile Send private message
kalcetoh
Guru
Guru


Joined: 05 Jun 2005
Posts: 304

PostPosted: Sun Sep 10, 2006 10:58 pm    Post subject: Reply with quote

Stolz wrote:
Segun dijo en el primer mensaje, eso ya está hecho y pertenece a samba

Tengo que leer más concienzudamente antes de escribir.

Prueba con la última versión de samba, quien sabe.

Por ahí hay un post que no sé si te servirá de algo.
Back to top
View user's profile Send private message
ebray187
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2005
Posts: 97
Location: Al otro lado de la pantalla

PostPosted: Sun Sep 10, 2006 11:22 pm    Post subject: Reply with quote

Pues ese post dio al clavo con mi problema :D. Simplemente quite wins de mi nsswitch.conf y listo, ahora el ping funciona sin problemas, tambien samba y todo.

Muchas gracias a todos los que me ayudaron.
Saludos
_________________
# emerge -C world >> 9/8
A flower?!

www.elipsis.tk
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum