Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
8 бит цвета в Xorg [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
nerff
n00b
n00b


Joined: 20 Feb 2005
Posts: 50
Location: Novosibirsk

PostPosted: Sun Feb 20, 2005 5:07 am    Post subject: 8 бит цвета в Xorg [solved] Reply with quote

Доброго времени суток всем!
Столкнулся со странной вещью - драйвер NVidia работает только в 8 бит
кусок лога:
==========================
(II) Setting vga for screen 0.
(II) NVIDIA(0): Creating default Display subsection in Screen section
"Screen0" for depth/fbbpp 8/8
(==) NVIDIA(0): Depth 8, (==) framebuffer bpp 8
(==) NVIDIA(0): Default visual is PseudoColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xF0000000
(--) NVIDIA(0): MMIO registers at 0xF8000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce4 Ti 4200 with AGP8X
(--) NVIDIA(0): VideoBIOS: 04.28.84.21.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): VideoRAM: 131072 kBytes
+++++++++++++
При всем этом framebuffer отключен в ядре, форум читан, маны выкурены, все обновлено. Кто может подсказать где зарыты грабли?
NVidia-kernel и nvidia-glx ставил через emerge, также пробовал драйвер воткнуть руками - результат тот же

Буду очень благодарен


Last edited by nerff on Wed Feb 23, 2005 7:18 am; edited 1 time in total
Back to top
View user's profile Send private message
Double
Apprentice
Apprentice


Joined: 23 Apr 2004
Posts: 250
Location: Kislovodsk, Russia

PostPosted: Sun Feb 20, 2005 8:29 pm    Post subject: Re: 8 бит цвета в Xorg Reply with quote

cat /etx/X11/xorg.conf
в студию
Back to top
View user's profile Send private message
nerff
n00b
n00b


Joined: 20 Feb 2005
Posts: 50
Location: Novosibirsk

PostPosted: Mon Feb 21, 2005 3:24 am    Post subject: Xorg.conf Reply with quote

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/lib/X11/rgb"
ModulePath "/usr/lib/modules"

FontPath "/usr/share/fonts/cyrillic/"
FontPath "/usr/share/fonts/cronyx/misc/"
FontPath "/usr/share/fonts/cronyx/100dpi/"
FontPath "/usr/share/fonts/cronyx/75dpi/"
FontPath "/usr/share/fonts/terminus/"
FontPath "/usr/share/fonts/corefonts/"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/TTF/"
FontPath "/usr/share/fonts/Type1/"
FontPath "/usr/share/fonts/CID/"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
Load "glx"
Load "record"
Load "extmod"
Load "dbe"
Load "dri"
Load "xtrap"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us, ru(winkeys)"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "False"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
HorizSync 31.5 - 64.3
VertRefresh 50.0 - 90.0
EndSection

Section "Device"

### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "DigitalVibrance" # <i>
#Option "NoFlip" # [<bool>]
#Option "Dac8Bit" # [<bool>]
#Option "NoLogo" # [<bool>]
#Option "UBB" # [<bool>]
#Option "Stereo" # <i>
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "VideoKey" # <i>
#Option "NvAGP" # <i>
#Option "IgnoreEDID" # [<bool>]
#Option "NoDDC" # [<bool>]
#Option "ConnectedMonitor" # <str>
#Option "ConnectedMonitors" # <str>
#Option "TVStandard" # <str>
#Option "TVOutFormat" # <str>
#Option "RenderAccel" # [<bool>]
#Option "CursorShadow" # [<bool>]
#Option "CursorShadowAlpha" # <i>
#Option "CursorShadowXOffset" # <i>
#Option "CursorShadowYOffset" # <i>
#Option "UseEdidFreqs" # [<bool>]
#Option "FlatPanelProperties" # <str>
#Option "TwinView" # [<bool>]
#Option "TwinViewOrientation" # <str>
#Option "SecondMonitorHorizSync" # <str>
#Option "SecondMonitorVertRefresh" # <str>
#Option "MetaModes" # <str>
#Option "UseInt10Module" # [<bool>]
#Option "NoTwinViewXineramaInfo" # [<bool>]
#Option "NoRenderExtension" # [<bool>]
#Option "Overlay" # [<bool>]
#Option "CIOverlay" # [<bool>]
#Option "ForceEmulatedOverlay" # [<bool>]
#Option "TransparentIndex" # <i>
#Option "OverlayDefaultVisual" # [<bool>]
#Option "NvEmulate" # <i>
#Option "NoBandWidthTest" # [<bool>]
#Option "CustomEDID-CRT-0" # <str>
#Option "CustomEDID-CRT-1" # <str>
#Option "CustomEDID-DFP-0" # <str>
#Option "CustomEDID-DFP-1" # <str>
#Option "CustomEDID-TV-0" # <str>
#Option "CustomEDID-TV-1" # <str>
#Option "TVOverScan" # <f>
#Option "IgnoreDisplayDevices" # <str>
#Option "MultisampleCompatibility" # [<bool>]
#Option "RegistryDwords" # <str>
#Option "RegistryBinary" # <str>
#Option "NoPowerConnectorCheck" # [<bool>]
#Option "AllowDFPStereo" # [<bool>]
#Option "XvMCUsesTextures" # [<bool>]
#Option "HorizSync" # <str>
#Option "VertRefresh" # <str>
#Option "AllowGLXWithComposite" # [<bool>]
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV28 [GeForce4 Ti 4200 AGP 8x]"
# ChipSet "GeForce4 Ti 4200 with AGP8X"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
==================================================
GLX естественно, не грузится, ему надо как минимум 16 бит, в логах Xorg присутствует также:

(II) NVIDIA(0): Setting mode "1280x1024"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(EE) NVIDIA(0): Failed to load GLX
(==) RandR enabled
Symbol __glXgetActiveScreen from module /usr/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXgetActiveScreen from module /usr/lib/modules/extensions/libdri.a is unresolved!
Back to top
View user's profile Send private message
User Unknown
n00b
n00b


Joined: 09 Aug 2004
Posts: 54

PostPosted: Mon Feb 21, 2005 10:22 am    Post subject: Reply with quote

DefaultDepth 24
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum