Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
NO displaymanager
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Ginku
n00b
n00b


Joined: 25 Dec 2002
Posts: 71
Location: Ludwigshafen/Germany

PostPosted: Wed Jan 08, 2003 7:53 pm    Post subject: NO displaymanager Reply with quote

Hi all,

could anybody tell me please, how to start KDE without displaymanager ?
No gdm, no xdm, no kdm...........only the console after booting. KDE should start with "startx" then.

Thx

Ginku
Back to top
View user's profile Send private message
count
Apprentice
Apprentice


Joined: 28 May 2002
Posts: 242
Location: Dalton, MA

PostPosted: Wed Jan 08, 2003 8:07 pm    Post subject: Reply with quote

You may be able to get it working by editing /etc/rc.conf and setting the XSESSION variable at the bottom of the file.

Not 100% sure, but thats my best guess.
_________________
- Joseph Monti
_________________
This message is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation. For more info visit http://joemonti.org/
Back to top
View user's profile Send private message
mrjoops
n00b
n00b


Joined: 23 Aug 2002
Posts: 23
Location: Annecy, France

PostPosted: Wed Jan 08, 2003 8:19 pm    Post subject: NO displaymanager Reply with quote

As root, type :
rc-update del xdm default

This should work if you didn't modify /etc/inittab
Back to top
View user's profile Send private message
scocou
Apprentice
Apprentice


Joined: 16 Aug 2002
Posts: 184
Location: Pacific NW, Canada

PostPosted: Wed Jan 08, 2003 8:20 pm    Post subject: Reply with quote

This is the bottom of my /etc/X11/xinit/xinitrc
Code:
else
        numlockx        &
        waimea          &
        wmCalClock      &
        wmifs           &
        wmcube
#       kicker
fi

Whatever you put under the part that says 'Start some nice programs" or whatever will be launched with startx. This is how I've always done it for KDE or anything else and it always works, but I don't know if it's 'proper', nor do I care ;) Btw... the command is
Code:
#startkde
but that's pretty obvious... don't forget your apersands(&) after each command but the last!
_________________
"A paranoid is someone who knows a little of what's going on." -William S. Burroughs


Last edited by scocou on Wed Jan 08, 2003 8:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ginku
n00b
n00b


Joined: 25 Dec 2002
Posts: 71
Location: Ludwigshafen/Germany

PostPosted: Wed Jan 08, 2003 8:22 pm    Post subject: Reply with quote

count wrote:
You may be able to get it working by editing /etc/rc.conf and setting the XSESSION variable at the bottom of the file.
.


Thx, but that didn't work :-( "startx" command starts now only the Xserver without KDE and "startkde" doesn't work.

Ginku
Back to top
View user's profile Send private message
Borisych
n00b
n00b


Joined: 03 Jan 2003
Posts: 3

PostPosted: Wed Jan 08, 2003 8:25 pm    Post subject: Reply with quote

create in your home directory file .xinitrc,
and add to it next string :
exec `which startkde`
Back to top
View user's profile Send private message
scocou
Apprentice
Apprentice


Joined: 16 Aug 2002
Posts: 184
Location: Pacific NW, Canada

PostPosted: Wed Jan 08, 2003 8:51 pm    Post subject: Reply with quote

All you have to do is comment out or delete all the programs already listed in /etc/X11/xinit/xinitrc at the bottom (3 xterms, twm and xclock). Next put one (1) line between the last else/fi. This line should read startkde.
Code:
else
   startkde
fi
If you follow this method it will set the system default behavior for when X is started with startx, and it will work! Delete the .xinitrc in your home directory or it will override the default. Simple to do, and foolproof, just one line!
_________________
"A paranoid is someone who knows a little of what's going on." -William S. Burroughs
Back to top
View user's profile Send private message
Ginku
n00b
n00b


Joined: 25 Dec 2002
Posts: 71
Location: Ludwigshafen/Germany

PostPosted: Wed Jan 08, 2003 10:06 pm    Post subject: Reply with quote

scocou wrote:
All you have to do is comment out or delete all the programs already listed in /etc/X11/xinit/xinitrc at the bottom (3 xterms, twm and xclock). Next put one (1) line between the last else/fi. This line should read startkde.
Code:
else
   startkde
fi
If you follow this method it will set the system default behavior for when X is started with startx, and it will work! Delete the .xinitrc in your home directory or it will override the default. Simple to do, and foolproof, just one line!


Thanks to BC and all other folks,

but it doesn't work here, maybe I am too stupid..

Ginku
Back to top
View user's profile Send private message
scocou
Apprentice
Apprentice


Joined: 16 Aug 2002
Posts: 184
Location: Pacific NW, Canada

PostPosted: Wed Jan 08, 2003 10:30 pm    Post subject: Reply with quote

No, your not stupid, these things can be tricky at first. What happens when you type startx at this point? Does X start? Are you currently booting to a text login like you wanted or are you stuck booting into xdm/gdm/kdm? I'd like to help if you still want it...
_________________
"A paranoid is someone who knows a little of what's going on." -William S. Burroughs
Back to top
View user's profile Send private message
Ginku
n00b
n00b


Joined: 25 Dec 2002
Posts: 71
Location: Ludwigshafen/Germany

PostPosted: Thu Jan 09, 2003 10:09 am    Post subject: Reply with quote

scocou wrote:
Id like to help if you still want it...


Of course, very kind of you ! Well, I've made the entry (startkde) in /etc/X11/xinit/xinitrc after "else" and removed the other. After rebooting it's the same as before. The command "startx" starts the X-server, nothing else. The command startkde fails. With "kdm" (default setting) I can start KDE. If I log out (KDE) or hit ctrl + alt + backspace I always come back to kdm displaymanager.
No chance to leave kdm/X ...:-(
If you have an idea, you can mail me as well ( michael.gehm@gmx.de ).
Sorry for my bad English.

Ginku
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum