Joined: 25 Feb 2003
Location: Essen, Germany
|Posted: Mon Feb 07, 2005 7:57 pm Post subject: [ GLSA 200502-08 ] PostgreSQL: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: PostgreSQL: Multiple vulnerabilities (GLSA 200502-08)
Exploitable: remote and local
Date: February 07, 2005
Updated: June 26, 2007
PostgreSQL contains several vulnerabilities which could lead to execution of arbitrary code, Denial of Service and security bypass.
PostgreSQL is a SQL compliant, open source object-relational database management system.
Vulnerable: < 7.3.10
Vulnerable: < 7.4.7
Vulnerable: < 8.0.1
Unaffected: = 7.3*
Unaffected: = 7.4*
Unaffected: >= 8.0.1
Architectures: All supported architectures
PostgreSQL's contains several vulnerabilities:
- John Heasman discovered that the LOAD extension is vulnerable to local privilege escalation (CAN-2005-0227).
- It is possible to bypass the EXECUTE permission check for functions (CAN-2005-0244).
- The PL/PgSQL parser is vulnerable to heap-based buffer overflow (CAN-2005-0244).
- The intagg contrib module is vulnerable to a Denial of Service (CAN-2005-0246).
An attacker could exploit this to execute arbitrary code with the privileges of the PostgreSQL server, bypass security restrictions and crash the server.
There is no know workaround at this time.
All PostgreSQL users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose dev-db/postgresql
Last edited by GLSA on Fri Jun 29, 2007 4:16 am; edited 6 times in total