Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
startx error: Cannot run in framebuffer mode.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
billbar
n00b
n00b


Joined: 06 Jun 2003
Posts: 9
Location: Austin, TX

PostPosted: Mon Feb 07, 2005 12:37 am    Post subject: startx error: Cannot run in framebuffer mode. Reply with quote

Read several posts about framebuffers and other starting problems but still don't have an answer.
Compiled kde with no apparent problems, reviewed my settings. Bound to be missing something.

Here's my response to 'startx':

Script started on Sat Feb 5 10:37:53 2005
billb@billb billb $ startx


X Window System Version 6.8.0
Release Date: 8 September 2004
X Protocol Version 11, Revision 0, Release 6.8
Build Operating System: Linux 2.6.10-gentoo-r6 i686 [ELF]
Current Operating System: Linux billb 2.6.10-gentoo-r6 #1 Tue Feb 1 08:44:30 CST 2005 i686
Build Date: 05 February 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Feb 5 10:37:57 2005
(EE) Unable to locate/open config file
Using vt 7
xf86AutoConfig: Primary PCI is 1:0:0
Running "/usr/X11R6/bin/getconfig -X 60800000 -I /etc/X11,/usr/X11R6/etc/X11,/usr/lib/modules,/usr/X11R6/lib/X11/getconfig -v 0x1002 -d 0x474d -r 0x65 -s 0x1002 -b 0x0008 -c 0x0300"
getconfig.pl: Version 1.0.
getconfig.pl: Xorg Version: 6.8.0.0.
getconfig.pl: 23 built-in rules.
getconfig.pl: rules file '/usr/X11R6/lib/X11/getconfig/xorg.cfg' has version 1.0.
getconfig.pl: 1 rule added from file '/usr/X11R6/lib/X11/getconfig/xorg.cfg'.
getconfig.pl: Evaluated 24 rules with 0 errors.
getconfig.pl: Weight of result is 500.
New driver is "ati"
(==) Using default built-in configuration (53 lines)

Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices


Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"

after 0 requests (0 known processed) with 0 events remaining.

Couldnt get a file descriptor referring to the console
billb@billb billb $ exit

Script done on Sat Feb 5 10:38:05 2005

Appreciate your help or pointers to appropriate discussion.

Bill Barnes

Edit: Stuck, and changed title from "'startx' fails [SOLVED]". --Maedhros
Edit2: Unstuck. --Maedhros


Last edited by billbar on Fri Feb 11, 2005 12:52 am; edited 1 time in total
Back to top
View user's profile Send private message
TheRAt
Veteran
Veteran


Joined: 03 Jun 2002
Posts: 1580
Location: Salt Spring Island, BC, Canada

PostPosted: Mon Feb 07, 2005 5:48 am    Post subject: Reply with quote

Check your xorg configuration file, usually /etc/X11/xorg.conf

The error message states it cannot find or open this file.
_________________
All reality is the construct of the observer.

Get Firefox and rediscover the web!

BOFH Excuse #295:
The Token fell out of the ring. Call us when you find it.
Back to top
View user's profile Send private message
bet1m
l33t
l33t


Joined: 04 Dec 2004
Posts: 631
Location: Kosova/Prishtine

PostPosted: Mon Feb 07, 2005 8:34 pm    Post subject: Reply with quote

X -configure
xorgconfig
xorgconf

....
_________________
#370559
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon Feb 07, 2005 9:57 pm    Post subject: Reply with quote

Did you configure ever configure xorg? Xorg uses the configuration file xorg.conf located in /etc/X11/. You can create your own configuration file using xorg.conf.example as a template, located in the same directory, or you can use one of the utilities bet1m suggested. They need to be run as root and are located in /usr/X11R6/bin/, which may or may not be in root's path, so if bash says command not found, add that location before the name of the command. Personally I use xorgconfig to create a template, and edit the file by hand when the need arises. xorgconfig asks you a series of questions about your hardware, so knowing the specs on your monitor and video card will help. X -configure configures xorg automatically, but I can never get it to work properly with my ATI card. I have used it on a system with a different card however with no problems. For future reference this post would be better placed in the Desktop Environments forum.
https://forums.gentoo.org/viewforum.php?f=13
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4932
Location: Gothenburg, Sweden

PostPosted: Mon Feb 07, 2005 11:47 pm    Post subject: Reply with quote

Moved from Installing Gentoo, not a non-GUI initial install support request.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Tue Feb 08, 2005 4:20 am    Post subject: Reply with quote

What did I say. :D
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
billbar
n00b
n00b


Joined: 06 Jun 2003
Posts: 9
Location: Austin, TX

PostPosted: Wed Feb 09, 2005 12:33 am    Post subject: [SOLVED] Startx fails Reply with quote

Bingo! Hurrah! At last!
Thanks for the help.

Cheated a little bit, however. After difficulties in getting the xorg-conf settings right, I copied the XF86config-4 from my MEPIS installation to xorg-conf. This from a posting on the MEPIS forums about installing Xorg to that system.
Well, whatever works!

BTW, I never did find X-configure on my Gentoo installation.

I am extremely pleased because this is the 3rd or 4th serious attempt to get Gentoo up and running. Now, I'll probably be back for some other inadequate reading of the documentation, which is really good.

Bill Barnes
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Thu Feb 10, 2005 10:11 pm    Post subject: Reply with quote

Append [SOLVED] to the topic of your first post. Glad I could help. :)
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
billbar
n00b
n00b


Joined: 06 Jun 2003
Posts: 9
Location: Austin, TX

PostPosted: Fri Feb 11, 2005 12:55 am    Post subject: Reply with quote

I agree. Tried that in a later post. Now it seems that I have accomplished it.

Bill Barnes
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon May 02, 2005 12:59 pm    Post subject: Reply with quote

You can also find guides here: http://www.gentoo.org/doc/en/index.xml?catid=desktop.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon May 02, 2005 2:33 pm    Post subject: Reply with quote

Maedhros wrote:
You can also find guides here: http://www.gentoo.org/doc/en/index.xml?catid=desktop.
Why is this a sticky topic? The guy basically couldn't find any of the xorg config binaries because /usr/X11R6/bin wasn't in his path, or he typed X-configure instead of X -configure, so he cheated by copying a config file from another installation. This doesn't seem like it holds too much wisdom for others. Is there some value I'm missing here? :?
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon May 02, 2005 5:29 pm    Post subject: Reply with quote

Sith_Happens wrote:
Why is this a sticky topic?

Look at the ~25 new dupes, all related to not having a config file and trying to start X, of which this topic was one of the more concise in answering the question. This question had also been asked enough times that I thought it ought to be stuck.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Sith_Happens
Veteran
Veteran


Joined: 15 Dec 2004
Posts: 1807
Location: The University of Maryland at College Park

PostPosted: Mon May 02, 2005 6:16 pm    Post subject: Reply with quote

Ah, well then I hope that this will be the cure to all xorg configuration stupidity (yeah right :roll: ). So just to provide a more specific link than Maedhros, here is the Gentoo Linux X server configuration how-to.
_________________
"That question was less stupid; though you asked it in a profoundly stupid way."
I'm the brains behind Jackass! | Tutorials: Shorewall
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon May 02, 2005 6:27 pm    Post subject: Reply with quote

Sith_Happens wrote:
Ah, well then I hope that this will be the cure to all xorg configuration stupidity (yeah right :roll: ).

It's not meant to be, just an answer to the distinctive error message:
Code:
Fatal server error:
Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices


Sith_Happens wrote:
So just to provide a more specific link than Maedhros, here is the Gentoo Linux X server configuration how-to.

Thanks, that would probably have been a more sensible link.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 890

PostPosted: Tue Aug 04, 2009 12:03 pm    Post subject: Reply with quote

Hi,

We are few years later and please tell me if I should open a new thread.

Now that we can skip using xorg.conf I try to upgrade to kernel 2.6.29-r5 but Xorg tells me:
Code:

Cannot run in framebuffer mode

lspci says:
Code:

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

emerge --info says:
Code:

Portage 2.1.6.13 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.27-gentoo-r10 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r10-i686-Intel-R-_Pentium-R-_4_CPU_2.60GHz-with-glibc2.0
Timestamp of tree: Sun, 02 Aug 2009 10:15:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.5.4-r3
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb bluetooth branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox flac fortran gdbm gif gpm gstreamer hal iconv ipv6 isdnlog java jpeg kde ldap libnotify mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg symlink sysfs tcpd tiff truetype unicode usb v4l v4l2 vorbis win32codecs x86 xml xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Any idea appriciated.

Thank you
_________________
Powered by Gentoo Linux since 2003
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 890

PostPosted: Tue Aug 04, 2009 2:42 pm    Post subject: Reply with quote

By the way, if I let X -configure create xorg.conf, startx gives the graphical interface but only at 800x600 and with vesa driver.

Still investigating what's wrong...
_________________
Powered by Gentoo Linux since 2003
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 890

PostPosted: Wed Aug 05, 2009 9:12 am    Post subject: Reply with quote

Back to 2.6.27-r10 where it worked before but now I also get "Cannot run in framebuffer mode".

So now I have no X interface, which quite anying, specially since it's my mother's computer...:-)

Xorg log file here: http://mybsd.free.fr/linux/Xorg.0.log

Any help still appriciated!

Thanks
_________________
Powered by Gentoo Linux since 2003
Back to top
View user's profile Send private message
mamac
l33t
l33t


Joined: 29 Feb 2004
Posts: 890

PostPosted: Wed Aug 05, 2009 1:26 pm    Post subject: Reply with quote

I unmerged f86-video-vesa and xf86-video-fbdev and X starts again, even though I got errors and warnings in X log at least I have a descent GUI. Fixed for me.
_________________
Powered by Gentoo Linux since 2003
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum