Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200501-38 ] Perl: rmtree and DBI tmpfile vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6377
Location: Graz / EU

PostPosted: Wed Jan 26, 2005 8:53 pm    Post subject: [ GLSA 200501-38 ] Perl: rmtree and DBI tmpfile vulnerabilit Reply with quote

Gentoo Linux Security Advisory

Title: Perl: rmtree and DBI tmpfile vulnerabilities (GLSA 200501-38)
Severity: normal
Exploitable: local
Date: January 26, 2005
Updated: March 15, 2005
Bug(s): #75696, #78634, #79685
ID: 200501-38

Synopsis

The Perl DBI library and File::Path::rmtree function are vulnerable to symlink attacks.

Background

Perl is a cross platform programming language. The DBI is the standard database interface module for Perl.

Affected Packages

Package: dev-perl/DBI
Vulnerable: <= 1.38
Unaffected: >= 1.37-r1 < 1.38
Unaffected: >= 1.38-r1
Architectures: All supported architectures

Package: dev-lang/perl
Vulnerable: <= 5.8.6-r3
Unaffected: >= 5.8.6-r4
Unaffected: >= 5.8.5-r5 < 5.8.6
Unaffected: >= 5.8.4-r4 < 5.8.5
Unaffected: >= 5.8.2-r4 < 5.8.3
Architectures: All supported architectures


Description

Javier Fernandez-Sanguino Pena discovered that the DBI library creates temporary files in an insecure, predictable way (CAN-2005-0077). Paul Szabo found out that "File::Path::rmtree" is vulnerable to various race conditions (CAN-2004-0452, CAN-2005-0448).

Impact

A local attacker could create symbolic links in the temporary files directory that point to a valid file somewhere on the filesystem. When the DBI library or File::Path::rmtree is executed, this could be used to overwrite or remove files with the rights of the user calling these functions.

Workaround

There are no known workarounds at this time.

Resolution

All Perl users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose dev-lang/perl
All DBI library users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose dev-perl/DBI


References

CAN-2004-0452
CAN-2005-0077
CAN-2005-0448


Last edited by GLSA on Sun May 07, 2006 4:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum