Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблема со звуком
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
agd
n00b
n00b


Joined: 24 Jan 2005
Posts: 8

PostPosted: Tue Jan 25, 2005 7:09 am    Post subject: Проблема со звуком Reply with quote

Первый раз ставлю Gentoo. С установкой разобрался. Ядро поставил 2.6.10. Включил поддержку ALSA в ядро. Поддержку OSS не включал. Сделал все, как написано в доках. Но звука так и нет. Звуковые модули грузятся. Не ясно надо ли ставить дополнительно ALSA-драйверы или нет? У меня не работает и с ними и без них. Само собой, что громкость в каналах я сделал 100% и сделал также unmute. Если я не стартую alsasound, то ядерные модули грузятся но не появляется /dev/dsp. При старте alsasound грузятся какие-то дополнительные модули, но звкука все равно нет. Может ли проблема быть связана с использованием udev вместо devfs? Может подскажете рецепт. Хорошо бы посмотреть как должно быть сконфигурировано ядро для правильной поддержки звука.
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Tue Jan 25, 2005 3:02 pm    Post subject: Reply with quote

надо звук включить или прибавить громкости

делается это так:
su
/etc/init.d/alsasound start
alsaconf
amixer set PCM on
amixer set PCM 100
amixer set Master on
amixer set Master 100
alsactl store
Back to top
View user's profile Send private message
agd
n00b
n00b


Joined: 24 Jan 2005
Posts: 8

PostPosted: Wed Jan 26, 2005 6:53 am    Post subject: Reply with quote

Спасибо за ответ, но я же написал, что громкость и unmute я сделал. Дело не в этом. В общем я разобрался. Ядерная поддержка ALSA (у меня по крайней мере) не работает. Я отключил в ядре поддержку ALSA и поставил отдельно alsa-drivers. И все заработало.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Wed Jan 26, 2005 7:25 am    Post subject: Reply with quote

В принципе в HOWTO так и написано. Включаешь только soundcore как модуль и все.... Читать надо howto ...
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Thu Jan 27, 2005 7:04 pm    Post subject: Reply with quote

rusxakep wrote:
В принципе в HOWTO так и написано. Включаешь только soundcore как модуль и все.... Читать надо howto ...


Я сталкивался с каким-то случаем, что алса в ядре была нужна.
Непомню нафига и кому :roll:
Я конечно забил и сделал как-то иначе, но в лоб было надо.
Так-что не всегда :wink:
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Fri Jan 28, 2005 7:21 am    Post subject: Reply with quote

В теории - в ядре должна быть старая алса, поэтому ее использование не рекомендуется - а зачем включать ее там и там - вообще не понимаю. Ну да ладно. :roll:
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Fri Jan 28, 2005 8:43 am    Post subject: Reply with quote

у меня ядерная :) alsa работает.
чего-то не хочется alsa скачивать
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Mon Jan 31, 2005 6:48 am    Post subject: Reply with quote

Незнаю а в чем проблема скачать 1887764 байт? :)
Back to top
View user's profile Send private message
d_n_k
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2004
Posts: 138
Location: Russia

PostPosted: Mon Jan 31, 2005 8:54 am    Post subject: Reply with quote

лень
Back to top
View user's profile Send private message
agd
n00b
n00b


Joined: 24 Jan 2005
Posts: 8

PostPosted: Fri Mar 11, 2005 8:26 am    Post subject: Reply with quote

Обнаружилась проблема другого плана. Если воспроизводить звук с аудио диска громкость регулируется хорошо, а если из файла (mp3, avi) громкость вообще не регулируется (орёт на полную катушку). Можно только отключить звук , если сделать mute для PCM. Больше никакие регулировки не работают. Может кто сталкивался с такой проблемой? Плата intel, драйвер intel8x0.
Back to top
View user's profile Send private message
GreenDragon
Guru
Guru


Joined: 31 Jul 2003
Posts: 319

PostPosted: Fri Mar 11, 2005 9:22 am    Post subject: Reply with quote

d_n_k wrote:
у меня ядерная :) alsa работает.
чего-то не хочется alsa скачивать

Аналогично ядро gentoo-dev-sources-2.6.11-r3n
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Sat Mar 12, 2005 7:27 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-306011.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum