Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
sun mouse issues with 2.6.9 on ultra5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
retroman
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 207
Location: Stuttgart

PostPosted: Mon Jan 17, 2005 4:26 pm    Post subject: sun mouse issues with 2.6.9 on ultra5 Reply with quote

Ive had much sucess configuring the atifb and the keyboard for 2.6.9 on my Ultra 5. However as I push towards X, a new problem emerges. Apparently there is a drastic change as to how the sun mouse is handeled between the 2.4 and 2.6 kernels. Everything runs fine in 2.4 with the items shown below. I am however confused as to how to configure for 2.6


The dmesg output on the 2.4 kernel will include the following lines....


PCIO serial driver version 1.54
su(mouse) at 0x1fff13062f8 (irq = 4,7ea) is a 16550A
Sun Mouse-Systems mouse driver version 1.00
su(kbd) at 0x1fff13083f8 (irq = 9,7e9) is a 16550A
Sun TYPE 5 keyboard detected without keyclick
SAB82532 serial driver version 1.65
ttyS00 at 0x1fff1400000 (irq = 12,7eb) is a SAB82532 V3.2
ttyS01 at 0x1fff1400040 (irq = 12,7eb) is a SAB82532 V3.2

<several lines later>


mice: PS/2 mouse device common for all mice


<several lines later>

sunmouse: Successfully adjusted to 1200 baud

*************************************************************




The mouse if configured in the xorg.conf file as


Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Busmouse"

Option "Device" "/dev/sunmouse"


When using the 2.6.9 kernel there is no more /dev/sunmouse so x doesnt start.


the dmesg will show

mice: PS/2 mouse device common for all mice
input: Sun Mouse on su/serio0




The kernel configs are as follows



--- Input Device Drivers
[*] Keyboards
< > AT keyboard support
<*> Sun Type 4 and Type 5 keyboard support
< > DECstation/VAXstation LK201/LK401 keyboard support
< > XT Keyboard support
< > Newton keyboard
[*] Mice
<M> PS/2 mouse
<M> Serial mouse
<M> DEC VSXXX-AA/GA mouse and VSXXX-AB tablet
[ ] Joysticks
[ ] Touchscreens
[*] Misc
<*> SPARC Speaker support
< > User level driver support




Since I know the mouse works just fine in 2.4 its not a hardware issue. Does anyone know if my configurations are right for the mouse to work in X with kernel 2.6.9

thanx

JR
Back to top
View user's profile Send private message
retroman
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 207
Location: Stuttgart

PostPosted: Mon Jan 17, 2005 4:43 pm    Post subject: sermouse modules in 2.6.9 Reply with quote

I forgot to add that typeing in the folllowing

modprobe sermouse


will yeild the following message in dmesg

input: Sun Mouse on su/serio0

where is su/serio0 and how would it be configured in xorg.conf


jr
Back to top
View user's profile Send private message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Tue Jan 18, 2005 10:00 pm    Post subject: Reply with quote

For me, I just do modprobe sermouse and then unplug the mouse out from the keyboard and then plug it back once the X starts to make it work.
Back to top
View user's profile Send private message
retroman
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 207
Location: Stuttgart

PostPosted: Wed Jan 19, 2005 5:16 am    Post subject: modprobe sermouse Reply with quote

when configuring X, what device do you assign the pointer?

/dev/mouse
/dev/ps2aux

etc..

thanxs

jr
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Thu Jan 20, 2005 4:43 am    Post subject: Reply with quote

You'll want to enable serial mice in the kernel. While the connectors on the keyboard and mouse look like PS/2 style connectors, they are actually serial.

As for X, you'll want to use the /dev/input/mice device, and IMPS/2 protocol.
Back to top
View user's profile Send private message
retroman
Apprentice
Apprentice


Joined: 18 Nov 2004
Posts: 207
Location: Stuttgart

PostPosted: Thu Jan 20, 2005 8:52 am    Post subject: Mouse works but keymap screwy on x Reply with quote

I made the configuration changes and modprobe'd sermouse. If I disconnect and reconnect the mouse after x starts then the mouse works.

Once X starts Im running into the Kepmap issue again. In run level 3 I made it go away by doing rc-update del keymap default /or boot.

when I go back to X I run into the problem again.

The question is....

On the Ultra5 running 2.6.9, what Keymap should we be using?

thanks much

JR
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Thu Jan 20, 2005 12:39 pm    Post subject: Reply with quote

You'll probably want your keyboard section to look something like this below(taken from http://dev.gentoo.org/~fmccor/docs/xorg/xorg.conf/xorg.conf.html) ;

Code:
Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
  Option      "XkbModel"    "type5"
  Option      "XkbRules"    "xorg"
  Option      "XkbLayout"   "en_US"
  Option      "XkbGeometry" "sun(type5)"
EndSection
Back to top
View user's profile Send private message
Mark Clegg
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 269
Location: ZZ9 Plural Z Alpha

PostPosted: Fri Jan 21, 2005 6:48 pm    Post subject: Reply with quote

2.6.x mouse initialisation on Ultra 5 is broken....

https://forums.gentoo.org/viewtopic.php?t=149437

I submitted it as a bug/fix to the kernel developers some time ago, but as the fix isn't 100%, David S Miller didn't want to incorporate it until he'd thought about the problem more, (which is fair comment).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum