Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Usb Flash и kernel 2.6.9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
macworm
n00b
n00b


Joined: 16 Nov 2004
Posts: 39

PostPosted: Wed Jan 12, 2005 4:53 pm    Post subject: Usb Flash и kernel 2.6.9 Reply with quote

Уважаемые помогите решить проблему или подскажите где прочитать.
Не хочет система создавать устройства для монтирования флеш.

в конфиге ядра
#
# SCSI device support
#
CONFIG_SCSI=y
CONFIG_SCSI_PROC_FS=y

#
# SCSI support type (disk, tape, CD-ROM)
#
CONFIG_BLK_DEV_SD=y
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
# CONFIG_BLK_DEV_SR is not set
CONFIG_CHR_DEV_SG=y

#
# USB support
#
CONFIG_USB=y
# CONFIG_USB_DEBUG is not set

#
# Miscellaneous USB options
#
CONFIG_USB_DEVICEFS=y
# CONFIG_USB_BANDWIDTH is not set
# CONFIG_USB_DYNAMIC_MINORS is not set
# CONFIG_USB_SUSPEND is not set
# CONFIG_USB_OTG is not set

#
# USB Host Controller Drivers
#
CONFIG_USB_EHCI_HCD=y
# CONFIG_USB_EHCI_SPLIT_ISO is not set
# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
CONFIG_USB_OHCI_HCD=y
CONFIG_USB_UHCI_HCD=y
#
# USB Device Class drivers
#
# CONFIG_USB_AUDIO is not set
# CONFIG_USB_BLUETOOTH_TTY is not set
# CONFIG_USB_MIDI is not set
# CONFIG_USB_ACM is not set
# CONFIG_USB_PRINTER is not set
CONFIG_USB_STORAGE=y
CONFIG_USB_STORAGE_DEBUG=y
CONFIG_USB_STORAGE_RW_DETECT=y

лог загрузки такой

Linux version 2.6.9-gentoo-r9 (root@home) (gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)) #6 Sun Jan 9 14:40:51 EET 2005
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 0000000017ffc000 (usable)
BIOS-e820: 0000000017ffc000 - 0000000017fff000 (ACPI data)
BIOS-e820: 0000000017fff000 - 0000000018000000 (ACPI NVS)
BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
383MB LOWMEM available.
On node 0 totalpages: 98300
DMA zone: 4096 pages, LIFO batch:1
Normal zone: 94204 pages, LIFO batch:16
HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 ASUS ) @ 0x000f5a60
ACPI: RSDT (v001 ASUS P3V_4X 0x30303031 MSFT 0x31313031) @ 0x17ffc000
ACPI: FADT (v001 ASUS P3V_4X 0x30303031 MSFT 0x31313031) @ 0x17ffc080
ACPI: BOOT (v001 ASUS P3V_4X 0x30303031 MSFT 0x31313031) @ 0x17ffc040
ACPI: DSDT (v001 ASUS P3V_4X 0x00001000 MSFT 0x0100000b) @ 0x00000000
ACPI: PM-Timer IO Port: 0xe408
Built 1 zonelists
Kernel command line: root=/dev/hdc3 ro acpi=force splash=silent
No local APIC present or hardware disabled
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 533.440 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 384700k/393200k available (2868k kernel code, 7912k reserved, 1009k data, 184k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 1056.76 BogoMIPS (lpj=528384)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: 0383f9ff 00000000 00000000 00000000
CPU: After vendor identify, caps: 0383f9ff 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU: After all inits, caps: 0383f9ff 00000000 00000000 00000040
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: Intel Pentium III (Coppermine) stepping 01
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
ACPI: IRQ9 SCI: Edge set to Level Trigger.
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xf0890, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20040816
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PCI Root Bridge [PCI0] (00:00)
PCI: Probing PCI hardware (bus 00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 5
ACPI: PCI interrupt 0000:00:04.2[D] -> GSI 5 (level, low) -> IRQ 5
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 10
ACPI: PCI interrupt 0000:00:0c.0[A] -> GSI 10 (level, low) -> IRQ 10
ACPI: PCI interrupt 0000:00:0e.0[A] -> GSI 11 (level, low) -> IRQ 11
NET: Registered protocol family 23
Simple Boot Flag at 0x3a set to 0x1
audit: initializing netlink socket (disabled)
audit(1105554656.290:0): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
Initializing Cryptographic API
Activating ISA DMA hang workarounds.
inotify init: minor=63
Real Time Clock Driver v1.12
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected VIA Apollo Pro 133 chipset
agpgart: Maximum main memory to use for agp memory: 321M
agpgart: AGP aperture is 64M @ 0xe4000000
ACPI: Power Button (FF) [PWRF]
ACPI: Processor [CPU0] (supports C1 C2, 16 throttling states)
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing disabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
input: ImPS/2 Generic Wheel Mouse on isa0060/serio1
parport0: PC-style at 0x378 (0x778) [PCSPP(,...)]
parport0: irq 7 detected
Using anticipatory io scheduler
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
loop: loaded (max 8 devices)
ub: sizeof ub_scsi_cmd 60 ub_dev 924
usbcore: registered new driver ub
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
PPP BSD Compression module registered
Linux Tulip driver version 1.1.13 (May 11, 2002)
PCI: Enabling device 0000:00:0a.0 (0014 -> 0017)
ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 11 (level, low) -> IRQ 11
tulip0: MII transceiver #1 config 3100 status 7849 advertising 05e1.
tulip0: MII transceiver #2 config 1000 status 7849 advertising 05e1.
tulip0: MII transceiver #3 config 1000 status 7849 advertising 05e1.
tulip0: MII transceiver #4 config 1000 status 7849 advertising 05e1.
eth0: ADMtek Comet rev 17 at 0xd000, 00:04:E2:3D:C6:1B, IRQ 11.
PCI: Enabling device 0000:00:0e.0 (0014 -> 0017)
ACPI: PCI interrupt 0000:00:0e.0[A] -> GSI 11 (level, low) -> IRQ 11
tulip1: MII transceiver #1 config 3100 status 7869 advertising 05e1.
eth1: ADMtek Comet rev 17 at 0xb400, 00:50:BF:9C:DF:AD, IRQ 11.
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller at PCI slot 0000:00:04.1
VP_IDE: chipset revision 16
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c596b (rev 23) IDE UDMA66 controller on pci0000:00:04.1
ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:DMA
Probing IDE interface ide0...
hda: WDC AC24300L, ATA DISK drive
hdb: SAMSUNG SV1022D, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: ST340014A, ATA DISK drive
hdd: LITE-ON LTR-48246S, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
Probing IDE interface ide2...
ide2: Wait for ready failed before probe !
Probing IDE interface ide3...
ide3: Wait for ready failed before probe !
Probing IDE interface ide4...
ide4: Wait for ready failed before probe !
Probing IDE interface ide5...
ide5: Wait for ready failed before probe !
hda: max request size: 128KiB
hda: 8421840 sectors (4311 MB) w/256KiB Cache, CHS=8912/15/63, UDMA(33)
hda: cache flushes not supported
/dev/ide/host0/bus0/target0/lun0: p1
hdb: max request size: 128KiB
hdb: 19931184 sectors (10204 MB) w/472KiB Cache, CHS=19773/16/63, UDMA(66)
hdb: cache flushes not supported
/dev/ide/host0/bus0/target1/lun0: p1
hdc: max request size: 1024KiB
hdc: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(33)
hdc: cache flushes supported
/dev/ide/host0/bus1/target0/lun0: p1 p2 p3
hdd: ATAPI 48X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ohci_hcd: 2004 Feb 02 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
USB Universal Host Controller Interface driver v2.2
ACPI: PCI interrupt 0000:00:04.2[D] -> GSI 5 (level, low) -> IRQ 5
uhci_hcd 0000:00:04.2: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
uhci_hcd 0000:00:04.2: irq 5, io base 0000d400
uhci_hcd 0000:00:04.2: new USB bus registered, assigned bus number 1
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
Advanced Linux Sound Architecture Driver Version 1.0.6 (Sun Aug 15 07:17:53 2004 UTC).
PCI: Enabling device 0000:00:0c.0 (0004 -> 0005)
ACPI: PCI interrupt 0000:00:0c.0[A] -> GSI 10 (level, low) -> IRQ 10
ALSA device list:
#0: Ensoniq AudioPCI ENS1371 at 0xb800, irq 10
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
ip_conntrack version 2.1 (3071 buckets, 24568 max) - 300 bytes per conntrack
ip_tables: (C) 2000-2002 Netfilter core team
ipt_recent v0.3.1: Stephen Frost <sfrost@snowman.net>. http://snowman.net/projects/ipt_recent/
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 15
IrCOMM protocol (Dag Brattli)
ReiserFS: hdc3: found reiserfs format "3.6" with standard journal
ReiserFS: hdc3: using ordered data mode
ReiserFS: hdc3: journal params: device hdc3, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hdc3: checking transaction log (hdc3)
ReiserFS: hdc3: Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Mounted devfs on /dev
Freeing unused kernel memory: 184k freed
Adding 1004052k swap on /dev/hdc2. Priority:-1 extents:1
devfs_mk_dev: could not append to parent for vcc/2
devfs_mk_dev: could not append to parent for vcc/a2
lp0: using parport0 (polling).
eth1: Setting full-duplex based on MII#1 link partner capability of 41e1.
devfs_mk_dev: could not append to parent for vcc/2
devfs_mk_dev: could not append to parent for vcc/a2
devfs_mk_dev: could not append to parent for vcc/3
devfs_mk_dev: could not append to parent for vcc/a3
devfs_mk_dev: could not append to parent for vcc/5
devfs_mk_dev: could not append to parent for vcc/a5
devfs_mk_dev: could not append to parent for vcc/6
devfs_mk_dev: could not append to parent for vcc/a6
devfs_mk_dev: could not append to parent for vcc/4
devfs_mk_dev: could not append to parent for vcc/a4
devfs_mk_dev: could not append to parent for vcc/7
devfs_mk_dev: could not append to parent for vcc/a7

подскажите что делаю не так, hotplug установлен.
Да и если не сложно подскажите в чем может быть проблема с последними сообщения лога насчет устройств vcc

Спасибо за терпение
Back to top
View user's profile Send private message
~Nexo~
n00b
n00b


Joined: 31 Oct 2004
Posts: 6
Location: Vladivostok

PostPosted: Wed Jan 12, 2005 10:35 pm    Post subject: Reply with quote

Я никак не пойму, что значит -
"Не хочет система создавать устройства для монтирования флеш. "???
ты имел ввиду /dev/sda* у тебя нет что-ли??
вроде ядро настроено правильно, да и загружаются вроде драйвера для USB, может просто монтируешь не так (или нет то)?
попробуй - mount /dev/sda1 /mnt/usb1
Только предварительно создай каталог - mkdir /mnt/usb1
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Wed Jan 12, 2005 10:55 pm    Post subject: Reply with quote

В загрузчике укажи, что root-партицию надо монтировать rw, по умолчанию --- ro.

Для grub'а просто добавь rw (через пробелы) в строчке kernel = ...
Back to top
View user's profile Send private message
Xenon_
n00b
n00b


Joined: 17 Sep 2004
Posts: 55

PostPosted: Thu Jan 13, 2005 12:01 am    Post subject: Reply with quote

Покажи lsmod
Back to top
View user's profile Send private message
macworm
n00b
n00b


Joined: 16 Nov 2004
Posts: 39

PostPosted: Thu Jan 13, 2005 10:33 am    Post subject: Reply with quote

~Nexo~ wrote:
Я никак не пойму, что значит -
"Не хочет система создавать устройства для монтирования флеш. "???
ты имел ввиду /dev/sda* у тебя нет что-ли??
вроде ядро настроено правильно, да и загружаются вроде драйвера для USB, может просто монтируешь не так (или нет то)?
попробуй - mount /dev/sda1 /mnt/usb1
Только предварительно создай каталог - mkdir /mnt/usb1


Таких устройств система не создает, а когда создаю сам, то ругается, что-то по поводу суперблоков.
На ядре 2.4. все создавалося
Back to top
View user's profile Send private message
sokhapkin
n00b
n00b


Joined: 13 Jan 2005
Posts: 33
Location: N Ft Myers, FL

PostPosted: Thu Jan 13, 2005 2:54 pm    Post subject: Reply with quote

Нет больше /dev/sda* для USB flash. Оно теперь /dev/ub/a/* (или /dev/uba* если повезет :-)
_________________
Sergey Okhapkin
http://www.callwithus.com
Back to top
View user's profile Send private message
macworm
n00b
n00b


Joined: 16 Nov 2004
Posts: 39

PostPosted: Thu Jan 13, 2005 2:59 pm    Post subject: Reply with quote

sokhapkin wrote:
Нет больше /dev/sda* для USB flash. Оно теперь /dev/ub/a/* (или /dev/uba* если повезет :-)

есть такое устройство, но все равно выдается ошибка что то связанная с суперблоками, подробнее скажу вечером, потому как комп дома
Back to top
View user's profile Send private message
doonkel
Apprentice
Apprentice


Joined: 06 Aug 2004
Posts: 202

PostPosted: Thu Jan 13, 2005 3:26 pm    Post subject: Reply with quote

Попробуй так
#mount -t vfat /dev/??? /mnt/? -o iocharset=koi8-r,codepage=866
Соответственно ??? и ? замени своими устройствами и кодировка должна быть твоя
Back to top
View user's profile Send private message
macworm
n00b
n00b


Joined: 16 Nov 2004
Posts: 39

PostPosted: Thu Jan 13, 2005 5:26 pm    Post subject: Reply with quote

sokhapkin wrote:
Нет больше /dev/sda* для USB flash. Оно теперь /dev/ub/a/* (или /dev/uba* если повезет :-)

Сама папка /dev/ub есть но вот устройств в ней нет.

вывод по lsmod следующий

Module Size Used by
lp 8040 0
vfat 11968 1
fat 39616 1 vfat
Back to top
View user's profile Send private message
Xenon_
n00b
n00b


Joined: 17 Sep 2004
Posts: 55

PostPosted: Thu Jan 13, 2005 9:36 pm    Post subject: Reply with quote

Я когда собирал систему просто в make.conf прописал:
USE="......usb......"
И все Ok
Back to top
View user's profile Send private message
ba
l33t
l33t


Joined: 25 May 2003
Posts: 804

PostPosted: Sat Jan 15, 2005 9:11 am    Post subject: Reply with quote

sokhapkin wrote:
Нет больше /dev/sda* для USB flash. Оно теперь /dev/ub/a/* (или /dev/uba* если повезет :-)

врете :)
/dev/uba* это _медленная_ замена драйвера для mass storage, работающая без scsi. Включается и отключается она в block devices, если ее отключить, то все будет по старому и с нормальной скоростью...
Back to top
View user's profile Send private message
xunnbi4
n00b
n00b


Joined: 19 Jan 2005
Posts: 1

PostPosted: Wed Jan 19, 2005 11:37 pm    Post subject: Reply with quote

Где то на родном форуме я видел что надо отключить в ядре 2.6.9 такое
Low Performance USB Block driver <DISABLE> что в Device drivers->Block Device
Вообще очень советую ходить по англоязычным форумам, школьного + технического уровня вполне достаточно
Back to top
View user's profile Send private message
_Sir_
Guru
Guru


Joined: 17 Jan 2005
Posts: 337
Location: Russia, Togliatti

PostPosted: Thu Jan 20, 2005 7:35 am    Post subject: Re: Usb Flash и kernel 2.6.9 Reply with quote

macworm wrote:
подскажите что делаю не так, hotplug установлен.
Да и если не сложно подскажите в чем может быть проблема с последними сообщения лога насчет устройств vcc
Очень рекомендуется вдумчиво прочесть "Миграция с ядер 2.4 на 2.6" (примерное название, я читал английскую версию) из документации пользователей на сайте gentoo. Потом выполнить все, что там написано. Например, удавить udev' ом devfsd :)

Если у тебя свежеустановленная система, можно попробовать ее переставить, начиная сразу с ядра 2.6. Для этого (гы, сам бы тоже не догадался, но я люблю доки читать!) нужно выбрать при установке (в GRP 2004.2 например) версию ядра smp (!) или, если будут проблемы с консолью smp-nofb что часто бывает на видеокартах с чипами nvidia
_________________
(Sir) * Life is placeholder for Love *
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum