Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
JACK and WINE: JACK protocol mismatch (15 vs 16)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
saffsd
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2006
Posts: 139

PostPosted: Fri Nov 02, 2007 12:59 pm    Post subject: JACK and WINE: JACK protocol mismatch (15 vs 16) Reply with quote

I've been working on getting wine+steam going. So far, I've been able to copy over steam from my windows partition, and most games from the orange box launch and run to some extent. Audio however has been a sticking point. I've tried both ALSA and OSS in winecfg, both crash pretty quick. Many guides I have seen suggest using jack, (eg http://gentoo-wiki.com/HOWTO_Counter-Strike_1.6_With_WINE ), which is what I'm trying to set up. However:

Code:

jackd -d dummy                            (11-02 23:54)
jackd 0.103.0
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
creating dummy driver ... dummy_pcm|48000|1024|21333|2|2
JACK protocol mismatch (15 vs 16)
cannot complete client connection process
JACK protocol mismatch (15 vs 16)
cannot complete client connection process


This happens on setting "JACK Driver" under audio in winecfg, and pushing the "Test Sound" button. Here is the corresponding output in winecfg's terminal:

Code:

ALSA lib pcm_softvol.c:889:(_snd_pcm_softvol_open) Unknown field max_dB
ALSA lib pcm_softvol.c:889:(_snd_pcm_softvol_open) Unknown field max_dB
client linked with incompatible libjack version.
could not attach to JACK server
client linked with incompatible libjack version.
could not attach to JACK server
err:wave:JACK_OpenWaveOutDevice jack server not running?
err:wave:wodOpen JACK_OpenWaveOutDevice(0) failed


Jack and wine are the latest versions available:

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-sound/jack-audio-connection-kit-0.103.0  USE="alsa mmx oss sse (-altivec) -caps (-coreaudio) -cpudetection -debug -doc -jack-tmpfs -netjack -portaudio" 0 kB
[ebuild   R   ] app-emulation/wine-0.9.48  USE="X alsa cups dbus esd hal jack jpeg ncurses opengl oss xml -lcms -ldap -nas -scanner" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB



Emerge info (if it's relevant)
Code:

Portage 2.1.3.16 (default-linux/amd64/2007.0, gcc-4.2.2, glibc-2.6.1-r0, 2.6.22-kamikaze4 x86_64)
=================================================================
System uname: 2.6.22-kamikaze4 x86_64 Intel(R) Core(TM)2 CPU 6420 @ 2.13GHz
Timestamp of tree: Fri, 02 Nov 2007 03:20:01 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=nocona -fforce-addr -fomit-frame-pointer -ftracer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS=OMITTED
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,--hash-style=gnu"
LINGUAS="en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/custom-kernels /usr/portage/local/layman/musicbrainz /usr/portage/local/layman/haskell /usr/portage/local/overlay"
SYNC=OMITTED
USE="X acl alsa amd64 arts berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus dri dvd dvdr eds emboss encode esd fam firefox fortran gdbm gif glitz gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jack jpeg kde kdeenablefinal kdehiddenvisibility mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl svg tcpd truetype truetype-fonts type1-fonts unicode vorbis xcomposite xinerama xml xorg xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


That jack error is hardly informative. It's not even clear which side is using protocol 15 and which side expects 16. Googling for it provides nothing useful. I've tried backing off revisions of both Jack and Wine, with no luck. If you're not able to help me directly, but have WINE+JACK+STEAM running well, could you please post version numbers? Thanks.
Back to top
View user's profile Send private message
stick_figure
n00b
n00b


Joined: 22 Jan 2004
Posts: 38
Location: Palo Alto, CA

PostPosted: Wed Dec 12, 2007 5:04 am    Post subject: Reply with quote

I'm also having this exact problem. It's actually so spot on that repasting the error messages would be a waste of space. I'm going to keep doing more research.
_________________
If someone drops a fort on Will, he makes a reflex save.
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 467

PostPosted: Wed Dec 12, 2007 6:12 am    Post subject: Reply with quote

Portal runs fine for me with OSS sound, try upgrading to 0.9.50.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum