Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Странная загрузка...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
~Nexo~
n00b
n00b


Joined: 31 Oct 2004
Posts: 6
Location: Vladivostok

PostPosted: Wed Jan 12, 2005 1:05 am    Post subject: Странная загрузка... Reply with quote

У меня при загрузке происходят странные вещи (может конечно это только мне кажется что они странные), так вот -
при загрузке можно наблюдат следующую картину
>> Loading modules...
:: Scanning for ehci-hcd... module not found.
:: Scanning for uhci... module not found.
:: Scanning for usb-ohci... module not found.
:: Scanning for hid... module not found.
:: Scanning for usb-storage... module not found.
:: Scanning for uhci-hcd... module not found.
:: Scanning for ohci-hcd... module not found.
:: Scanning for usbhid... module not found.
:: Scanning for ieee1394... module not found.
:: Scanning for ohci1394... module not found.
:: Scanning for sbp2... module not found.
:: Scanning for dm-mod... module not found.
:: Scanning for dm-snapshot... module not found.
:: Scanning for dm-mirror... module not found.

При этом после завершения загрузки все модули прекрасно работают.
В связи с этим возник вопрос как можено избавится (правильным путем, а не чисткой стандартных скриптов) от этих строк при загрузке, которыые очень сильно похожи на ошибки загрузки.
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Wed Jan 12, 2005 3:09 am    Post subject: Re: Странная загрузка... Reply with quote

В Генту вроде настройками модулей и их конфигов заведует:

# modules-update

Можно его попробовать, т.к. я с ним и его фишками до конца не разбирался еще, не скажу, что 100% поможет, но ...
:?

Думаю, что стоит попробовать :idea:

Я так понял, что потом все работает замечательно и
# depmod -a
не нужен :wink:
Back to top
View user's profile Send private message
~Nexo~
n00b
n00b


Joined: 31 Oct 2004
Posts: 6
Location: Vladivostok

PostPosted: Wed Jan 12, 2005 10:23 pm    Post subject: Reply with quote

Все модули действительно работают на ура, причем без вопросов...
Судя по конфигам эти строки появляются еще на момент загрузки ядра (до монтирования корневой системы => конфиги тут не причем), скорее всего нужно попробовать пересобрать ядро, возможно без genkernel... В ближайшее время проверю, может что получится...
Back to top
View user's profile Send private message
ZByte
Tux's lil' helper
Tux's lil' helper


Joined: 18 Aug 2004
Posts: 141
Location: Moscow, Russia

PostPosted: Fri Jan 14, 2005 7:53 am    Post subject: Reply with quote

Могу ошибаться, но эти ошибки являтся следствием того, что у тебя в чудном файлике /etc/modules.autoload.d/kernel-2.6 прописаны эти модули, но реально они у тебя не собраны в виде модулей, т.е. их нету в папке /lib/modules/<kernel version>/.
А работает у тебя всё по той причине, что эти модули в ядро вкомпилины.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Fri Jan 14, 2005 8:00 am    Post subject: Reply with quote

~Nexo~ wrote:
Судя по конфигам эти строки появляются еще на момент загрузки ядра (до монтирования корневой системы => конфиги тут не причем)

Причем.
Ядро грузиться с boot-партиции, далее управление передается initrd, genkernel его всегда генерит. А в initrd/sbin/init'е, как правило, монтируется root-партиция и с нее читаются всякие настройки и пр. фигня, запускаются всякие скрипты, результат работы которых ты и видишь.

Так что, помимо написанного ZByte, можешь убрать строчку "initrd ..." из настроек загрузчика.
Back to top
View user's profile Send private message
sokhapkin
n00b
n00b


Joined: 13 Jan 2005
Posts: 33
Location: N Ft Myers, FL

PostPosted: Fri Jan 14, 2005 1:06 pm    Post subject: Reply with quote

Я, честно говоря, вообще не вижу смысла использовать initrd при загрузке с HDD. Единственное условие - драйвер boot device должен быть вкомпилирован в ядро, а не модулем.
_________________
Sergey Okhapkin
http://www.callwithus.com
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Fri Jan 14, 2005 1:17 pm    Post subject: Reply with quote

Согласен.
Только все вопросы и предложения к genkernel'у.
Back to top
View user's profile Send private message
ManJak
Guru
Guru


Joined: 18 Dec 2004
Posts: 561
Location: St. Petersburg, Russia

PostPosted: Fri Jan 14, 2005 8:20 pm    Post subject: Reply with quote

viy wrote:
Согласен.
Только все вопросы и предложения к genkernel'у.


Может попробовать не юзать генкернел?
Собрал одни раз ядро и забыл, и никто не поменяет ничегошеньки :P

Я сам пробовал генкернел, но снес НЕЩАДНО!
Что-то мне там не понравилось
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum