Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas com Coldplugging PCI devices
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
humbertoleal
n00b
n00b


Joined: 09 Jan 2005
Posts: 3

PostPosted: Sun Jan 09, 2005 11:01 pm    Post subject: Problemas com Coldplugging PCI devices Reply with quote

Pessoal, estou com um problema na minha inicialização, ainda estou aprendendo a utilizar o Gentoo/Linux e preciso de uma ajuda com isso aqui..

Na inicialização acontece o seguinte erro

Coldplugging PCI devices:
Missisng kernel or user mode driver hw_random
cannot load driver hw_random

E isso continua se repetindo para os seguintes drivers,
rivafb
i810-rng
i810-tco
8139cp

Como arrumar isso?
Estou utilizando o linux-2.4.26-gentoo-r14
Sou novato por aqui, este é meu primeiro post, se alguem puder me ajudar, pq eu realmente gostaria terminar minha migração XP - Gentoo!!
Devo passar mais alguma informação para que algum bom samaritano consiga me ajudar?

Obrigado!
Humberto Leal
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Mon Jan 10, 2005 3:00 am    Post subject: Reply with quote

Precisas de activar essa opção no kernel. Se não me engano está nas General Settings.
Back to top
View user's profile Send private message
lmpinto
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2003
Posts: 94
Location: somewhere near a computer and a beer.

PostPosted: Mon Jan 10, 2005 12:39 pm    Post subject: Reply with quote

Mas isso é so se tiveres suporte de hardware para isso. Até agora a unica board que tive com suporte para isso era uma Intel D815EEA. Caso contrário, experimenta recompilar o kernel (e os modulos) sem activar o modulo.
Back to top
View user's profile Send private message
humbertoleal
n00b
n00b


Joined: 09 Jan 2005
Posts: 3

PostPosted: Mon Jan 10, 2005 11:42 pm    Post subject: Reply with quote

As opções no kernel estão corretas eu acho,
mas como posso descobrir se eu nao vou usar estes drivers
minha MB é uma Asus P4B266-C

Obrigado pela ajuda
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Tue Jan 11, 2005 3:36 am    Post subject: Reply with quote

Se você nem sabe o que é, provavelmente não precisa. :wink:
_________________
RTFM!
Back to top
View user's profile Send private message
lmpinto
Tux's lil' helper
Tux's lil' helper


Joined: 12 Feb 2003
Posts: 94
Location: somewhere near a computer and a beer.

PostPosted: Tue Jan 11, 2005 2:42 pm    Post subject: Re: Problemas com Coldplugging PCI devices Reply with quote

humbertoleal wrote:

hw_random
rivafb
i810-rng
i810-tco
8139cp


O primeiro e o terceiro modulos são para geradores de números aleatórios por hardware. Não precisas (se precisasses sabias o que era, como disse o Fernando, se não sabes o que é é porque não precisas :-))
O segundo é para o framebuffer para algumas nvidias riva. Também não deves precisar. O último é o driver da realtek 8139c plus. Se tiveres uma realtek podes usar em vez disto o 8139too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum