Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Php-related block
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
ElleStone
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2013
Posts: 91

PostPosted: Thu Jul 25, 2013 7:46 pm    Post subject: [SOLVED] Php-related block Reply with quote

I'm trying to update and keep getting told there's a block. There were a lot more blocks but I've reduced it to the following, which is probably as far as I can go without a helping hand from someone more knowledgeable than myself about Gentoo (that's setting the bar very low!).

Code:
gentoo portage # emerge -pv php

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/libpcre-8.33:3 [8.30-r2:3] USE="bzip2 cxx jit readline recursion-limit (unicode) zlib -libedit% -pcre16 -pcre32% -static-libs" 1,408 kB
[ebuild     U  ] app-admin/eselect-php-0.7.1 [0.6.2] USE="apache2%* -fpm%" 3 kB
[ebuild     U  ] dev-lang/php-5.4.17:5.4 [5.4.13:5.4] USE="apache2 bzip2 cli ctype exif fileinfo filter gd gdbm hash iconv posix readline simplexml truetype unicode xml zlib -bcmath -berkdb -calendar -cdb -cgi -cjk -crypt -curl -curlwrappers -debug -embed -enchant -firebird -flatfile -fpm (-frontbase) -ftp -gmp -imap -inifile -intl -iodbc -ipv6 -json -kerberos -ldap -ldap-sasl -libedit -mhash -mssql -mysql -mysqli -mysqlnd -nls -oci8-instant-client -odbc -pcntl -pdo -phar -postgres -qdbm -recode (-selinux) -session -sharedmem -snmp -soap -sockets -spell -sqlite -ssl (-sybase-ct) -sysvipc -threads -tidy -tokenizer -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xslt% -zip (-doc%) (-xsl%)" 11,424 kB
[blocks b      ] <dev-lang/php-5.4.13-r1:5.4 ("<dev-lang/php-5.4.13-r1:5.4" is blocking app-admin/eselect-php-0.7.1)

Total: 3 packages (3 upgrades), Size of downloads: 12,833 kB
Conflict: 1 block


Thanks very much for any enlightenment.
ElleStone


Last edited by ElleStone on Fri Jul 26, 2013 9:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
ElleStone
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2013
Posts: 91

PostPosted: Thu Jul 25, 2013 11:18 pm    Post subject: Reply with quote

Hmm, possibly I might have gotten past this "block" problem. I'll post tomorrow if I did, what the solution was, and if not, what the remaining problem seems to be.
Back to top
View user's profile Send private message
ElleStone
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2013
Posts: 91

PostPosted: Fri Jul 26, 2013 9:31 pm    Post subject: Reply with quote

I have a pretty good idea of why there was a block, though no clue as to why php in particular was involved. I had installed the latest version of Blender, which meant installing a more recent version of python. Something else installed an even later version of python. The way out was to uninstall several programs, including Blender and everything that depended on python 3.3. Then reinstall those other programs, but not Blender as Blender froze my computer up and I don't feel like figuring out why. Anyway, I got back to "no blocks" by the usual method of installing small subsets of all the programs that "emerge -pv --update --newuse --deep --with-bdeps=y @world", each time tracking down issues.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum