Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.10-rc3-bk15-ck2-nitro2 "Too Fast For Your Eyes"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
YourDoom123
Apprentice
Apprentice


Joined: 06 Mar 2004
Posts: 163

PostPosted: Thu Dec 23, 2004 5:56 am    Post subject: Reply with quote

nope... didn't work... it wouldn't emerge after i deleted the digest files, so i remade those and ran the emerge only to run into the exact same problem.... i'm gonna use ck-sources for (it has reiser4 support right?)
_________________
Acer Aspire 5672
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Thu Dec 23, 2004 6:50 am    Post subject: Reply with quote

You have to emerge it with emerge --digest to recreate the digest file.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
YourDoom123
Apprentice
Apprentice


Joined: 06 Mar 2004
Posts: 163

PostPosted: Thu Dec 23, 2004 6:54 am    Post subject: Reply with quote

i'll try it tomorrow... mm-sources had the reiser4 support so i went with that. i'll try yours tom.
_________________
Acer Aspire 5672
Back to top
View user's profile Send private message
vrln
Guru
Guru


Joined: 11 Sep 2004
Posts: 534
Location: Finland

PostPosted: Thu Dec 23, 2004 11:02 am    Post subject: Reply with quote

what kernel is the reiser4 support from? 2.6.10-rc3-mm1 or is it a snapshot from the namesys site? A tarball md5sum would be nice too.

Other than that, looks interesting :)


Last edited by vrln on Thu Dec 23, 2004 12:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
ericsson
n00b
n00b


Joined: 08 Oct 2004
Posts: 24

PostPosted: Thu Dec 23, 2004 11:50 am    Post subject: 2.6.10-rc3-bk15-ck2-nitro2 "Too Fast For Your Eyes" Reply with quote

Hello,

Anybody else having trouble emerging nvidia-kernel ?
Back to top
View user's profile Send private message
Xylene
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2003
Posts: 111

PostPosted: Thu Dec 23, 2004 1:10 pm    Post subject: Reply with quote

Nice. I just compiled and booted into the other nitro you released the other day (which btw worked perfectly for me). I'll give this a try when I get home.
Back to top
View user's profile Send private message
Macumba
Tux's lil' helper
Tux's lil' helper


Joined: 13 Sep 2004
Posts: 112

PostPosted: Thu Dec 23, 2004 2:27 pm    Post subject: Reply with quote

compiled and it runs...
Code:

                              Gentoo Linux 1.6.8
       Linux 2.6.10-rc3-nitro2, Compiled #1 Thu Dec 23 15:16:20 CET 2004
            One AMD Athlon 64 2.41GHz CPU, 1GB RAM, 4767.74 Bogomips
                            Uptime 0 hours 0 minutes
                                      tux

I don't have probs with the latest nvidia-drivers
_________________
Code:
dd if=/dev/urandom of=/dev/speech

ogg - mp3
Back to top
View user's profile Send private message
Zyne
Guru
Guru


Joined: 08 Jun 2004
Posts: 334

PostPosted: Thu Dec 23, 2004 2:32 pm    Post subject: Reply with quote

Xylene wrote:
Nice. I just compiled and booted into the other nitro you released the other day (which btw worked perfectly for me). I'll give this a try when I get home.



I'll do the same thing now... :)
the previous kernel has now been running for about 16 hours...
I've compiled firefox in the mean time, and let matlab run a pretty heavy algorithm...
all is still working fine! :)

thanks again for you hard work though m8! I'll compile it in a few seconds..


Z
Back to top
View user's profile Send private message
M@rijn
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2004
Posts: 145
Location: Zierikzee (The Netherlands)

PostPosted: Thu Dec 23, 2004 3:08 pm    Post subject: Reply with quote

Why aren't the ebuilds in portage :) It isn't easy for me to download it etc. etc. I want it back in portage :P :P
_________________
Gentoo is just an Aston Martin, "Power, beauty and soul"
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Thu Dec 23, 2004 3:24 pm    Post subject: Reply with quote

M@rijn wrote:
Why aren't the ebuilds in portage :) It isn't easy for me to download it etc. etc. I want it back in portage :P :P


It was (and may still be) on one server in germany.

However, this has been discussed to death many times on the forums (which you probably don't know about)...

The basic answer is that any patchset not officially sanctioned by Gentoo will not go into portage. This includes nitro, love, vivid, evil, onion, etc, etc, etc, etc.

Why? Because the devs and maintainers have enough problems without new problems to deal with when they had nothing to do with it. It is a sensible solution in my opinion but if you want to discuss it more please do a search and add to the threads already on the forums. I would also point out that most of the patchset makers that I know would not want to burden the developers with any problems created by their own patchset.

But that is why we have a portage overlay, and it only needs a quick download of an ebuild into the portage overlay and then emerge it (quicker than an emerge sync if you think about it).

HTH :D
_________________
usefuljaja.com - VPS Tutorials
Back to top
View user's profile Send private message
ashtophet
Guru
Guru


Joined: 08 Aug 2004
Posts: 396
Location: Galiza

PostPosted: Thu Dec 23, 2004 3:40 pm    Post subject: Reply with quote

Well my first attempt with this kernel patchset series... Booted smoothly, let's see... ;)

nvidia proprietary drivers compile and run fine, also vmware.

cheers
_________________
O coração, se pudesse pensar, pararia. Fernando Pessoa
If heart could think, it would stop
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Thu Dec 23, 2004 3:43 pm    Post subject: Reply with quote

yeah everything compiled fine with out the orinoco drivers, but with them, the compile failed, I also couldnt use the orinoco modules from the dev site
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
djh-world
Apprentice
Apprentice


Joined: 04 Jan 2004
Posts: 281
Location: Nottingham, UK

PostPosted: Thu Dec 23, 2004 7:05 pm    Post subject: Reply with quote

Just booted into this new kernel.

Pretty smooth so far, and the ati-drivers patch worked a treat.

Good work!
_________________
djh-solutions :: freelance web design | solution provider
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Thu Dec 23, 2004 7:09 pm    Post subject: Reply with quote

BTW. What's keeping the new love release?

@Darckness Sorry about last night, got called away, just came back online. Glad to see you already fixed it yourself :)
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Thu Dec 23, 2004 8:14 pm    Post subject: Reply with quote

vrln: the reiser4 patch is from namesys.

md5sum: a33283a68b01e337494d7583df7237a4
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 466

PostPosted: Fri Dec 24, 2004 6:40 am    Post subject: Reply with quote

I get this error when trying to compile:
Code:
Cannot open 'n' (CONFIG_INITRAMFS_SOURCE)

Happens with the vanilla 2.6.10-rc3 sources also.I am using an old .config file but I am running make clean and make oldconfig so should be no issues there.The message is also very cryptic,and I have no idea what driver or config option may be causing this or if it could be something on my system affecting this.I have seen one mention of this through a google but nobody answered him so that was no help.I am using debian unstable along with a mix of various source-compiled programs/libs/kernel,although I doubt that information would be of any use.I am not running a 64-bit kernel,in case anyone asks.

Thanks

EDIT:Figured it out .For anyone else search for :
Code:
 CONFIG_INITRAMFS_SOURCE=""

And check to see if anything is inserted between the quotes.I must of hit 'n' instead of just hitting 'enter' for a blank value,which is the default option.]
Back to top
View user's profile Send private message
MyKillK
n00b
n00b


Joined: 13 Dec 2004
Posts: 33
Location: Bakersfield, CA

PostPosted: Fri Dec 24, 2004 7:21 am    Post subject: Reply with quote

I'm still getting the MKI_INIT_TASK compile errors

I downloaded the ebuild to my /usr/local/portage overlay, and then ran emerge --digest nitro-sources

Is this correct? I previously was using the last nitro kernel.
_________________
Michael Koehmstedt
2.6.10 Nitro
Xfce4.2 RC3
Back to top
View user's profile Send private message
MyKillK
n00b
n00b


Joined: 13 Dec 2004
Posts: 33
Location: Bakersfield, CA

PostPosted: Fri Dec 24, 2004 7:38 am    Post subject: Reply with quote

Oh whoops, I didn't delete the patch file in the distfiles directory.

It compiles fine now. Thanks for the fantastic kernel!
_________________
Michael Koehmstedt
2.6.10 Nitro
Xfce4.2 RC3
Back to top
View user's profile Send private message
Guinpen
Guru
Guru


Joined: 08 Dec 2004
Posts: 393

PostPosted: Fri Dec 24, 2004 7:58 am    Post subject: Reply with quote

Hello,
It's probably not right place to spam, but I was wondering - if all those "third-party" patchsets are not official and not on portage, then:
1. How do I download/install/use them?
2. Is there a place where I can read descriptions of the strengths / weaknesses of each? Some could be made for servers, others for gaming, who knows....
Thanks!
Back to top
View user's profile Send private message
snake111
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2004
Posts: 113

PostPosted: Fri Dec 24, 2004 6:26 pm    Post subject: Reply with quote

I've problems applying patch manually: i start from a vanilla 2.6.9, than patch with vanilla 2.6.10-rc3 and then apply nitro patch.

If i do "make menuconfig" i can see at the top of the screen "linux-2.6.10-nitro2" but i can't see ReiserFS 4 options in "file systems" and also if i compile the kernel i'll have Kernel panic because it can't mount root partition (Reiser4).

Where i'm wrong?
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Fri Dec 24, 2004 6:41 pm    Post subject: Reply with quote

the vanilla kernel from kernel.org differs slightly from the kernel on the gentoo mirrors. Nitro is patched against the latter one.

Which did you use?

If you save the options do you have a REISER4_FS entry in your .config?
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
snake111
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2004
Posts: 113

PostPosted: Fri Dec 24, 2004 7:23 pm    Post subject: Reply with quote

i didn't save my option :(

i used kernel from kernel.org! can you post a link for a valid kernel?

thank you!
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Fri Dec 24, 2004 7:32 pm    Post subject: Reply with quote

just download the ebuild and patch, thats all u need to do
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
nejiron
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 95
Location: U.S.A.

PostPosted: Fri Dec 24, 2004 8:56 pm    Post subject: Reply with quote

it fails to compile for me, gets some errors with the Orinoco drivers. also, i dont see the reiser4 option either
_________________
I am a traveler of both time and space
Back to top
View user's profile Send private message
nejiron
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 95
Location: U.S.A.

PostPosted: Fri Dec 24, 2004 9:22 pm    Post subject: Reply with quote

found why it didnt display the reiser 4 option, i had to remove the selection for 4kb stacks
_________________
I am a traveler of both time and space
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum