Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200412-16 ] kdelibs, kdebase: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4087
Location: Dresden, Germany

PostPosted: Sun Dec 19, 2004 3:11 pm    Post subject: [ GLSA 200412-16 ] kdelibs, kdebase: Multiple vulnerabilitie Reply with quote

Gentoo Linux Security Advisory

Title: kdelibs, kdebase: Multiple vulnerabilities (GLSA 200412-16)
Severity: normal
Exploitable: remote and local
Date: December 19, 2004
Bug(s): #72804, #73869
ID: 200412-16

Synopsis

kdelibs and kdebase contain a flaw allowing password disclosure when creating a link to a remote file. Furthermore Konqueror is vulnerable to window injection.

Background

KDE is a feature-rich graphical desktop environment for Linux and Unix-like Operating Systems. The KDE core libraries (kdebase and kdelibs) provide native support for many protocols. Konqueror is the KDE web browser and filemanager.

Affected Packages

Package: kde-base/kdelibs
Vulnerable: < 3.3.2-r1
Unaffected: >= 3.2.3-r4 < 3.2.4
Unaffected: >= 3.3.1-r2 < 3.3.2
Unaffected: >= 3.3.2-r1
Architectures: All supported architectures

Package: kde-base/kdebase
Vulnerable: < 3.3.2-r1
Unaffected: >= 3.2.3-r3 < 3.2.4
Unaffected: >= 3.3.1-r2 < 3.3.2
Architectures: All supported architectures


Description

Daniel Fabian discovered that the KDE core libraries contain a flaw allowing password disclosure by making a link to a remote file. When creating this link, the resulting URL contains authentication credentials used to access the remote file (CAN 2004-1171). The Konqueror webbrowser allows websites to load webpages into a window or tab currently used by another website (CAN-2004-1158).

Impact

A malicious user could have access to the authentication credentials of other users depending on the file permissions. A malicious website could use the window injection vulnerability to load content in a window apparently belonging to another website.

Workaround

There is no known workaround at this time.

Resolution

All kdelibs users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=kde-base/kdelibs-3.2.3-r4"
All kdebase users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=kde-base/kdebase-3.2.3-r3"


References

KDE Security Advisory: plain text password exposure
CAN 2004-1171
KDE Security Advisory: Konqueror Window Injection Vulnerability
CAN 2004-1158


Last edited by GLSA on Sun May 07, 2006 4:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum