Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200412-15 ] Ethereal: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Sun Dec 19, 2004 2:57 pm    Post subject: [ GLSA 200412-15 ] Ethereal: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Ethereal: Multiple vulnerabilities (GLSA 200412-15)
Severity: high
Exploitable: remote
Date: December 19, 2004
Bug(s): #74443
ID: 200412-15

Synopsis

Multiple vulnerabilities exist in Ethereal, which may allow an attacker to run arbitrary code, crash the program or perform DoS by CPU and disk utilization.

Background

Ethereal is a feature rich network protocol analyzer.

Affected Packages

Package: net-analyzer/ethereal
Vulnerable: < 0.10.8
Unaffected: >= 0.10.8
Architectures: All supported architectures


Description

There are multiple vulnerabilities in versions of Ethereal earlier than 0.10.8, including:
  • Bug in DICOM dissection discovered by Bing could make Ethereal crash (CAN 2004-1139).
  • An invalid RTP timestamp could make Ethereal hang and create a large temporary file (CAN 2004-1140).
  • The HTTP dissector could access previously-freed memory (CAN 2004-1141).
  • Brian Caswell discovered that an improperly formatted SMB could make Ethereal hang (CAN 2004-1142).


Impact

An attacker might be able to use these vulnerabilities to crash Ethereal, perform DoS by CPU and disk space utilization or even execute arbitrary code with the permissions of the user running Ethereal, which could be the root user.

Workaround

For a temporary workaround you can disable all affected protocol dissectors by selecting Analyze->Enabled Protocols... and deselecting them from the list. However, it is strongly recommended to upgrade to the latest stable version.

Resolution

All ethereal users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-analyzer/ethereal-0.10.8"


References

Ethereal enpa-sa-00016
CAN 2004-1139
CAN 2004-1140
CAN 2004-1141
CAN 2004-1142


Last edited by GLSA on Sun May 07, 2006 4:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum