Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
hpijs error compiling on SPARC
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message

Joined: 12 Dec 2004
Posts: 5

PostPosted: Sun Dec 12, 2004 2:59 pm    Post subject: hpijs error compiling on SPARC Reply with quote

Hi everybody,

i've seen that hpijs 1.5 is marked stable so i tried to install it bat what i obtain is so:

bash-2.05b# emerge hpijs
Calculating dependencies ...done!
>>> emerge (1 of 1) net-print/hpijs-1.5 to /
>>> md5 src_uri ;-) hpijs-1.5.tar.gz
>>> md5 src_uri ;-) foomatic-db-hpijs-1.5-20031125.tar.gz
>>> Unpacking source...
>>> Unpacking hpijs-1.5.tar.gz to /var/tmp/portage/hpijs-1.5/work
>>> Unpacking foomatic-db-hpijs-1.5-20031125.tar.gz to /var/tmp/portage/hpijs-1.5/work
* Using GNU config files from /usr/share/libtool
* Updating config.sub [ ok ]
* Updating config.guess [ ok ]
* Applying hpijs-1.5-gcc34.patch ... [ ok ]
* Applying hpijs-1.4.1-rss.1.patch ... [ ok ]
>>> Source unpacked.
* econf: updating /var/tmp/portage/hpijs-1.5/work/hpijs-1.5/config.guess with /usr/share/gnuconfig/config.guess
* econf: updating /var/tmp/portage/hpijs-1.5/work/hpijs-1.5/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=sparc-unknown-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-cups-install --disable-foomatic-install
configure: WARNING: If you wanted to set the --build type, don't use --host.
If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking for sparc-unknown-linux-gnu-strip... sparc-unknown-linux-gnu-strip
checking for sparc-unknown-linux-gnu-gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking how to run the C preprocessor... gcc -E
checking for sparc-unknown-linux-gnu-g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking dependency style of g++... gcc3
checking for a BSD-compatible install... /bin/install -c
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking malloc.h usability... yes
checking malloc.h presence... yes
checking for malloc.h... yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking for unistd.h... (cached) yes
checking for gcc option to accept ANSI C... none needed
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether byte ordering is bigendian... yes
checking "which type of build"... release
checking "for unint32_t"... "found in stdint.h"
checking build system type... sparc64-unknown-linux-gnu
checking host system type... sparc-unknown-linux-gnu
checking "for platform-dependencies"... "using Default platform.h"
checking "for cups ppd path"... "using /usr/share/cups/model"
checking "for cups filter path"... "using /usr/lib/cups/filter"
checking "for cups install"... no
checking "for foomatic install"... no
checking for working memcmp... yes
checking for strtod... yes
checking for strtol... yes
checking for pow... no
checking for pow in -lm... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
source='hpijs.cpp' object='hpijs.o' libtool=no \
depfile='.deps/hpijs.Po' tmpdepfile='.deps/hpijs.TPo' \
depmode=gcc3 /bin/sh ./depcomp \
hpijs.cpp: In function `int main(int, char**)':
hpijs.cpp:583: internal compiler error: in get_loop_body, at cfgloop.c:1020
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:> for instructions.
Preprocessed source stored into /var/tmp/portage/hpijs-1.5/temp/ccKe95rC.out file, please attach this to your bugreport.
make: *** [hpijs.o] Error 1

!!! ERROR: net-print/hpijs-1.5 failed.
!!! Function src_compile, Line 39, Exitcode 2
!!! make failed
!!! If you need support, post the topmost build error, NOT this status message.

i tried to download other releases (youger, older ) but i get always the same error message.
Could anyone help me ?

Thaks anyway
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum