Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge update world doesn't update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
dice
Guru
Guru


Joined: 21 Apr 2002
Posts: 577

PostPosted: Thu May 16, 2002 9:34 am    Post subject: emerge update world doesn't update Reply with quote

So, I rust ran an emerge rsync...

Code:

somebox portage # emerge --version
Portage 1.9.11
somebox root # emerge --pretend update world

These are the packages that I would merge, in order.

Calculating world dependencies  ...done!

somebox root # emerge -s abiword
[ Results for search key : abiword ]
[ Applications found : 1 ]
 
*  app-office/abiword
      Latest version Available: 1.0.1
      Latest version Installed: 1.0.0
      Homepage: http://www.abisource.com
      Description:
      Text processor


It's not just AbiWord either, there's a couple other applications that I know need to be upgraded as well. Any clues as to what's going on? I've been able to do update world before, but recently it hasn't been updating and it was bothering me since I noticed that there were new/updated packages but I didn't really look into it untill now.
Back to top
View user's profile Send private message
kerframil
l33t
l33t


Joined: 19 Apr 2002
Posts: 710
Location: London, UK

PostPosted: Thu May 16, 2002 11:46 am    Post subject: Portage problems Reply with quote

Annoying, isn't it? Upgrade Portage to 1.9.12 and the problem should go away. And double-check abiword (for example) is in your /var/cache/edb/world file.
Back to top
View user's profile Send private message
dice
Guru
Guru


Joined: 21 Apr 2002
Posts: 577

PostPosted: Thu May 16, 2002 12:37 pm    Post subject: Re: Portage problems Reply with quote

kerframil wrote:
Annoying, isn't it? Upgrade Portage to 1.9.12 and the problem should go away. And double-check abiword (for example) is in your /var/cache/edb/world file.


:(

Code:

somebox root # emerge --version
Portage 1.9.12
somebox root # cat /var/cache/edb/world | grep abiword
app-office/abiword
somebox root # emerge --pretend update world

These are the packages that I would merge, in order.

Calculating world dependencies ...done!

somebox root # emerge -s abiword
[ Results for search key: abiword ]
[ Applications found : 1 ]

*  app-office/abiword
      Latest version Available: 1.0.1
      Latest version Installed: 1.0.0
      Homepage: http://www.abisource.com
      Description:
      Text processor
Back to top
View user's profile Send private message
DNH
n00b
n00b


Joined: 16 Apr 2002
Posts: 60
Location: Ann Arbor, MI

PostPosted: Thu May 16, 2002 2:21 pm    Post subject: Reply with quote

how about using "emerge --pretend --update world" Works for me.
_________________
The answer
Back to top
View user's profile Send private message
dArkMaGE
Apprentice
Apprentice


Joined: 20 Apr 2002
Posts: 152

PostPosted: Thu May 16, 2002 5:05 pm    Post subject: Reply with quote

does it only update the progs in your world file? i thought it updated everything in the world file plus dependencies.
Back to top
View user's profile Send private message
dice
Guru
Guru


Joined: 21 Apr 2002
Posts: 577

PostPosted: Thu May 16, 2002 9:32 pm    Post subject: Reply with quote

DNH wrote:
how about using "emerge --pretend --update world" Works for me.


This workes, but I swear I was using "emerge --pretend update world" before and it worked. I'm not crazy, I tells ya!

Did the syntax for this change recently?

Thanks, BTW :D
Back to top
View user's profile Send private message
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2379
Location: Wisconsin (USA)

PostPosted: Fri May 17, 2002 12:03 am    Post subject: Reply with quote

it's possible it used to be like that, because I know you can do "emerge unmerge xxxxx" at least
Back to top
View user's profile Send private message
Nitro
Bodhisattva
Bodhisattva


Joined: 08 Apr 2002
Posts: 661
Location: San Francisco

PostPosted: Fri May 17, 2002 12:25 am    Post subject: Reply with quote

dice wrote:
DNH wrote:
how about using "emerge --pretend --update world" Works for me.


This workes, but I swear I was using "emerge --pretend update world" before and it worked. I'm not crazy, I tells ya!

Did the syntax for this change recently?


Yeah, it was updated it a week or two ago, I'm not sure what version changed it. Your best friend is emerge --help. That seems to be most up-to-date.
_________________
- Kyle Manna

Please, please SEARCH before posting.

There are three kinds of people in the world: those who can count, and those who can't.
Back to top
View user's profile Send private message
Guest






PostPosted: Sun May 19, 2002 3:40 pm    Post subject: Reply with quote

Nitro wrote:
dice wrote:
DNH wrote:
how about using "emerge --pretend --update world" Works for me.


This workes, but I swear I was using "emerge --pretend update world" before and it worked. I'm not crazy, I tells ya!

Did the syntax for this change recently?


Yeah, it was updated it a week or two ago, I'm not sure what version changed it. Your best friend is emerge --help. That seems to be most up-to-date.


yeah... even man emerge isn't up to date... damn... that really suck :(
i searched that command for 2h wondering why the fuck it won't update, and i though about some command line change too, i did man emerge and nothing said about this
damn!! it's the most important tool of the system and the man is not up to date ? wtf ?
Back to top
BradN
Advocate
Advocate


Joined: 19 Apr 2002
Posts: 2379
Location: Wisconsin (USA)

PostPosted: Mon May 20, 2002 1:10 am    Post subject: Reply with quote

Yeah, they really should keep that updated.

--help is pretty much guaranteed to be accurate, if not especially descriptive though.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum