Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GRUB Install Walkthrough
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
s0be
Apprentice
Apprentice


Joined: 23 Nov 2002
Posts: 223

PostPosted: Wed Dec 18, 2002 8:33 pm    Post subject: GRUB Install Walkthrough Reply with quote

ok, when I installed Gentoo, I ran into issues with GRUB. The particular problem is that GRUB saw my IDE drive first, then my SCSI Drives, and my BIOS recognized my SCSI Drive first, so my MAP File in GENTOO was:

Code:

(fd0) /dev/floppy/0
(hd0) /dev/ide/host0/bus1/target0/lun0/disc
(hd1) /dev/ide/host2/bus0/target0/lun0/disc
(hd2) /dev/ide/host2/bus0/target1/lun0/disc
(hd3) /dev/ataraid/disc0/disc
(hd4) /dev/scsi/host0/bus0/target4/lun0/disc
(hd5) /dev/scsi/host0/bus0/target5/lun0/disc
(hd6) /dev/scsi/host2/bus0/target1/lun0/disc
(hd7) /dev/scsi/host2/bus0/target2/lun0/disc


Following are the steps I followed to solve this. This solution should work for ANY gentoo installation.

I made a grub Boot Disk and booted it. I went into command line mode and did root (hd then press tab and it'll show you a list of hd0 through hd7. I typed 0 making it (hd0 and press tab and it'll list the partitions and types. I repeated this until it listed the correct partitions and types for the drive I want to boot(that drive being hd4 for me)

Anyways, use the information you just got along with a map file (the format is:

Code:

(fd0) /dev/floppy/0
(hd4) /dev/ide/host0/bus1/target0/lun0/disc
(hd1) /dev/ide/host2/bus0/target0/lun0/disc
(hd2) /dev/ide/host2/bus0/target1/lun0/disc
(hd3) /dev/ataraid/disc0/disc
(hd0) /dev/scsi/host0/bus0/target4/lun0/disc
(hd5) /dev/scsi/host0/bus0/target5/lun0/disc
(hd6) /dev/scsi/host2/bus0/target1/lun0/disc
(hd7) /dev/scsi/host2/bus0/target2/lun0/disc

(that's my map file after corrections, the 0 and 4 switched positions)

make sure your map file agrees with what you found when you did the grub boot disk. Now modify your grub.conf and redo your root and install steps. My grub.conf file has:

Code:

default 2
timeout 10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo 2.4.20-ck1.19(safe)
root(hd0,0)
kernel /boot/gentoo-happy


and everything works fine after doing:

Code:

root (hd0,0)
setup  (hd4)


from grub in gentoo.
good luck.

s0be
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7209
Location: Pelotas, BR

PostPosted: Wed Dec 18, 2002 11:28 pm    Post subject: Reply with quote

Moved to Documentation, Tips & Tricks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum