Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200412-01 ] rssh, scponly: Unrestricted command execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7225
Location: Pelotas, BR

PostPosted: Fri Dec 03, 2004 4:54 pm    Post subject: [ GLSA 200412-01 ] rssh, scponly: Unrestricted command execu Reply with quote

Gentoo Linux Security Advisory

Title: rssh, scponly: Unrestricted command execution (GLSA 200412-01)
Severity: normal
Exploitable: remote
Date: December 03, 2004
Updated: May 22, 2006
Bug(s): #72815, #72816
ID: 200412-01

Synopsis

rssh and scponly do not filter command-line options that can be exploited to execute any command, thereby allowing a remote user to completely bypass the restricted shell.

Background

rssh and scponly are two restricted shells, allowing only a few predefined commands. They are often used as a complement to OpenSSH to provide access to remote users without providing any remote execution privileges.

Affected Packages

Package: net-misc/scponly
Vulnerable: < 4.0
Unaffected: >= 4.0
Architectures: All supported architectures

Package: app-shells/rssh
Vulnerable: <= 2.2.2
Unaffected: >= 2.2.3
Architectures: All supported architectures


Description

Jason Wies discovered that when receiving an authorized command from an authorized user, rssh and scponly do not filter command-line options that can be used to execute any command on the target host.

Impact

Using a malicious command, it is possible for a remote authenticated user to execute any command (or upload and execute any file) on the target machine with user rights, effectively bypassing any restriction of scponly or rssh.

Workaround

There is no known workaround at this time.

Resolution

All scponly users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/scponly-4.0"
All rssh users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=app-shells/rssh/rssh-2.2.3"


References

BugTraq Posting
CVE-2004-1161
CVE-2004-1162


Last edited by GLSA on Sat Aug 23, 2008 4:17 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum