Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Проблема в кде с smb протоколом
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
dsch
n00b
n00b


Joined: 23 Nov 2004
Posts: 5

PostPosted: Tue Nov 23, 2004 1:06 pm    Post subject: Проблема в кде с smb протоколом Reply with quote

Суть проблемы, что под КДЕ не работают ссылки вида smb://
Собственно изучая эту тему в инете я поял суть проблемы, но не могу понять, как ее решить.
При собирании кде не образуется библиотека kio_smb.so в класическом варианте сбора нужно в конфигурации указать libsmbclient и все будет нормально, в генте я в переменной use указал samba , но это не помогло.
В англоязычных форумах пробегало, что это стандартный баг самбы выше 3.0.8 и кде 3.3.1 но нигде не сказанно как это лечится.

Теперь конкретика по моему случаю
Samba 3.0.8
KDE 3.3.1
Ошибка, которая генерится в конгуероре
Could not start process Unable to create io-slave:
klauncher said: Unknown protocol 'smb'.

Самба настроена и успешно работает, работают как шары так и монтирование виртуальной файловой системы. Понятно, что можно намонтировать все ресурсы (что я и сделал) и спокойно работать, но хотелось бы сделать все нормально.
Заранее спасибо за ответы.
Дмитрий.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Tue Nov 23, 2004 1:53 pm    Post subject: Reply with quote

Хм, я не помню, который из пакетов kde отвечал за работу с протоколами, то-ли kdelibs, то-ли kdebase. Судя по выводу emerge -pv kde, это kdebase.

Посмотри содержимое kdebase так: qpkg -l kdebase.

Затем я бы посмотрел все библиотеки на предмет наличия libsmbclient в списке динамических библиотек, типа так: ldd <path-2-kde-lib>.

Проверь, может стоит kdebase пересобрать.
Back to top
View user's profile Send private message
dsch
n00b
n00b


Joined: 23 Nov 2004
Posts: 5

PostPosted: Tue Nov 23, 2004 4:04 pm    Post subject: Reply with quote

Библиотека действительно находится в kdebase и называется kio_smb.so в его сырцах она есть, но при установки не собирается. Установка флага use samba ни к чему не привели.

Исходя из этого вопрос, возможно ли как-то повлиять на процесс сборки кдебэйса руками, ну типа чтонть поправить в портаджах или установить еще какойнть юз.

Насколько я понима/ эта проблема именно кде версии 3.3.1, поэтому попутный вопрос у тех, кто эту версию ставил, это чисто моя проблема или так у всех.

Я вот раскопал такой диалог https://bugs.gentoo.org/show_bug.cgi?id=70925
но вот так и не понял можно ли это как-то решить.
Back to top
View user's profile Send private message
viy
Veteran
Veteran


Joined: 03 Jul 2004
Posts: 1580
Location: Riga, Latvia

PostPosted: Tue Nov 23, 2004 4:23 pm    Post subject: Reply with quote

Может поможет: перед сборкой kdebase сделай export LIBS="-lsmbclient".
Back to top
View user's profile Send private message
dsch
n00b
n00b


Joined: 23 Nov 2004
Posts: 5

PostPosted: Tue Nov 23, 2004 7:28 pm    Post subject: Reply with quote

Вобщем откатился на 3.3.0 и все стало нормально, видимо придется ждать следующих версий кде, где все будет нормально.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum