Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] apache2 problems after upgrade
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
opoc
n00b
n00b


Joined: 22 Apr 2005
Posts: 4

PostPosted: Wed Nov 30, 2005 11:48 am    Post subject: [Solved] apache2 problems after upgrade Reply with quote

Hi
There seem to be a lot of messages re. apache2 - I have been searching for some time but found no answer to my problem.

I recently upgraded to Apache 2.0.54-r31. Now, it starts fine but when I try to access localhost I get a 404 error, which is not surprising looking at the error log, as my DocumentRoot is /var/www/localhost/htdocs and not /usr/htdocs where it seems to be being looked for. Now, I can't find anywhere where the DocumentRoot is set as /usr/htdocs. Can anyone give me an idea? Sorry if it something I should be aware of or that has been discussed elsewhere but.... :?

kind regards


[Wed Nov 30 11:26:40 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Wed Nov 30 11:26:41 2005] [notice] Digest: generating secret for digest authentication ...
[Wed Nov 30 11:26:41 2005] [notice] Digest: done
[Wed Nov 30 11:26:41 2005] [notice] Apache configured -- resuming normal operations
[Wed Nov 30 11:26:52 2005] [error] [client 127.0.0.1] File does not exist: /usr/htdocs
[Wed Nov 30 11:26:52 2005] [error] [client 127.0.0.1] File does not exist: /usr/htdocs


Last edited by opoc on Wed Nov 30, 2005 12:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ctrl+Alt+Del
Guru
Guru


Joined: 04 Jul 2004
Posts: 326
Location: .de

PostPosted: Wed Nov 30, 2005 12:36 pm    Post subject: Reply with quote

add APACHE2_OPTS="-D DEFAULT_VHOST" to /etc/conf.d/apache
Back to top
View user's profile Send private message
opoc
n00b
n00b


Joined: 22 Apr 2005
Posts: 4

PostPosted: Wed Nov 30, 2005 12:54 pm    Post subject: apache2 problems after upgrade Reply with quote

Ctrl+Alt+Del wrote:
add APACHE2_OPTS="-D DEFAULT_VHOST" to /etc/conf.d/apache


Thank you very much, added above to apache2 and it did the trick. :lol:

regards
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum