Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] gnomeapplet Python module required to build deskbar
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Fri Sep 14, 2007 6:34 pm    Post subject: [SOLVED] gnomeapplet Python module required to build deskbar Reply with quote

Hello,

i try to install gnome-extra/deskbar-applet-2.19.90.1 (gnome-experimental overlay) and i'm falling on the fllowing error:
Code:

checking for gnomeapplet module... no
configure: error: gnomeapplet Python module required to build deskbar


the error in /var/tmp/portage/gnome-extra/deskbar-applet-2.19.90.1/work/deskbar-applet-2.19.90.1/config.log:
Code:

configure:23082: checking for gnomeapplet module
configure:23092: DISPLAY= $PYTHON -c '
try:
    import gnomeapplet
except ImportError, e:
    if str(e).find("gnomeapplet") >= 0:
          raise
except:
    pass
'
Traceback (most recent call last):
  File "<string>", line 3, in <module>
ImportError: No module named gnomeapplet
configure:23103: $? = 1
configure:23108: result: no
configure:23110: error: gnomeapplet Python module required to build deskbar


i've made an 'emerge --depclean --pretend' and tested all the unnecessary packages with 'equery d' so, the system seems clean now

i've reinstalled the following ebuilds but the problem is the same:
Code:

dev-lang/python-2.5.1-r2
dev-python/gnome-python-2.19.2
dev-python/gnome-python-desktop-2.19.2
dev-python/gnome-python-extras-2.19.1
gnome-base/gnome-panel-2.19.92
gnome-base/gnome-applets-2.19.91


'revdep-rebuild -p -i' doesn't find any problem
'python-updater' have no effect because i've only the 2.5.1-r2 version installed

for information, i've three other package i can't install but with a different error:
dev-libs/fribidi-0.19
net-misc/ntp-4.2.5_p72
dev-cpp/libgnomecanvasmm-2.16.0

i've deleted the /var/tmp/ccache and /var/tmp/portage/ directories, identical problem.

here is my emerge --info:
Code:

Portage 2.1.3.9 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.21-gentoo-r2-g1cb51f48-dirty i686)
=================================================================
System uname: 2.6.21-gentoo-r2-g1cb51f48-dirty i686 AMD Athlon(tm) XP 2800+
Timestamp of tree: Fri, 14 Sep 2007 04:50:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.modulix.net/gentoo/ http://ftp.club-internet.fr/pub/mirrors/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo "
LANG="C"
LC_ALL="C"
LINGUAS="en fr fr_FR"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/webapps-experimental /usr/portage/local/layman/x11 /usr/portage/local/layman/gnome-experimental /usr/portage/local/layman/gentopia /usr/portage/local/layman/genstef /usr/portage/local/layman/kde-experimental /usr/portage/local/layman/kde /usr/portage/local/layman/sunrise /usr/portage/local/layman/xeffects /usr/portage/local/layman/zugaina /usr/portage/local/layman/ecatmur /usr/portage/local/layman/hanno-xgl /usr/portage/local/layman/mpd /usr/portage/local/layman/lapis /usr/portage/local/gnome-experimental /usr/portage/local/ebuildexchange /usr/portage/local/overlay_perso /usr/portage/local/overlay"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d a52 aac aiglx alsa apache2 artworkextrai asf bash-completion berkdb bitmap-fonts bonjour bzip2 cairo cdr cli console cpudetection cracklib crypt cups dbus dmi dri dts dv dvd dvdnav dvdr dvdread dvi dxr3 emerald exif ffmpeg fortran ftp fuse gdbm gif glitz gnome gnutls gpm gstreamer gtk gtk-doc hal iconv imagemagick isdnlog ithreads java javascript jikes jpeg kde kdrive libnotify libsexy lm_sensors logitech-mouse lzo mbox meanwhile midi mjpeg mmx mono mp3 mpeg msn mudflap musepack music mysql nautilus ncurses new-login nls nptl nptlonly ogg ole opengl openmp pam pcre pda pdf perl php png pppd ps python quicktime readline real realmedia reflection samba sasl sensord server session sndfile sockets spamassassin spell spl sse ssl startup-notification svg swat symlink tcpd theora threads tiff toolbar truetype truetype-fonts type1-fonts unicode upnp userlocales utempter v4l vanilla vidix vim-syntax vorbis win32codecs wmf wmp wxwindows x x264 x86 xlib xml xorg xv xvid xvmc zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en fr fr_FR" USERLAND="GNU" VIDEO_CARDS="nv vesa vga nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


i've searched through google but can't find any actions that i've not made yet.
any advices?

regards,
mobidyc


Last edited by mobidyc on Fri Sep 14, 2007 7:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
mobidyc
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 109

PostPosted: Fri Sep 14, 2007 7:33 pm    Post subject: [SOLVED] gnomeapplet Python module required to build deskbar Reply with quote

i've searched a solution for two days without success, finally, i've posted a message on this forum.

and now...i've just found the problem.
when i've installed pygtk, i've not seen the following errors:
/usr/lib/python2.5/site-packages/pygtk.py is symlink and points to pygtk.py
/usr/lib/python2.5/site-packages/pygtk.pth is also symlink and points to pygtk.pth

a simple :
emerge -avt pygobject pygtk

and i can install deskbar-applet.

hope this solution can help people ;)

regards,
mobidyc
Back to top
View user's profile Send private message
hefest
n00b
n00b


Joined: 03 Mar 2006
Posts: 13

PostPosted: Sat Sep 29, 2007 8:59 am    Post subject: Reply with quote

Mobydic, you made my day. :)

However, I'd still like to know: should the deskbar applet have declared a dependency on the other two packages or was the problem caused by something else?
_________________
Not a single drop of rain will accept the blame for the flood.
Back to top
View user's profile Send private message
phoe
n00b
n00b


Joined: 27 Nov 2004
Posts: 15
Location: canada

PostPosted: Thu Nov 01, 2007 7:03 pm    Post subject: thanks! Reply with quote

thanks so much! I was busy trying to find the source of this problem when I found this - I agree, the dependencies should be updated so one dosent have to guess what should be upgraded next - thats the whole purpose of the portage system in the first place!
Back to top
View user's profile Send private message
Bombe
n00b
n00b


Joined: 07 Jul 2004
Posts: 21
Location: Hamburg, Germany

PostPosted: Wed Nov 07, 2007 11:29 am    Post subject: Reply with quote

I needed to update dev-python/gnome-python-desktop before desktop-applets would finally compile.
Back to top
View user's profile Send private message
smitty_one_each
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2004
Posts: 94
Location: Right coast, halfway up

PostPosted: Sun Feb 03, 2008 10:15 pm    Post subject: Props Reply with quote

Bombe wrote:
I needed to update dev-python/gnome-python-desktop before desktop-applets would finally compile.

You exorcised my demon.
You exercised my daemon.
_________________
I'm just looking for clues at the scene of the crime.--Walsh
Back to top
View user's profile Send private message
aminalshmu
Tux's lil' helper
Tux's lil' helper


Joined: 13 Sep 2004
Posts: 78
Location: Tallahassee, Florida, USA

PostPosted: Sun May 17, 2009 9:06 pm    Post subject: Re: [SOLVED] gnomeapplet Python module required to build des Reply with quote

mobidyc wrote:

a simple :
emerge -avt pygobject pygtk

and i can install deskbar-applet.

hope this solution can help people ;)


you did! though not sure why this bug should still be around. trying to emerge gnome on ~amd64, still have a few packages to get through before gnome-base/gnome-2.24.1 will make it into /var/lib/portage/world though... =)

edit: maybe i will try gnome overlay from layman... also... 69th post, w00t w00t hehe
Back to top
View user's profile Send private message
linear
Apprentice
Apprentice


Joined: 12 Aug 2004
Posts: 220

PostPosted: Thu May 21, 2009 1:00 am    Post subject: Reply with quote

Well, I think it might have something to do with the following:
Code:
localhost ~ # emerge -pv gnome-applets-python gnome-desktop-python

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-python/gnome-applets-python-2.24.1  USE="-debug -examples" 0 kB
[ebuild   R   ] dev-python/gnome-desktop-python-2.24.1  USE="-debug" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB
localhost ~ # emerge -pv gnome-python-desktop

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-python/gnome-python-desktop-2.24.1  0 kB

Total: 1 package (1 new), Size of downloads: 0 kB
localhost ~ #


Now, how would you know what you needed?

As a note, I have tried all of the above so far and I'm still getting a failure. The core of my issue seems to be shown here in the config.log:
Code:
configure:23562: checking for python
configure:23580: found /usr/bin/python
configure:23592: result: /usr/bin/python
configure:23612: checking for python version
configure:23619: result: 2.5
configure:23631: checking for python platform
configure:23638: result: linux2
configure:23645: checking for python script directory
configure:23653: result: ${prefix}/lib64/python2.5/site-packages
configure:23662: checking for python extension module directory
configure:23670: result: ${exec_prefix}/lib64/python2.5/site-packages
configure:23684: checking for headers required to compile python extensions
configure:23708: x86_64-pc-linux-gnu-gcc -E  -I/usr/include/python2.5 conftest.c
configure:23715: $? = 0
configure:23720: result: found
configure:23833: checking for DESKBAR
configure:23846: $PKG_CONFIG --exists --print-errors "gtk+-2.0                          >= 2.12
        pygtk-2.0                               >= 2.12
        pygobject-2.0                   >= 2.12
        gnome-python-2.0                >= 2.10
        gnome-desktop-2.0               >= 2.10
        dbus-python                             >= 0.80.2
"
configure:23855: $? = 0
configure:23880: $PKG_CONFIG --exists --print-errors "gtk+-2.0                          >= 2.12
        pygtk-2.0                               >= 2.12
        pygobject-2.0                   >= 2.12
        gnome-python-2.0                >= 2.10
        gnome-desktop-2.0               >= 2.10
        dbus-python                             >= 0.80.2
"
configure:23889: $? = 0
configure:23996: result: yes
configure:24003: checking for gnomeapplet module
configure:24018: DISPLAY= $PYTHON -c '
import pygtk
pygtk.require("2.0")
import gtk
gtk.gdk.threads_init()

try:
    import gnomeapplet
except ImportError, e:
    if str(e).find("gnomeapplet") >= 0:
          raise
except:
    pass
'
Traceback (most recent call last):
  File "<string>", line 4, in <module>
  File "//usr/lib64/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
ImportError: No module named cairo
configure:24034: $? = 1
configure:24039: result: no
configure:24041: error: gnomeapplet Python module required to build deskbar


Any thoughts?
Back to top
View user's profile Send private message
linear
Apprentice
Apprentice


Joined: 12 Aug 2004
Posts: 220

PostPosted: Thu May 21, 2009 4:53 pm    Post subject: Reply with quote

Got it...

But again, the dependencies in Python really need to be checked and fixed!

The error was coming from needing to update pycairo. Nowhere in the output there does it even mention pycairo. And it's not a requirement when it's doing the checks of versions right above the failure.

Well, at least I have it built and just about finished with this bloody update!

HTH others.
Back to top
View user's profile Send private message
suprafluid
n00b
n00b


Joined: 07 Jan 2011
Posts: 25
Location: Deep in the Bavarian Forrest, Germany

PostPosted: Fri Sep 02, 2011 8:13 am    Post subject: Reply with quote

Sorry to bother you all again with this gnome-applet story... but during my decent emerge world action, I did not get this "gnome-extra/deskbar-applet" installed. I tried revdep-rebuild, python-updater, re-emerging several packages, but it still says:

Code:

checking for gnomeapplet module... no
configure: error: gnomeapplet Python module required to build deskbar


I re-emerged

dev-python/pygtk
dev-python/pygobject
gnome-applets-python
gnome-desktop-python

Code:

[ebuild   R    ] dev-python/pygtk-2.24.0-r1  USE="-doc -examples -test" 0 kB
[ebuild   R    ]  dev-python/pygobject-2.28.6  USE="cairo introspection -doc -examples -libffi -test" 0 kB
[ebuild   R    ] dev-python/gnome-applets-python-2.32.0  USE="-examples" 0 kB
[ebuild   R    ] dev-python/gnome-desktop-python-2.32.0  0 kB


emerge --info

Code:

Portage 2.1.10.11 (default/linux/x86/10.0/desktop/gnome, gcc-4.4.5, glibc-2.12.2-r0, 2.6.36.2 i686)
=================================================================
System uname: Linux-2.6.36.2-i686-Intel-R-_Pentium-R-_D_CPU_3.40GHz-with-gentoo-2.0.3
Timestamp of tree: Thu, 01 Sep 2011 07:30:01 +0000
distcc 3.1 i686-pc-linux-gnu [disabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: embedded-cross gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.halifax.rwth-aachen.de/gentoo/ ftp://ftp6.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de_DE"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/embedded-cross /usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aiglx alsa aoss asf avi beagle berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus device-mapper dri dts dvd dvdr eds emboss encode evo exif extensions extras fam firefox flac fortran gdbm gdu gif glitz gnome gnome-keyring gpm gstreamer gtk iconv java jpeg kdrive kerberos lcms ldap libnotify mad mng modules mono mp3 mp4 mpeg mudflap nautilus nautlius ncurses new-login nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png policykit ppds pppd python qt3support qt4 readline sdl session spell sqlite ssl startup-notification static-libs svg symlink sysfs tcpd threads tiff toolbar truetype udev unicode usb vidix vorbis win32codecs winbind x264 x86 xcb xcomposite xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de_DE" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Any hints what to do or what to check?

Kind regards
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum