Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.9-nitro4 "Less is more"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Thu Dec 09, 2004 5:35 pm    Post subject: Reply with quote

thanx i will try :)
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
Jengu
Guru
Guru


Joined: 28 Oct 2004
Posts: 383

PostPosted: Sat Dec 11, 2004 12:57 am    Post subject: Reply with quote

MrApples wrote:
Jengu wrote:
I'd like to see the orinoco patch put back in. Doesn't cause any harm and saves me trouble =)
i think seppe provided it separately, he was going for a more stripped down nitro, so patches like orinoco can be added if needed by the user


Where? I've looked around a little and can't find 'em.
Back to top
View user's profile Send private message
MrApples
Guru
Guru


Joined: 13 Dec 2002
Posts: 511

PostPosted: Sun Dec 12, 2004 12:05 am    Post subject: Reply with quote

http://www.sepi.be/nitro/2.6.9-nitro4/addons/orinoco-0.13e-patch.diff
_________________
http://www.whatsinyourbox.org -- Technology discussion, news, and more.
Back to top
View user's profile Send private message
kare
n00b
n00b


Joined: 06 Jun 2004
Posts: 26
Location: Friedberg, Germany

PostPosted: Sun Dec 12, 2004 8:33 am    Post subject: Reply with quote

MrApples wrote:
http://www.sepi.be/nitro/2.6.9-nitro4/addons/orinoco-0.13e-patch.diff

This is what I get:
Quote:
http://www.sepi.be/403.htm
(>_<)
Oooooh Nooooo!


Four Oh Three verboden! | forbidden!
ga naar de hoofdpagina | go to the main page
Back to top
View user's profile Send private message
BlueSand
n00b
n00b


Joined: 08 Dec 2004
Posts: 12

PostPosted: Sun Dec 12, 2004 1:01 pm    Post subject: Reply with quote

many thanks .
but when i patch unicon patch on this source,
http://vdlinux.sourceforge.jp/dists/vd_unicon-kernel-2.6.9-20041019.patch.bz2
it sucks.
with the compile errors as follow:
CHK include/linux/version.h
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
CHK include/asm-i386/asm_offsets.h
CHK include/linux/compile.h
dnsdomainname: Unknown host
GEN .version
CHK include/linux/compile.h
dnsdomainname: Unknown host
UPD include/linux/compile.h
CC init/version.o
LD init/built-in.o
LD .tmp_vmlinux1
drivers/built-in.o(.text+0x15eb3): In function `put_queue':
: undefined reference to `Unicon_fnKeyHook'
drivers/built-in.o(.text+0x15f92): In function `puts_queue':
: undefined reference to `Unicon_fnKeyHook'
drivers/built-in.o(.text+0x16497): In function `fn_send_intr':
: undefined reference to `Unicon_fnKeyHook'
drivers/built-in.o(.text+0x19e32): In function `respond_string':
: undefined reference to `Unicon_fnKeyHook'
make: *** [.tmp_vmlinux1] Error 1

i don't know how to solve it .
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Mon Dec 13, 2004 6:55 am    Post subject: Reply with quote

Is Nitro-Sources dead? no new nitro for ahwile now... I hope someone still working on it if Seppe dont got the time cause i think this is the best patchet...
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
ZothOmmog
Apprentice
Apprentice


Joined: 05 May 2003
Posts: 216
Location: Nashville, TN

PostPosted: Mon Dec 13, 2004 6:17 pm    Post subject: Reply with quote

Is anyone else having the problem I describe here:

https://forums.gentoo.org/viewtopic.php?t=264556

Basically, none of my memory is being used for buffers. As a result, a good number of programs are starting slowly & my mouse cursor jerks under heavy load.
_________________
-It's gonna take a lot of fireworks to clean this place up.
Back to top
View user's profile Send private message
seppe
Guru
Guru


Joined: 01 Sep 2003
Posts: 431
Location: Hove, Antwerp, Belgium

PostPosted: Mon Dec 13, 2004 6:40 pm    Post subject: Reply with quote

Robin79 wrote:
Is Nitro-Sources dead? no new nitro for ahwile now... I hope someone still working on it if Seppe dont got the time cause i think this is the best patchet...


No it's not, I just don't have the time now. It will be back in a month or so. Feel free to make a nitro yourself, I think everyone knows what should be in there: latest stable ck, reiser4, vesafb-tng, gensplash, swsusp2 + win4lin, ... If you have made one, send a mail to "seppe [at] pandora [dot] be" and I'll approve it (probably) and put in online if you don't have a webhost.
_________________
nitro-sources, because between stable and experimental there exists only speed

Latest release I made: 2.6.13.2-nitro1
Back to top
View user's profile Send private message
noooob
n00b
n00b


Joined: 15 Dec 2004
Posts: 5

PostPosted: Wed Dec 15, 2004 12:05 pm    Post subject: Reply with quote

Hi guys,


I tried to patch orinoco..patch..but no luck so far..what went wrong?

I've downloaded orinoco-0.13e-patch.diff to /usr/src/linux and then patch it:
Code:

1. # cd /usr/src/linux
2. # ls
3. # orinoco-0.13e-patch.diff
4. patch -p1 < orinoco-0.13e-patch.diff
 patch -p1 < orinoco-0.13e-patch.diff
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/hermes.c orinoco-0.13e-patched/hermes.c
|--- orinoco-0.13e/hermes.c     2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/hermes.c     2003-08-07 04:16:04.000000000 -0700
--------------------------1 out of 1 hunk ignored
can't find file to patch at input line 18
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/hermes.h orinoco-0.13e-patched/hermes.h
|--- orinoco-0.13e/hermes.h     2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/hermes.h     2003-08-07 04:16:04.000000000 -0700
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
4 out of 4 hunks ignored
can't find file to patch at input line 94
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/orinoco.c orinoco-0.13e-patched/orinoco.c
|--- orinoco-0.13e/orinoco.c    2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/orinoco.c    2003-08-07 04:16:04.000000000 -0700
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
11 out of 11 hunks ignored
can't find file to patch at input line 595
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/orinoco.h orinoco-0.13e-patched/orinoco.h
|--- orinoco-0.13e/orinoco.h    2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/orinoco.h    2003-08-07 04:16:04.000000000 -0700
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
4 out of 4 hunks ignored
localhost linux #



help please
Back to top
View user's profile Send private message
FlumMmicH
n00b
n00b


Joined: 31 Oct 2004
Posts: 58
Location: Sweden

PostPosted: Wed Dec 15, 2004 1:25 pm    Post subject: Reply with quote

nice.. they've used my signature :D
_________________
Less is more.
Back to top
View user's profile Send private message
seppe
Guru
Guru


Joined: 01 Sep 2003
Posts: 431
Location: Hove, Antwerp, Belgium

PostPosted: Wed Dec 15, 2004 1:30 pm    Post subject: Reply with quote

noooob wrote:
Hi guys,


I tried to patch orinoco..patch..but no luck so far..what went wrong?

I've downloaded orinoco-0.13e-patch.diff to /usr/src/linux and then patch it:
Code:

1. # cd /usr/src/linux
2. # ls
3. # orinoco-0.13e-patch.diff
4. patch -p1 < orinoco-0.13e-patch.diff
 patch -p1 < orinoco-0.13e-patch.diff
can't find file to patch at input line 4
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/hermes.c orinoco-0.13e-patched/hermes.c
|--- orinoco-0.13e/hermes.c     2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/hermes.c     2003-08-07 04:16:04.000000000 -0700
--------------------------1 out of 1 hunk ignored
can't find file to patch at input line 18
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/hermes.h orinoco-0.13e-patched/hermes.h
|--- orinoco-0.13e/hermes.h     2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/hermes.h     2003-08-07 04:16:04.000000000 -0700
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
4 out of 4 hunks ignored
can't find file to patch at input line 94
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/orinoco.c orinoco-0.13e-patched/orinoco.c
|--- orinoco-0.13e/orinoco.c    2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/orinoco.c    2003-08-07 04:16:04.000000000 -0700
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
11 out of 11 hunks ignored
can't find file to patch at input line 595
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -aur orinoco-0.13e/orinoco.h orinoco-0.13e-patched/orinoco.h
|--- orinoco-0.13e/orinoco.h    2003-05-11 23:22:27.000000000 -0700
|+++ orinoco-0.13e-patched/orinoco.h    2003-08-07 04:16:04.000000000 -0700
--------------------------
File to patch:
Skip this patch? [y]
Skipping patch.
4 out of 4 hunks ignored
localhost linux #



help please


First, I'm not sure this is the right solution because I don't have that orinocco patch right now at this computer (and I'm in that other evil OS :rolleyes:). But try this:

cd /usr/src/linux/drivers/net/wireless
patch -p1 < /path/to/orinocco-0.13e.patch.diff
_________________
nitro-sources, because between stable and experimental there exists only speed

Latest release I made: 2.6.13.2-nitro1
Back to top
View user's profile Send private message
noooob
n00b
n00b


Joined: 15 Dec 2004
Posts: 5

PostPosted: Wed Dec 15, 2004 7:15 pm    Post subject: Reply with quote

Thanks for for your replied seppe..I did tried with some of orinoco patch but no luck
Code:
bash-2.05b# patch -p1 < /usr/src/linux/orinoco-0.13e-patch.diff
patching file hermes.c
Hunk #1 succeeded at 186 with fuzz 2 (offset 3 lines).
patching file hermes.h
Hunk #1 succeeded at 42 with fuzz 2 (offset 9 lines).
Hunk #2 succeeded at 249 with fuzz 1 (offset 96 lines).
Hunk #3 FAILED at 418.
Hunk #4 FAILED at 472.
2 out of 4 hunks FAILED -- saving rejects to file hermes.h.rej
patching file orinoco.c
Reversed (or previously applied) patch detected!  Assume -R? [n] y
Hunk #1 succeeded at 1038 (offset -635 lines).
Hunk #2 succeeded at 1054 with fuzz 1 (offset -635 lines).
Hunk #3 succeeded at 1064 (offset -635 lines).
Hunk #4 succeeded at 1095 (offset -635 lines).
Hunk #5 succeeded at 1169 (offset -635 lines).
Hunk #6 FAILED at 1811.
Hunk #7 FAILED at 2963.
Hunk #8 succeeded at 3992 (offset 162 lines).
Hunk #9 succeeded at 4092 with fuzz 1 (offset 168 lines).
Hunk #10 FAILED at 4314.
Hunk #11 succeeded at 4557 with fuzz 1 (offset 386 lines).
3 out of 11 hunks FAILED -- saving rejects to file orinoco.c.rej
patching file orinoco.h
Hunk #1 FAILED at 37.
Hunk #2 FAILED at 68.
Hunk #3 FAILED at 282.
Hunk #4 succeeded at 329 with fuzz 2 (offset -3 lines).
3 out of 4 hunks FAILED -- saving rejects to file orinoco.h.rej
bash-2.05b#


BTW this laptop used to have nitro3 kernel (with orinoco patch already in it) and I love it so much...but now I've installed kernel 2.6.9-nitro4 I couldn't patch orinoco..I dunno why. Maybe if you put orinoco patch for the next version..that''ll be nice...thanks.. like the one I used to have kernel 2.6.9-nitro3.
Back to top
View user's profile Send private message
soluzar
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2004
Posts: 81
Location: England

PostPosted: Thu Dec 16, 2004 8:41 pm    Post subject: Reply with quote

I've just tried nitro-sources for the first time with this version, and I'm happy to report that I get a small speed-boost as well as no loss of stability. :D

I plan to try some other optimisations pretty soon, but thanks Seppe, for the nitro patchset.
_________________
Soluzar
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Sat Dec 18, 2004 2:32 pm    Post subject: Reply with quote

I couldn't wait for seppe to come out of hibernation, so I whipped up a new version of nitro which applies on top of 2.6.9. It has the following patches:
Code:
latest ck
alsa 1.0.7 (finally!)
win4lin
reiser4     
vesafb-tng
gensplash
swsusp2
-bk12
config_hz
chmp
cflags-selection-for-nitro


I'm running it now and it seems to work quite nicely, but I haven't tested all the stuff (win4lin, reiser4, swsusp2) since I don't use them. Anyway, I've sent it off to seppe so that I can get his blessing. If he approves, it will be called "Now with 3 times more calcium!".
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
kontol
n00b
n00b


Joined: 19 Dec 2004
Posts: 31

PostPosted: Sun Dec 19, 2004 3:34 am    Post subject: Reply with quote

[Request please], Can you please please... add orinoco and hostap patch for the next version nitro kernel...


I've been using this kernel every version and I love it so much


Thanks alot
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Sun Dec 19, 2004 8:48 am    Post subject: Reply with quote

Darckness wrote:
I couldn't wait for seppe to come out of hibernation, so I whipped up a new version of nitro which applies on top of 2.6.9. It has the following patches:
Code:
latest ck
alsa 1.0.7 (finally!)
win4lin
reiser4     
vesafb-tng
gensplash
swsusp2
-bk12
config_hz
chmp
cflags-selection-for-nitro


I'm running it now and it seems to work quite nicely, but I haven't tested all the stuff (win4lin, reiser4, swsusp2) since I don't use them. Anyway, I've sent it off to seppe so that I can get his blessing. If he approves, it will be called "Now with 3 times more calcium!".



Give me give me? i want to try it out!! so fix a ebuild or give me the patch now or i have to hunt you down and cripple you lol
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Sun Dec 19, 2004 1:08 pm    Post subject: Can't find Reiser4 kernel option Reply with quote

Hi all!

I just emerged nitro4 and I'm attempting to configure it on my Athlon XP. Problem is I can't find the options to enable Reiser4: I tried both make menuconfig and make config, but the Reiser4 options just do not appear on the list.

I checked my .config and I have none of the following lines, which other people positng in this thread seem to have:

Code:

CONFIG_FS_MBCACHE=y
CONFIG_REISER4_FS=m
CONFIG_REISER4_LARGE_KEY=y
# CONFIG_REISER4_CHECK is not set


However, if I perform a find in the kernel directory, it finds several files related to Reiser4, so the nitro4 kernel I have should be the right one. But, so, why doesn't it show an option to enable Reiser4 in config?

Thanks, Michele.
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Sun Dec 19, 2004 4:49 pm    Post subject: Reply with quote

If you had serached for it in the this threads you had find the issue.. Disable this in the kernel... Kernel hacking >> disable Use 4Kb for kernel stacks instead of 8Kb and resierfs4 is there :P
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
LordArthas
Guru
Guru


Joined: 01 Nov 2004
Posts: 493
Location: Maniago, Friûl, Italia

PostPosted: Mon Dec 20, 2004 8:13 am    Post subject: Reply with quote

Robin79 wrote:
If you had serached for it in the this threads you had find the issue.. Disable this in the kernel... Kernel hacking >> disable Use 4Kb for kernel stacks instead of 8Kb and resierfs4 is there :P


Thank you. Frankly I searched, but probably not deeply enough. ;-)

Michele.
Back to top
View user's profile Send private message
toMeloos
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2003
Posts: 101
Location: The Netherlands

PostPosted: Mon Dec 20, 2004 9:06 am    Post subject: Reply with quote

Nitro4 does not seem to work on my laptop. It boots just fine but when the X server starts all I get is a black screen (not even the gray screen). Using the gentoo-dev-sources the X server does start correctly. I'm using the Xorg-x11 6.7.0-r2 server with the ati-drivers and GDM. Does anybody know a solution for this???

Also quite disappointing that swsusp2 doesn't work with the ati-drivers. I want to use it to quickly shutdown/restart my laptop when I need to swich trains when traveling to work. Using the radeon driver will increase the average load on my laptop and stopping and starting will also be a very high load for it. I need to minimize the load to save as much power as possible so I can work on the battery the whole trip. :(
Back to top
View user's profile Send private message
toMeloos
Tux's lil' helper
Tux's lil' helper


Joined: 24 Jul 2003
Posts: 101
Location: The Netherlands

PostPosted: Mon Dec 20, 2004 11:40 am    Post subject: Reply with quote

Correction: my X server is working again. I was missing some things in my kernel config. It now correctly finds my touchpad. Didn't see the error message because of a problem between the radeonfb and fglrx drivers.

The vesafb-tng driver however does not seem to work and results in some kind of error message...
Back to top
View user's profile Send private message
Robin79
l33t
l33t


Joined: 18 Oct 2003
Posts: 632
Location: /home/valdemarsvik

PostPosted: Mon Dec 20, 2004 12:30 pm    Post subject: Reply with quote

LordArthas wrote:
Robin79 wrote:
If you had serached for it in the this threads you had find the issue.. Disable this in the kernel... Kernel hacking >> disable Use 4Kb for kernel stacks instead of 8Kb and resierfs4 is there :P


Thank you. Frankly I searched, but probably not deeply enough. ;-)

Michele.


np m8
_________________
Gentoo 2005.0
ASUS P5AD2 Deluxe MB
Intel P4 3.2GHz
PCI-E Nvidia Geforce PCX 5750
--------------------

Registered Linux User Nr # 319050 http://counter.li.org
Back to top
View user's profile Send private message
sibov
Tux's lil' helper
Tux's lil' helper


Joined: 09 Feb 2004
Posts: 147
Location: Germany

PostPosted: Mon Dec 20, 2004 7:14 pm    Post subject: Reply with quote

:lol: :lol: :lol: :lol:

I have found the problem why my MSI mainboarded PC won't shutdown without powering off since kernel 2.6.9-xxx.

IT S A WRONG DSDT BIOS VERSION FROM MSI! :twisted:


I tried the HowTo from WIKI "Howto Fix Common ACPI Problems" and found
the hint. No Errors while reompiling my dsdt but my MSI DSDT makes some
OS specific checks for:

"Microsoft Windows"
"Microsoft Windwos NT" and
"Microsoft Windows Millennium Edition".

If none of these above Opration Systems are matching the bios is using a fallback mode.

This mode seems to be without good SMP+ACPI poweroff issues.


Code:
If (MCTH (\_OS, "Microsoft Windows NT"))
                    If (MCTH (\_OS, "Microsoft Windows"))
                        If (MCTH (\_OS, "Microsoft WindowsME: Millennium Edition"))



It is just as simple: I added

Quote:
acpi_os_name="Microsoft Windows"


into my grub.conf line for my nitro4 and voila my system is able to power off again :wink:
_________________
Gentoo 2.6.17-gentoo-r5 with dmraid Raid0 Dualboot
AMD64 X2 3800+, 4x512MB DDR PC3200Pro Corsair Geforce EN6600GT silencer @ 256MB
4x250GB SATAII Samsung SP120, Asus A8N Premium, Plextor PX712SA DVDRW
Logitech Dinovo, SB Audigy4


Last edited by sibov on Tue Dec 21, 2004 10:53 am; edited 2 times in total
Back to top
View user's profile Send private message
M@rijn
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jan 2004
Posts: 145
Location: Zierikzee (The Netherlands)

PostPosted: Tue Dec 21, 2004 8:22 am    Post subject: Reply with quote

Are there people here who uses this kernel with IPW2200 driver? Mine give errors. Or will there come a fix for it?
_________________
Gentoo is just an Aston Martin, "Power, beauty and soul"
Back to top
View user's profile Send private message
discomfitor
l33t
l33t


Joined: 21 Feb 2003
Posts: 927
Location: None

PostPosted: Tue Dec 21, 2004 10:10 am    Post subject: Reply with quote

Hrmm. seppe still hasn't gotten back to me yet. I suppose if I don't hear anything back from him by Wednesday or Thursday, I'll post it here since I've been running it with perfect uptime since Saturday.

Don't get your hopes up though. This will be even more experimental than the normal nitro-sources.
_________________
There is no substitute for experience.
Imperfection indicates a lack of effort.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
Page 8 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum