Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound in Gnome not working...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Utoxin
Guru
Guru


Joined: 19 Apr 2002
Posts: 413
Location: American Fork, UT

PostPosted: Tue Apr 23, 2002 9:32 am    Post subject: Sound in Gnome not working... Reply with quote

Sound in gnome doesn't work. I have XMMS working, using the ALSA driver, but Gnome doesn't want to play nicely with it. What things should I check to figure out why this might be?
Back to top
View user's profile Send private message
cr0nos
n00b
n00b


Joined: 22 Apr 2002
Posts: 36

PostPosted: Tue Apr 23, 2002 9:34 am    Post subject: Re: Sound in Gnome not working... Reply with quote

Utoxin wrote:
Sound in gnome doesn't work. I have XMMS working, using the ALSA driver, but Gnome doesn't want to play nicely with it. What things should I check to figure out why this might be?


I don`t know too much about alsa, but there might be some daemon or something like that you hva to start.

You should try with esound or/and OSS. If one of them works, then stick with it, or find out why it isn`t working with alsa :wink:
Back to top
View user's profile Send private message
Utoxin
Guru
Guru


Joined: 19 Apr 2002
Posts: 413
Location: American Fork, UT

PostPosted: Tue Apr 23, 2002 10:53 am    Post subject: Reply with quote

ALSA itself is working great. The sound quality is even better than I'm used to in Linux. Maybe things have improved in the year I was away though.

Anyway, ALSA is running just fine, getting along happilng with xmms, and aplay, and all that stuff. I even had it working with gnome for a brief time, but then it stopped, and I don't know why. When I used Gnome before, I always used kernel drivers with esd, but that setup was a little laggy and unstable. I'd rather not go that route if I can help it.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18344

PostPosted: Tue May 14, 2002 3:43 am    Post subject: Reply with quote

Does anyone know of a solution for this? Once the planets aligned and the virgins were sacrificed to the gods,
I can now play sounds with aplay. Gnome sounds do not work though. Also, I get quite a bit of hiss.

EDIT: tcd (non-gui cd player) plays CDs fine too. No hiss noticeable. I think the hiss comes into play when "event sounds" (mail notify etc.) are played. They are quiet, so to hear them, volume is up and so is the hiss i guess. Gnome sounds still do not work though.
Back to top
View user's profile Send private message
Guest
Guest





PostPosted: Tue May 14, 2002 11:45 am    Post subject: Reply with quote

maybe you should check the box in gnome-config "Start sound server at startup" and "Play sound" ?
Back to top
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18344

PostPosted: Tue May 14, 2002 12:22 pm    Post subject: Reply with quote

Guest wrote:
maybe you should check the box in gnome-config "Start sound server at startup" and "Play sound" ?

That was the first thing I checked.
Back to top
View user's profile Send private message
BillyD
Guru
Guru


Joined: 05 May 2002
Posts: 318
Location: Australia

PostPosted: Tue May 14, 2002 1:41 pm    Post subject: Reply with quote

I have noticed with Gnome that you need to open gmixer and adjust the volume settings in there to get sound to work even after you have alsa running correctly. You may have already tried this to no avail, but if not, give it a go and see if it works.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18344

PostPosted: Tue May 14, 2002 4:27 pm    Post subject: Reply with quote

Tried again just to make sure. Settings seemed to be where I put them. Interestingly enough, sound only comes out of the left speaker
using tcd / gtcd to play a CD. Haven't figured out how to get xmms to play a CD yet.
Back to top
View user's profile Send private message
rac
Bodhisattva
Bodhisattva


Joined: 30 May 2002
Posts: 6553
Location: Japanifornia

PostPosted: Mon Aug 19, 2002 10:35 am    Post subject: Reply with quote

Fled the crowds in Desktop Environments for the wide open spaces of the new Multimedia forum.
_________________
For every higher wall, there is a taller ladder
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum