Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200411-15 ] OpenSSL, Groff: Insecure tempfile handling
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Mon Nov 08, 2004 7:27 pm    Post subject: [ GLSA 200411-15 ] OpenSSL, Groff: Insecure tempfile handlin Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL, Groff: Insecure tempfile handling (GLSA 200411-15)
Severity: normal
Exploitable: local
Date: November 08, 2004
Updated: August 23, 2006
Bug(s): #68404, #68407
ID: 200411-15

Synopsis

groffer, included in the Groff package, and the der_chop script, included in the OpenSSL package, are both vulnerable to symlink attacks, potentially allowing a local user to overwrite arbitrary files with the rights of the user running the utility.

Background

OpenSSL is a toolkit implementing the Secure Sockets Layer and Transport Layer Security protocols as well as a general-purpose cryptography library. It includes the der_chop script, which is used to convert DER-encoded certificates to PEM format. Groff (GNU Troff) is a typesetting package which reads plain text mixed with formatting commands and produces formatted output. It includes groffer, a command used to display groff files and man pages on X and tty.

Affected Packages

Package: dev-libs/openssl
Vulnerable: < 0.9.7d-r2
Unaffected: >= 0.9.7d-r2
Architectures: All supported architectures

Package: sys-apps/groff
Vulnerable: < 1.19.1-r2
Unaffected: >= 1.19.1-r2
Unaffected: >= 1.18.1.1 < 1.18.1.2
Architectures: All supported architectures


Description

groffer and the der_chop script create temporary files in world-writeable directories with predictable names.

Impact

A local attacker could create symbolic links in the temporary files directory, pointing to a valid file somewhere on the filesystem. When groffer or der_chop is executed, this would result in the file being overwritten with the rights of the user running the utility, which could be the root user.

Workaround

There is no known workaround at this time.

Resolution

All Groff users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose sys-apps/groff
All OpenSSL users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.7d-r2"
Note: /etc/ssl/misc/der_chop is protected by Portage as a configuration file. Don't forget to use etc-update and overwrite the old version with the new one.

References

CAN-2004-0969
CAN-2004-0975


Last edited by GLSA on Sun Apr 29, 2007 4:16 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum