Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Steam installing issues and WarThunder issue?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Wed Jul 06, 2016 1:16 pm    Post subject: [SOLVED] Steam installing issues and WarThunder issue? Reply with quote

I tried to install Steam as an Overlay according this wiki: https://wiki.gentoo.org/wiki/Steam - However get this message when trying to launch it:
"Your video card or it's driver may not be supported. Be sure to install the best video card driver and try again."
I have Intel on board video card:
Code:
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

Can do something with kernel's driver or change preferences of Steam - or must to add video card?

Anyway, I want to verify if installing Steam by the other way (NOT Overlay) can work without video card -
Thus I followed the first part of the wiki and every thing went ok till running ./steam -
I get these errors with both introduced installing methods - Manual and Manual with alternative installer script:
Code:
./steam
/home/mg_e/.local/share/Steam/steam.sh: line 159: DISTRIB_RELEASE: unbound variable
/home/mg_e/.local/share/Steam/steam.sh: line 159: DISTRIB_RELEASE: unbound variable
Running Steam on gentoo  64-bit
/home/mg_e/.local/share/Steam/steam.sh: line 159: DISTRIB_RELEASE: unbound variable
STEAM_RUNTIME is enabled automatically
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2016-07-06 14:48:29] Startup - updater built Nov 17 2015 12:33:46
Installing breakpad exception handler for appid(steam)/version(0)
libGL error: unable to load driver: i915_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i915
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)


I wonder if this wiki is updated or need some changes?
Please advise!

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”


Last edited by pmam on Thu Aug 18, 2016 8:52 am; edited 2 times in total
Back to top
View user's profile Send private message
BT
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 292

PostPosted: Wed Jul 06, 2016 11:21 pm    Post subject: Reply with quote

Do you have 32-bit media-libs/mesa installed?
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Thu Jul 07, 2016 7:15 am    Post subject: Reply with quote

BT Hi,

Do not know regarding 32 bits however this package is installed:
Code:
eix media-libs/mesa
[I] media-libs/mesa
     Available versions:  [M]7.10.3 10.3.7-r1^d 11.0.6^d ~11.0.9^d ~11.1.3^d ~11.1.4^d ~11.2.1^d ~11.2.2^d **9999^d {bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles gles1 gles2 hardened (+)llvm motif +nptl opencl openmax openvg osmesa pax_kernel pic selinux +udev vaapi valgrind vdpau wayland xa xvmc ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" KERNEL="FreeBSD linux" VIDEO_CARDS="freedreno i915 i965 ilo intel mach64 mga nouveau r100 r128 r200 r300 r600 radeon radeonsi savage sis tdfx vc4 via vmware"}
     Installed versions:  11.0.6^d(07:36:29 PM 06/24/2016)(classic dri3 egl gallium gbm llvm nptl udev wayland xa -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic -selinux -vaapi -vdpau -xvmc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32" KERNEL="-FreeBSD" VIDEO_CARDS="intel -freedreno -i915 -i965 -ilo -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware")
     Homepage:            http://mesa3d.sourceforge.net/
     Description:         OpenGL-like graphic library for Linux


Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
BT
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 292

PostPosted: Thu Jul 07, 2016 8:11 am    Post subject: Reply with quote

The eix output reports that 32-bit mesa is installed. It also shows that VIDEO_CARDS is set to "intel i915". However according to the Gentoo Wiki, VIDEO_CARDS may need to be set to "intel i965" for 4th generation Intel chipsets. Which Intel CPU do you have?
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Thu Jul 07, 2016 8:23 am    Post subject: Reply with quote

Here my cpu - Please advise if need to change VIDEO_CARDS driver?
Code:
uname -a
Linux mg_6300 4.4.6-gentoo #3 SMP Wed Jun 8 16:20:27 IDT 2016 x86_64 Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz GenuineIntel GNU/Linux


EDIT: Please refer new info in my next post.

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”


Last edited by pmam on Thu Jul 07, 2016 8:35 am; edited 1 time in total
Back to top
View user's profile Send private message
BT
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 292

PostPosted: Thu Jul 07, 2016 8:27 am    Post subject: Reply with quote

I should have also asked, what Intel chipset does your motherboard have?
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Thu Jul 07, 2016 8:34 am    Post subject: Reply with quote

I have 2 similar machines with the same "Steam' issues - Please do not refer to previous info - here the right info of the actual machine:
Code:
uname -a
Linux mg_e2180 4.4.6-gentoo #1 SMP Thu May 12 18:24:57 IDT 2016 x86_64 Intel(R) Pentium(R) Dual CPU E2180 @ 2.00GHz GenuineIntel GNU/Linux

Code:
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

The other machine:
Code:
uname -a
Linux mg_6300 4.4.6-gentoo #3 SMP Wed Jun 8 16:20:27 IDT 2016 x86_64 Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz GenuineIntel GNU/Linux

Code:
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)

_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
BT
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 292

PostPosted: Thu Jul 07, 2016 8:58 am    Post subject: Reply with quote

It seems that "intel i915" is correct. The chipsets are quite old, so they may not be supported by Steam. However the error "unable to load driver: i915_dri.so" indicates another cause.
Back to top
View user's profile Send private message
kajzer
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2014
Posts: 102

PostPosted: Thu Jul 07, 2016 5:34 pm    Post subject: Reply with quote

Chipsets has nothing to do with it, it happens with nvidia and ati cards as well.

Solution is to run this in terminal :

Code:
$ find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" \) -print -delete
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Thu Jul 07, 2016 8:26 pm    Post subject: Reply with quote

kajzer Hi,

After running your 'find' command, downloading was started.
After downloading was finished I needed to run the command ./steam again -
Then got the same errors... so after running your 'find' command again, Steam was launched :D
(I followed this way of installing from wiki: 'Manual with alternative installer script' - Looks ok so far...)

Now i am downloading 'War Thunder' - Hope it will work ok with my Intel on board graphics -
As mentioned before, Installing Steam as an Overlay did not work...

Looks a good idea to update Steam's wiki by someone who understand how to work it out!

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
kajzer
Tux's lil' helper
Tux's lil' helper


Joined: 27 Nov 2014
Posts: 102

PostPosted: Thu Jul 07, 2016 8:31 pm    Post subject: Reply with quote

Hi,

you need to run that command every time you do a fresh install of Steam , sometimes you need to run it if Steam client gets updated.

btw it is on wiki, you missed it , it's here : https://wiki.gentoo.org/wiki/Steam/Client_troubleshooting
Back to top
View user's profile Send private message
BT
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 292

PostPosted: Fri Jul 08, 2016 2:52 am    Post subject: Reply with quote

kajzer,

Thank you for providing the solution. I also didn't find it on the Wiki :oops:. I have now updated the Wiki, with the addition of the error message, so that it's a little easier for others to find.
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Fri Jul 08, 2016 7:47 am    Post subject: Reply with quote

After downloading 'War Thunder' I am facing same issue as was when Steam installed as Overlay :(
"Your video card or it's driver may not be supported. Be sure to install the best video card driver and try again."
Maybe on board video card is not enough - Anyone had succeeded to run such game on Steam with on board chipset?!
Looks must to add video card...
Are there any differences, in terms of machine's resources, between Overlay vs Manual Steam's installing?
Maybe 'War Thunder' is too heavy to my setup - Can you please recommend on lighter nice free game?

Another little issue: during Steam's installation I did not choose to create shortcut launcher -
I did not find how to do it after installing?

BT: Hope after your wiki's updating this solution will be found faster -
If not - This topic may help :)

Thanks
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
BT
Apprentice
Apprentice


Joined: 13 Jun 2004
Posts: 292

PostPosted: Fri Jul 08, 2016 8:27 am    Post subject: Reply with quote

pmam,

The War Thunder store page lists the following minimum system requirements:
Code:
Processor: Dual-Core 2.4 GHz
Memory: 4 GB RAM
Graphics: Intel 4000 HD/Radeon HD 5550/GeForce 8800

It appears that your system is too weak :(

There is no difference between manual and overlay installation methods on system resources. It's just a matter of choice.
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Fri Jul 15, 2016 10:15 am    Post subject: Reply with quote

I added this video card and you can see cpu info in my previous post:
Code:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cypress PRO [Radeon HD 5850]

Now I can play with some games however still have issue with WarThunder -
I can launch the game and it is loaded but when choose to start particular game: i.e aircraft,
I get a screen without all details and psychedelic colours :(
I know that WarThunder is quite heavy game and may be it is beyond my machine's resources,
however please advise if can do something in order to improve graphics performance or change some setting of the game etc
In addition: I followed this https://wiki.gentoo.org/wiki/Radeon -
How can verify if this video card is properly installed with the right driver etc?
Is there any performance testing (bench mark)?
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
pmam
l33t
l33t


Joined: 30 Dec 2013
Posts: 975

PostPosted: Thu Aug 18, 2016 8:51 am    Post subject: Reply with quote

This issue was solved by installing propriety driver as described here:
https://forums.gentoo.org/viewtopic-t-1049996-highlight-.html
_________________
“You can take our property, our sweet homes, even our cloths...
But don't touch the streets, Ah, That's NO, NO, NO!
The streets are our @world's compilable kernel ...”
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum