Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Система грузится, но только на чтение...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
M0rf
n00b
n00b


Joined: 28 Oct 2004
Posts: 27
Location: Russia, Moscow

PostPosted: Thu Oct 28, 2004 2:51 pm    Post subject: Система грузится, но только на чт Reply with quote

Здраствуйте.

Ставлю дженту 2004.2 ядро 2.6.* Собирал руками. Загрузчик поставил grub.
Все установилось, и вроде бы все хорошо.
Сейчас ситуация такая. Система грузится, но fstab в загрузке не используется. Грузился c LiveCD и комментировал все в fstab, ситуация одинаковая когда fstab есть и когда его нет.
Система грузится с примонтированным одним корневым разделом /dev/hda3 /. И тот в режиме только чтения.
Swap и proc то же не монтируются…

Как исправить нынешнюю ситуацию?
Заранее благодарен.
Back to top
View user's profile Send private message
M0rf
n00b
n00b


Joined: 28 Oct 2004
Posts: 27
Location: Russia, Moscow

PostPosted: Fri Oct 29, 2004 1:16 am    Post subject: Reply with quote

кажись у меня initrd не запускается...
Как его заставить запускаться?
Back to top
View user's profile Send private message
Nelud
Apprentice
Apprentice


Joined: 08 Oct 2004
Posts: 271

PostPosted: Fri Oct 29, 2004 7:27 am    Post subject: Reply with quote

Во-первых, grub.conf в студию! Во-вторых, ls /boot (предварительно сделав mount /dev/hda1 /boot)
Back to top
View user's profile Send private message
M0rf
n00b
n00b


Joined: 28 Oct 2004
Posts: 27
Location: Russia, Moscow

PostPosted: Fri Oct 29, 2004 12:24 pm    Post subject: Reply with quote

grub.conf
Code:

default 0
timeout 30
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
title=My example Gentoo Linux
root (hd0,0) vga=795
kernel (hd0,0)/boot/bzImage root=/dev/hda3


ls -ls /boot
Code:

drwxr-xr-x   4 root root    1024 Oct 28 17:10 .
drwxr-xr-x  18 root root    4096 Oct 26 17:41 ..
-rw-r--r--   1 root root 1359340 Oct 28 17:10 System.map
lrwxrwxrwx   1 root root       1 Oct 24 19:55 boot -> .
-rw-r--r--   1 root root     512 Oct 25 07:33 boot.0300
-rw-r--r--   1 root root 3066221 Oct 28 17:10 bzImage
drwxr-xr-x   2 root root    1024 Oct 26 18:25 grub
drwx------   2 root root   12288 Oct 24 18:53 lost+found
-rw-------   1 root root   38912 Oct 25 17:04 map
Back to top
View user's profile Send private message
Nelud
Apprentice
Apprentice


Joined: 08 Oct 2004
Posts: 271

PostPosted: Fri Oct 29, 2004 3:32 pm    Post subject: Reply with quote

1. какого @#$% делает "vga=795" в команде root? оно должна быть в kernel !
2. и где же прописана загрузка initrd ? :) да его и не видать по команде ls !
Back to top
View user's profile Send private message
M0rf
n00b
n00b


Joined: 28 Oct 2004
Posts: 27
Location: Russia, Moscow

PostPosted: Fri Oct 29, 2004 7:20 pm    Post subject: Reply with quote

Nelud wrote:
1. какого @#$% делает "vga=795" в команде root? оно должна быть в kernel !
2. и где же прописана загрузка initrd ? :) да его и не видать по команде ls !

1 Спасибо за замечание, но не в этом дело.
2 видимо не создался...
Может подскажешь какой этап инстала нужно повторить что бы инит создался?
или все заново ставить (
Back to top
View user's profile Send private message
Nelud
Apprentice
Apprentice


Joined: 08 Oct 2004
Posts: 271

PostPosted: Sat Oct 30, 2004 9:49 pm    Post subject: Reply with quote

Раз ты компил ядро руками то initrd и не должно быть. (правда, у меня он есть, но он появился только после того какfbsplash прикрутил)...
1 предположение. Может у тебя ошибки в fstab? можешь его выставить сюда?
2 предположение. По документации файл System.map должен называться как-то так (в зависимости от версии ядра): System.map-2.6.8-gentoo-r1 . Я не знаю зачем этот файл нужен, но может в этом причина?
3 предположение. Может ты не включил в ядро поддержку нужных файловых систем?
Back to top
View user's profile Send private message
M0rf
n00b
n00b


Joined: 28 Oct 2004
Posts: 27
Location: Russia, Moscow

PostPosted: Sun Oct 31, 2004 12:29 am    Post subject: Reply with quote

Nelud спасибо за советы.
проблема решене, но не самым лучшим способом :(
Я отформатил разделы и поставил все заново
1
initrd и на самом деле не дожно быть в буте, (такая информация есть в доке по установке) если ядро собиралось руками, а не генкернелом...
2 не думаю, что проблема была в этом
3 Самая интересная весч, что в прошлый раз я в ядро очень много всего впихал... Все файловые системы!!! :(
В этот же раз собирал все по минимуму...
Собралось и запустилось.

Жаль, что неизвестно из-за чего трабл был в прошлый раз.
Back to top
View user's profile Send private message
rusxakep
Guru
Guru


Joined: 09 Jul 2004
Posts: 458
Location: Moscow, Russia

PostPosted: Mon Nov 01, 2004 9:21 am    Post subject: Reply with quote

tmpfs поставит в svc в yes (вроде в rc.conf) - вот он и пытался подмонтировать /mnt/.init.d

ps: возможно
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum