Joined: 13 Jun 2003
Location: Dresden, Germany
|Posted: Wed Oct 27, 2004 10:57 pm Post subject: [ GLSA 200410-29 ] PuTTY: Pre-authentication buffer overflow
|Gentoo Linux Security Advisory
Title: PuTTY: Pre-authentication buffer overflow (GLSA 200410-29)
Date: October 27, 2004
Updated: May 22, 2006
PuTTY contains a vulnerability allowing an SSH server to execute arbitrary
code on the connecting client.
PuTTY is a free implementation of Telnet and SSH for Win32 and Unix
platforms, along with an xterm terminal emulator.
Vulnerable: <= 0.55
Unaffected: >= 0.56
Architectures: All supported architectures
PuTTY fails to do proper bounds checking on SSH2_MSG_DEBUG packets. The
"stringlen" parameter value is incorrectly checked due to signedness
issues. Note that this vulnerability is similar to the one described in
GLSA 200408-04 but not the same.
When PuTTY connects to a server using the SSH2 protocol, an attacker
may be able to send specially crafted packets to the client, resulting
in the execution of arbitrary code with the permissions of the user
running PuTTY. Note that this is possible during the authentication
process but before host key verification.
There is no known workaround at this time.
All PuTTY users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=net-misc/putty-0.56"
iDEFENSE Security Advisory 10.27.04
Last edited by GLSA on Sun Nov 18, 2012 4:17 am; edited 6 times in total