Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200410-16 ] PostgreSQL: Insecure temporary file use in make_oidjoins_check
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6377
Location: Graz / EU

PostPosted: Mon Oct 18, 2004 10:02 pm    Post subject: [ GLSA 200410-16 ] PostgreSQL: Insecure temporary file use i Reply with quote

Gentoo Linux Security Advisory

Title: PostgreSQL: Insecure temporary file use in make_oidjoins_check (GLSA 200410-16)
Severity: normal
Exploitable: local
Date: October 18, 2004
Updated: May 28, 2009
Bug(s): #66371
ID: 200410-16

Synopsis

The make_oidjoins_check script, part of the PostgreSQL package, is vulnerable to symlink attacks, potentially allowing a local user to overwrite arbitrary files with the rights of the user running the utility.

Background

PostgreSQL is an open source database based on the POSTGRES database management system. It includes several contributed scripts including the make_oidjoins_check script.

Affected Packages

Package: dev-db/postgresql
Vulnerable: <= 7.4.5-r1
Unaffected: >= 7.4.5-r2
Unaffected: >= 7.3.7-r2 < 7.3.8
Unaffected: >= 7.3.15 < 7.3.16
Unaffected: >= 7.3.16 < 7.3.17
Unaffected: >= 7.3.18 < 7.3.19
Unaffected: >= 7.3.21 < 7.3.22
Architectures: All supported architectures


Description

The make_oidjoins_check script insecurely creates temporary files in world-writeable directories with predictable names.

Impact

A local attacker could create symbolic links in the temporary files directory, pointing to a valid file somewhere on the filesystem. When make_oidjoins_check is called, this would result in file overwrite with the rights of the user running the utility, which could be the root user.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=dev-db/postgresql-7.4.5-r2"
# emerge ">=dev-db/postgresql-7.4.5-r2"
Upgrade notes: PostgreSQL 7.3.x users should upgrade to the latest available 7.3.x version to retain database compatibility.

References

Trustix Advisory #2004-0050
CVE-2004-0977


Last edited by GLSA on Sun Jul 26, 2009 4:16 am; edited 12 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum