Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cedilla usando teclado internacional (Resolvido)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
Guzymuzy
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2004
Posts: 102
Location: Manaus - Brazil

PostPosted: Mon Oct 18, 2004 7:31 pm    Post subject: Cedilla usando teclado internacional (Resolvido) Reply with quote

Deixa eu explicar o problema:

Eu tenho um teclado Logitech Elite Keyboard que tem padrão inglês internacional,
portanto para se fazer o cedilha, tenho que apertar em ' e em seguida no c.
Acontece que o Thunderbird e o Mozilla-Firefox não reconhecem o cedilha como "ç" e sim como "ć".
Nunca tinha visto isso antes. Um c com acento agudo. Hehehe.
Todos os outros programas do kde, acentuam normalmente, inclusivo o Open-office.

Eu estou fazendo assim. Quando eu quero escrever o cedilha eu mudo o padrão do teclado para Pt_ABNT2 e aperto em ": " que equivale à localização do cedilha no ABNT2. Daí eu copio o cedilha e colo quando for necessário.
Ah no terminal também estou acentuando normalmente.
A bronca é somente no firefox e no thunderbird.

Agradeço a colaboração,

Gustavo Motta 8O


Last edited by Guzymuzy on Sun Oct 24, 2004 3:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Tue Oct 19, 2004 7:36 pm    Post subject: Reply with quote

Você já leu o tópico sticky sobre layouts de teclados e locales para pt e pt_BR?
_________________
RTFM!
Back to top
View user's profile Send private message
Nattie
n00b
n00b


Joined: 07 Feb 2003
Posts: 45
Location: Sao Paulo, Brazil

PostPosted: Wed Oct 20, 2004 2:50 pm    Post subject: Reply with quote

Um detalhe importante: apesar de seguir todos os passos daquele manual, eu tive que tirar a use flag "userlocales" e recompilar a glibc, porque por algum motivo louco ela não compilava os locales especificados no arquivo de configuração. Então, se você está com essa flag habilitada, recomendo que coloque um - antes dela e recompile sua glib. :)
Back to top
View user's profile Send private message
malloc
l33t
l33t


Joined: 19 Sep 2003
Posts: 762

PostPosted: Wed Oct 20, 2004 6:54 pm    Post subject: Reply with quote

Nattie wrote:
Um detalhe importante: apesar de seguir todos os passos daquele manual, eu tive que tirar a use flag "userlocales" e recompilar a glibc, porque por algum motivo louco ela não compilava os locales especificados no arquivo de configuração. Então, se você está com essa flag habilitada, recomendo que coloque um - antes dela e recompile sua glib. :)

I'll second that, nota que esta useflag so aparece nas ebuilds das glibc's mais recentes.
_________________
--> Linux ### 2.6.11-ck2 #1 Sat Mar 12 20:21:30 WET 2005 i686 GNU/Linux <--
Back to top
View user's profile Send private message
Guzymuzy
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2004
Posts: 102
Location: Manaus - Brazil

PostPosted: Thu Oct 21, 2004 11:59 pm    Post subject: gcc Reply with quote

Então no caso eu preciso refazer o gcc e recompilar o firefox e o thunderbird com ele? Pq o meu problema só é com esses pacotes.
Já tentei o thunderbird-bin e tb não funcionou.
Pq? Já que ele já é um pacote pré-compilado?
Agradeço a colaboração

Gustavo
Back to top
View user's profile Send private message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Fri Oct 22, 2004 8:57 pm    Post subject: Reply with quote

Eu tive esse problema qdo mudei tudo pra UTF-8, mas o c agudo aparecia em todos os programas, nao somente em alguns.

Eu resolvi mexendo em alguns arquivos do XOrg, que tavam usando o código do ç pro c agudo. O problema agora é lembrar qual arquivo :D

Se vc quiser tentar, me fala q eu procuro.
Back to top
View user's profile Send private message
Guzymuzy
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2004
Posts: 102
Location: Manaus - Brazil

PostPosted: Fri Oct 22, 2004 11:37 pm    Post subject: Reply with quote

Claro que quero!
Nada na vida linux é fácil mesmo.
Acho que é por isso que todos nós somos apaixonados por ele.
Tudo que é fácil enjôa! Hehehehe.

Valeu.

Gustavo Motta
Back to top
View user's profile Send private message
gmichels
Guru
Guru


Joined: 20 Jun 2003
Posts: 480
Location: Brazil

PostPosted: Fri Oct 22, 2004 11:50 pm    Post subject: Reply with quote

/usr/X11R6/lib/X11/locale/en_US.UTF-8/Compose, linhas 634 a 641. Onde tá cedilha, tava esse c com acento agudo.
Code:
<dead_acute> <C> : "Ç" U00c7 # LATIN CAPITAL LETTER C WITH CEDILLA
<Multi_key> <acute> <C> : "Ç" U00c7 # LATIN CAPITAL LETTER C WITH CEDILLA
<Multi_key> <apostrophe> <C> : "Ç" U00c7 # LATIN CAPITAL LETTER C WITH CEDILLA
<combining_acute> <C> : "Ç" U00c7 # LATIN CAPITAL LETTER C WITH CEDILLA
<dead_acute> <c> : "ç" U00e7 # LATIN SMALL LETTER C WITH CEDILLA
<Multi_key> <acute> <c> : "ç" U00e7 # LATIN SMALL LETTER C WITH CEDILLA
<Multi_key> <apostrophe> <c> : "ç" U00e7 # LATIN SMALL LETTER C WITH CEDILLA
<combining_acute> <c> : "ç" U00e7 # LATIN SMALL LETTER C WITH CEDILLA

Isso pra mim funcionou, mas foi pq eu tinha vindo de um locale POSIX pra um UTF-8, como vc pode ver no diretório do arquivo que estou editando.
Back to top
View user's profile Send private message
Guzymuzy
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2004
Posts: 102
Location: Manaus - Brazil

PostPosted: Sun Oct 24, 2004 2:44 pm    Post subject: Reply with quote

Eu mudei tudo o que vc sugeriu, mas mesmo assim não funcionou.
Mas muito obrigado assim mesmo por tentar me ajudar.

Gustavo Motta
Back to top
View user's profile Send private message
Guzymuzy
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2004
Posts: 102
Location: Manaus - Brazil

PostPosted: Sun Oct 24, 2004 3:29 pm    Post subject: Reply with quote

Resolvi o problema fazendo o seguinte:

adicionei export LC_CTYPE=pt_BR.ISO-8859-1 em /etc/profile

e

mudei o xorg.conf

Option "XkbLayout" "us_intl"

agora tá tudo funcionando.

Valeu!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum