Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge ltmodem failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
Taoub
Apprentice
Apprentice


Joined: 12 Jan 2004
Posts: 173

PostPosted: Mon Oct 18, 2004 7:51 am    Post subject: emerge ltmodem failed Reply with quote

Выдает служующее
Code:

>>> Unpacking source...
>>> Unpacking ltmodem-8.26a9.tar.gz to /var/tmp/portage/ltmodem-8.26_alpha9-r1/work
>>> Source unpacked.
Within build_module FV=
/tmp/ltmodem/tmpfile
Now acquiring distribution data:
The distribution is Not_identified
   Please report the identifying /etc/FileName to discuss@linmodems.org
TARGET_CPU=
   End of distribution check.

Setting BLDrecord.txt link within source/ folder.
lrwxr-xr-x  1 root root 16 пЛФ 18 09:04 BLDrecord.txt -> ../BLDrecord.txt
Following a successful check for matching kernel-headers,
the modem drivers will be compiled for the current kernel version: 2.6.8.1-ck9

Performing a configure trial and capturing the report to ../conf-report.txt.
Parsing the report:
   No evident problems.

creating cache ./config.cache
Checking OS
Checking machine type
checking for gcc... gcc
checking whether the C compiler (gcc -march=pentium3 -O3 -pipe -fomit-frame-pointer ) works... yes
checking whether the C compiler (gcc -march=pentium3 -O3 -pipe -fomit-frame-pointer ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
Checking gcc major version 3
Checking for rpm build... which: no rpmbuild in (/usr/lib/ccache/bin:/sbin:/usr/sbin:/usr/lib/portage/bin:/bin:/usr/bin:/usr/local/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/3.3:/usr/X11R6/bin:/usr/qt/3/bin:/usr/kde/3.3/sbin:/usr/kde/3.3/bin)
rpm
checking for a BSD compatible install... /bin/install -c
checking for make... yes
checking for ld... yes
Checking for kernel headers
  ... in /usr/src/linux: Kernel headers found in /usr/src/linux
  ... in /usr/src/kernel-headers-2.6.8.1-ck9: nope
  ... in /usr/src/linux-2.6.8.1: nope
  ... in /usr/src/linux-2.6.8.1-ck9: Kernel headers found in /usr/src/linux-2.6.8.1-ck9
  ... in /lib/modules/2.6.8.1-ck9/build: Kernel headers found in /lib/modules/2.6.8.1-ck9/build
  using /lib/modules/2.6.8.1-ck9/build
Checking kernel header version
  kernel headers are version 2.6.8.1-ck9
configure support only for 2.2, 2.4 and 2.5 kernels

The check for compilation tools and general resources was successful.
Within DOCs/ there is an annotated conf-report.txt
The Makefile and down steam installation scripts have been created.

Next checking for the the needed header file:   modversions.h
Properly configuring your sources may be aided by for RPM using Distros
by:    utils/srcprep
for RPM using Distros
and for Debian style Distros, the resources of kernel-package.deb
Sorry, assembly of the needed header file:    modversions.h
was not specified during configuration of the kernel sources.
Withing the section LOADABLE MODULE SUPPORT:
 [*]   Set version information on all module symbols
which is necessary to specify the assembly of modeversions.h
Consequently compiling of the drivers will fail at the next step.

Next checking utilty versions,
           Version_min
 Utility    or range for kernels   
   name     2.2.16       2.4.18          Actual_version   
-------------------------------------------------------------------
Gnu C      2.7.2.3      2.95.3-2.9.99   3.3.4
Gnu make   3.77         3.79.1         
binutils   2.8.1.0.23   2.9.1.0.25      2.14.90.0.8

-------------------------------------------------------------------

  The gcc compiler resources available are:
 ----------------------------
 -rwxr-xr-x  1 root root  7520 пЛФ 12 12:01 /usr/bin/gcc
-rwxr-xr-x  1 root root 10153 пЛФ 12 11:10 /usr/bin/gcc-config
 ----------------------------
 with your System currently using version 3.3.4
 Do NOT mix the major versions of compilers for the kernel and modem drivers
 or your System will crash! The following releases are using gcc version 3.2.x :
    Mandrake 9, Redhat 8 and SuSE 8.1 in November 2002.
 This build_module automatically adjusts its resources to the compiler version used.
 See the utils/ltrename (by Mark Spieth) called by the Makefile.
 
To continue:
   Enter



Checking for driver products:

Compilation of lt_modem.o failed,
as expected from absence of modversions.h
Read Compile_properly.txt from DOCs/.
If you cannot solve the problem, send BLDrecord.txt to: discuss@linmodems.org

Calculating dependencies    ...done!
>>> emerge (1 of 1) net-dialup/ltmodem-8.26_alpha9-r1 to /
>>> md5 src_uri ;-) ltmodem-8.26a9.tar.gz

grep: Makefile: No such file or directory
make: *** Не заданы цели и не найден make-файл.  Останов.

!!! ERROR: net-dialup/ltmodem-8.26_alpha9-r1 failed.
!!! Function src_compile, Line 25, Exitcode 2
!!! (no error message)


[/code]
Back to top
View user's profile Send private message
Taoub
Apprentice
Apprentice


Joined: 12 Jan 2004
Posts: 173

PostPosted: Mon Oct 18, 2004 7:54 am    Post subject: Reply with quote

ACCEPT_KEYWORDS="~x86" emerge ltmodem прошел успешно
Back to top
View user's profile Send private message
Taoub
Apprentice
Apprentice


Joined: 12 Jan 2004
Posts: 173

PostPosted: Mon Oct 18, 2004 8:03 am    Post subject: Reply with quote

установилось то установилось только вот при запуске
lt_autoload выдает следующие
Code:
 
To continue:    Enter

/usr/sbin/lt_autoload: line 74: test: too many arguments
 
 The currently serving modules tree is:    /lib/modules/2.6.8.1-ck9/
 The modem drivers have been installeed in /lib/modules/2.4.19-plip/ltmodem/   
 Thus they cannot serve under the current kernel: 2.6.8.1-ck9
 
 This is acceptable ONLY if a kernel + modules for kernel-version 2.4.19-plip
 will be later installed.

 Otherwise DO get advice on a suitable installer run:   scanmodem
 The desired Installer name is like: ltmodem-kv-2.6.8.1-ck9-8.22a5-1.i686.rpm

DEVFSD=/etc/devfsd.conf /usr/share/doc/devfsd-1.3.25-r8/devfsd.conf.gz /usr/share/man/man5/devfsd.conf.5.gz /usr/portage/sys-fs/devfsd/files/devfsd.conf
/usr/sbin/lt_autoload: line 101: $DEVFSD: ambiguous redirect
/usr/sbin/lt_autoload: line 102: $DEVFSD: ambiguous redirect
/usr/sbin/lt_autoload: line 103: $DEVFSD: ambiguous redirect
Back to top
View user's profile Send private message
Taoub
Apprentice
Apprentice


Joined: 12 Jan 2004
Posts: 173

PostPosted: Mon Oct 18, 2004 8:52 am    Post subject: Reply with quote

Проблема решилась путем загрузки модулей вручную и перезапуска devfsd
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum