Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --update, problems
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message

Joined: 02 Jul 2006
Posts: 10

PostPosted: Sat Apr 07, 2007 11:13 pm    Post subject: emerge --update, problems Reply with quote


I am a happy user of gentoo system. I have been using version 2005.1 for a long time, without update. But I am also interested in web development, so I decided to update my php version. I have both php4 and php5 as cgi scripts, everything worked fine.
Somewhere I read about update so, I typed emerge --update =dev-lang/php-4*, and list of packages was quite big (about 15 positions) - lot of core apps i think. After emerge sync I tried to emerge portage, but access violation summary error don't let me to do it. Probably that was my fault, that I try to emerge php without updating portage. I have emerged 3, or 4 apps but the same error came - access violation summary. I searched forums and found solution - I should emerge it with flag FEATURES="-sandbox", so I did it in that way. Portage emerged fine, but during php emerging (package called, I don't remeber but short name with 'db' and lot of numbers inside) error called and emerge stopped.
I tried to emerge typing emerge =dev-lang/php-4*. Emerge was succesfull, but in my apache log there is: Premature end of script headers: php-cgi
when i try to simply call phpinfo() inside my script. None of my php apps works . Typing php info in command line with php -r 'phpinfo();' is ok - everything works.
I was trying to install php as a module, but when I emerge apache I get the following error:

gawk -f /nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/build/make_exports.awk `cat export_files` > exports.c
/usr/lib/apache2/build/libtool --silent --mode=compile i686-pc-linux-gnu-gcc  -pthread  -O2 -march=i686 -pipe -fomit-frame-pointer  -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE -DAP_HAVE_DESIGNATED_INITIALIZER   -I/usr/include/apache2 -I. -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/os/unix -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/server/mpm/worker -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/modules/http -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/modules/filters -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/modules/proxy -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/include -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/modules/generators -I/usr/include/openssl -I/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/modules/dav/main -prefer-non-pic -static -c exports.c && touch exports.lo
exports.c:115: error: `ap_set_receive_buffer_size' undeclared here (not in a function)
exports.c:288: error: `ap_get_server_revision' undeclared here (not in a function)
exports.c:362: error: `ap_log_cerror' undeclared here (not in a function)
make[2]: *** [exports.lo] B³±d 1
make[2]: Leaving directory `/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/server'
make[1]: *** [all-recursive] B³±d 1
make[1]: Leaving directory `/nowy/tmp/portage/net-www/apache-2.0.58-r2/work/httpd-2.0.58/server'
make: *** [all-recursive] B³±d 1

!!! ERROR: net-www/apache-2.0.58-r2 failed.
Call stack:, line 1614:   Called dyn_compile, line 971:   Called qa_call 'src_compile'
  environment, line 3466:   Called src_compile
  apache-2.0.58-r2.ebuild, line 181:   Called die

!!! problem compiling apache2

So , I am in big trouble. Thanks for any answers

[/post]Here is my emerge --info (a little bit strange)
1. First few lines is the error, which is caused by the emerge update errors - I can't read /etc/portage/package.use !
2. I have usr directory in root partition as a symlink to directory on another hard drive. Maybe it is a source of my problems .. ? But everything seems to work - programs run, X starts..

Parse Error reading PROVIDE and USE in '/var/db/pkg/x11-base/xorg-x11-6.8.2-r2'
Possibly Invalid: 'virtual/x11 opengl? virtual/opengl opengl? virtual/glu virtual/xft'
Exception: Conditional without parenthesis: 'opengl?'

Portage (default-linux/x86/2006.1, gcc-3.3.5-20050130, glibc-2.3.5-r1, 2.6.12-gentoo-r9 i686)
System uname: 2.6.12-gentoo-r9 i686 Intel(R) Pentium(R) 4 CPU 2.60GHz
Gentoo Base System version 1.6.13
Timestamp of tree: Sat, 07 Apr 2007 08:30:01 +0000
dev-java/java-config: 1.2.11
dev-lang/python: 2.3.5
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.61
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1, 1.10
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/php/apache1-php4/ext-active/ /etc/php/apache2-php4/ext-active/ /etc/php/cgi-php4/ext-active/ /etc/php/cli-php4/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=i686 -O2 -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
USE="berkdb bitmap-fonts bzip2 cli cracklib crypt cups dri fortran gdbm gpm iconv ipv6 isdnlog ithreads libg++ midi ncurses nls nptl nptlonly pam pcre perl ppds pppd python readline reflection session spl ssl tcpd threads truetype-fonts type1-fonts unicode x86 xorg zlib" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="apm ark ati chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mga neomagic nsc nv rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Back to top
View user's profile Send private message

Joined: 26 Apr 2006
Posts: 674

PostPosted: Sun Apr 08, 2007 2:21 pm    Post subject: Reply with quote

Try adding --deep.

If you haven't been using --update and your profile is 2005.1, then your system is probably way out of date. You need to switch to a newer profile and run 'emerge --update world', but don't do it all at once. At least try 'emerge -DNua world', probably you'll get dozens of packages to update, but if there are no blocks or masks, then you should end up with a functioning (and up to date) system when it's over.

Never '--update'ing your system in gentoo eventually leads to trouble. Once a year is not enough. I find that more than 2-3 weeks between updates is too much, becuase little glitches tend to pile up and interfere with each other, that is, the error messages from one confuse the error messages from the other.

I wish someone would write a "weekly housekeeping guide" to using emerge -DNua world, revdep-rebuild, building the latest kernel and eliminateing builtup cruft to keep a system up to date. There are many different strategies, of course to keeping an up to date system, but at least a guide that works would be useful to a lot of beginners.


Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum