Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kdelibs-3.3.0 nao compila de forma alguma
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Sep 27, 2004 2:48 pm    Post subject: kdelibs-3.3.0 nao compila de forma alguma Reply with quote

Code:
.......e-strings -DNDEBUG -DNO_DEBUG -O2 -O2 -march=athlon-xp -fomit-frame-pointer -Wfo rmat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-com mon  -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_ TRANSLATION  -c -o artskde.lo artskde.cc
/bin/sh ../../libtool --silent --mode=link --tag=CXX g++  -Wnon-virtual-dtor -Wn o-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconve rsion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_D EBUG -O2 -O2 -march=athlon-xp -fomit-frame-pointer -Wformat-security -Wmissing-f ormat-attribute -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE  -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o libarts kde.la -rpath /usr/kde/3.3/lib -L/usr/X11R6/lib -L/usr/qt/3/lib -L/usr/kde/3.3/l ib  -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 3 :0:2 artskde.lo kioinputstream_impl.lo kplayobject.lo kplayobjectfactory.lo kart sfloatwatch.lo kartsdispatcher.lo kaudiorecordstream.lo kaudioplaystream.lo kart sserver.lo kdatarequest_impl.lo kaudioconverter.lo kvideowidget.lo kplayobjectcr eator.lo kaudiomanagerplay.lo ../../kio/libkio.la -lqtmcop -lsoundserver_idl
libtool: link: warning: `/usr/lib/libidn.la' seems to be moved
libtool: link: warning: `/usr/lib/libidn.la' seems to be moved
libtool: link: warning: `/usr/lib/libidn.la' seems to be moved
libtool: link: warning: `/usr/lib/libidn.la' seems to be moved
libtool: link: warning: `/usr/lib/libidn.la' seems to be moved
libtool: link: warning: library `/usr/lib/libidn.la' was moved.
grep: /var/tmp/portage/libmad-0.15.1b/image//usr/lib/libmad.la: No such file or directory
/bin/sed: can't read /var/tmp/portage/libmad-0.15.1b/image//usr/lib/libmad.la: N o such file or directory
libtool: link: `/var/tmp/portage/libmad-0.15.1b/image//usr/lib/libmad.la' is not  a valid libtool archive
make[3]: ** [libartskde.la] Erro 1
make[3]: Leaving directory `/var/tmp/portage/kdelibs-3.3.0/work/kdelibs-3.3.0/ar ts/kde'
make[2]: ** [all-recursive] Erro 1
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.3.0/work/kdelibs-3.3.0/ar ts'
make[1]: ** [all-recursive] Erro 1
make[1]: Leaving directory `/var/tmp/portage/kdelibs-3.3.0/work/kdelibs-3.3.0'
make: ** [all] Erro 2

!!! ERROR: kde-base/kdelibs-3.3.0 failed.
!!! Function kde_src_compile, Line 142, Exitcode 2
!!! died running emake, kde_src_compile:make

208 root #



atlhon seprom XP 1666MHZ

Code:
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"

_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
xef
Guru
Guru


Joined: 20 Jun 2003
Posts: 460
Location: Porto - Portugal

PostPosted: Mon Sep 27, 2004 4:00 pm    Post subject: Reply with quote

Esse erro não me parece ter a ver com as CFLAGS

Ao que parece falta o ficheiro para onde o link /usr/lib/libidn.la aponta. Tenta ver o que se passa aí...
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Sep 27, 2004 4:29 pm    Post subject: Reply with quote

por via das dúvidas, estou removendo e adcionando novamente o libidn, e logo em seguida dando sequencia em mais uma tentativa de terminar a compilação do KDE, assim que obtiver os resultados posto por aqui

obrigado
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Mon Sep 27, 2004 9:08 pm    Post subject: Reply with quote

Pode ser um problema com a use flag libmad, ou mad, não me lembro. Tente desabilita-la e recompilar de novo. Alternativamente, instale a libmad.
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Tue Oct 05, 2004 3:15 pm    Post subject: Reply with quote

OLá amigos estou aqui voltando, mesmo depois de algum tempo, fiz as recomendaços e pelo visto nao funcionou


mesmo reinstalando os suspostos pacotes que deveriam estar gerando o problema, nao resolveu

grato

Code:
ormat-attribute -fno-exceptions -fno-check-new -fno-common  -DQT_CLEAN_NAMESPACE  -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o libarts kde.la -rpath /usr/kde/3.3/lib -L/usr/X11R6/lib -L/usr/qt/3/lib -L/usr/kde/3.3/l ib  -no-undefined -Wl,--no-undefined -Wl,--allow-shlib-undefined -version-info 3 :0:2 artskde.lo kioinputstream_impl.lo kplayobject.lo kplayobjectfactory.lo kart sfloatwatch.lo kartsdispatcher.lo kaudiorecordstream.lo kaudioplaystream.lo kart sserver.lo kdatarequest_impl.lo kaudioconverter.lo kvideowidget.lo kplayobjectcr eator.lo kaudiomanagerplay.lo ../../kio/libkio.la -lqtmcop -lsoundserver_idl
grep: /var/tmp/portage/libmad-0.15.1b/image//usr/lib/libmad.la: No such file or directory
/bin/sed: can't read /var/tmp/portage/libmad-0.15.1b/image//usr/lib/libmad.la: N o such file or directory
libtool: link: `/var/tmp/portage/libmad-0.15.1b/image//usr/lib/libmad.la' is not  a valid libtool archive
make[3]: ** [libartskde.la] Erro 1
make[3]: Leaving directory `/var/tmp/portage/kdelibs-3.3.0/work/kdelibs-3.3.0/ar ts/kde'
make[2]: ** [all-recursive] Erro 1
make[2]: Leaving directory `/var/tmp/portage/kdelibs-3.3.0/work/kdelibs-3.3.0/ar ts'
make[1]: ** [all-recursive] Erro 1
make[1]: Leaving directory `/var/tmp/portage/kdelibs-3.3.0/work/kdelibs-3.3.0'
make: ** [all] Erro 2

!!! ERROR: kde-base/kdelibs-3.3.0 failed.
!!! Function kde_src_compile, Line 142, Exitcode 2
!!! died running emake, kde_src_compile:make
[/quote]
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Oct 06, 2004 12:10 pm    Post subject: Reply with quote

ola pessoal refiz tb o pacote libtool, nao sei mais o que pode ser em si tratando de pacotes, alguem sabe dizer se isso tem relaçao com esses semproms? nessa mesma maquina, compilei, gnome, mozilla e openOffice 1.1.2 sem problemas, somente o KDE ta dando essa chiada

t+
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum