Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems booting EM64T with amd64 live cd - No long mode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
triode
n00b
n00b


Joined: 11 Aug 2004
Posts: 22
Location: Oz

PostPosted: Sat May 13, 2006 6:05 am    Post subject: Problems booting EM64T with amd64 live cd - No long mode Reply with quote

Hi -

I have recently aquired an Intel Entry Server which I would like to install Gentoo on.

INT4541 3.2GHz p4 CPU LGA775 (with em64t)
SE7221BA1-E Motherboard
2 x SATA 300GB hard drives
2GB DDR2 533 RAM

Every time I try and boot from the amd64 live CD I get the following error:

"Your CPU does not support long mode. Use a 32bit Distribution"

I have tried with the minimal 2006 amd64 livecd and the universal 2006 livecd, both with the same above error.

I know this processor and MB support 64bit operations... So what could be the problem? There seems to be very little googleable info on this problem.

The only thing I can think of is that the MB bios does not include em64t support. The MB itself is specified as supporting em64t, so should there be some option in the bios settings that would indicate em64t is enabled or not?

Also. if I install gentoo as usual in 32 bit, can I then just emerge a 64 bit kernel and build the system with the correct settings in /etc/make.conf. Or would it be best to boot, say, ubuntu amd64 live and then install gentoo from a chrooted shell whilst already running in 64 bit?

Thanks in advance
Back to top
View user's profile Send private message
magic919
Advocate
Advocate


Joined: 17 Jun 2005
Posts: 2174
Location: Berkshire, UK

PostPosted: Sat May 13, 2006 5:39 pm    Post subject: Reply with quote

Make sure you have high enough BIOS version for the processor. http://www.intel.com/support/motherboards/server/se7221ba1-e/sb/cs-020019.htm

Not trivial to hop from 32 to 64 bit afterwards. Get it how you want from the start.
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 832
Location: NY, USA

PostPosted: Sat May 13, 2006 7:34 pm    Post subject: Reply with quote

Have you looked at your bios? Make sure you don't have some strange setting set that is interfering. Also verify those CPUs are EM64T processors, it should say somewhere in your BIOS the details of your CPUs.
_________________
I am not anti-systemd; I am pro-choice. If being the latter makes you feel that I am the former, then so be it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum