Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Outra dúvida sobre instalação de pacotes
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Sat Sep 11, 2004 10:29 pm    Post subject: Outra dúvida sobre instalação de pacotes Reply with quote

Pretendo instalar um pacote ( submount, acho que é esse o nome ) que tem dependências. Uma delas é o kernel, o mesmo pretende instalar uma versão inferior do que a que tenho. Isso me deixa com 2 dúvidas.

Se eu instalar com emerge -U submount correrei o risco dele não funcionar, já que uma das dependências é o kernel ?

E, se eu instalar apenas com [b]emerge submount[b] e, depois dele instalado dar um outro emerge para voltar a versão do kernel que uso poderei ter problemas ?

Vale lembrar que o emerge irá apenas instalar o source de um kernel inferior ao meu ( uso a série 2.6 e ele quer instalar um da série 2.4 ) e não irei recompilá-lo.

A instalação desse pacote ( submount ) é importante para mim, de modo que eu possa resolver alguns problemas que tenho de montagem das minhas unidades de cd ( um CDRW e um CDRW+DVD )

Obrigado.
Back to top
View user's profile Send private message
RoadRunner
Bodhisattva
Bodhisattva


Joined: 12 Jun 2002
Posts: 490
Location: Coimbra, Portugal

PostPosted: Sat Sep 11, 2004 10:59 pm    Post subject: Reply with quote

Se o pacote tem como dependencia uma versão do kernel é porque precisa dela. Se apenas necessitade de um kernel dependia não de uma versão mas de um qualquer que estivesse instalado.

Ou seja, a partir daí tira as tuas conclusões, testa e se não funcionar já sabes do que é. Convinha que especificasses se o programa depende de um kernel 2.4 e tu tens um 2.6, nesse caso é normal que seja impossível instalar no kernel 2.6, ou até pode acontecer que já esteja incluido, como o alsa ou os lm_sensors.
Back to top
View user's profile Send private message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Sun Sep 12, 2004 12:06 am    Post subject: Reply with quote

Esse é o caso, ele depende de um kernel 2.4 e eu tenho um 2.6.7 instalado. O programa é o submount, para facilitar o uso de mídias removíveis. Já usava isso no SuSE 9.1, com kernel 2.6.5, por isso acho que pode ser que funcione... Só tenho receio de estragar minha instalação e ter que fazer tudo de novo !!!!

Obrigado !
Back to top
View user's profile Send private message
fernandotcl
Veteran
Veteran


Joined: 20 Nov 2003
Posts: 1396
Location: Sao Paulo, Brazil

PostPosted: Sun Sep 12, 2004 1:38 am    Post subject: Reply with quote

Você pode usar dois kernels (kernéis? :D) simultaneamente, bastando alterar o lilo/grub.conf. Logicamente, um de cada vez. :wink:

Se eu não me engano, o SuperMount exerce a mesma função desse SubMount, e está nos kernels 2.6. Mas não sei a quanto à configuração.

E é muito difícil quebrar uma instalação a ponto de ter que reinstalar tudo.
Back to top
View user's profile Send private message
alex-gurgel
n00b
n00b


Joined: 06 Sep 2004
Posts: 13
Location: Brasil - Rio de Janeiro

PostPosted: Sun Sep 12, 2004 5:42 pm    Post subject: Reply with quote

Valeu pela explicação. No final das contas não precisei instalar o submount. O problema estava nas configurações do meu arquivo /etc/fstab. As linhas relativas as duas unidades de cd estavam assim:

Code:

/dev/cdroms/cdrom0  /mnt/cdrom  iso9660  noauto,ro,users,umask=000  0 0
/dev/cdroms/cdrom1  /mnt/dvd      iso9660  noauto,ro,users,umask=000  0 0


Bastou remover o parâmetro umask=000 e trocar o iso9660 por auto que passou a funcionar corretamente. Mas no caso das partições do meu outro hd ( onde tenho o Win XP, em ntfs ) tive de manter o umask.

De qualquer modo, valeu pelas dicas !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum