Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TOOL] Unclepine [VECCHIO THREAD]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5 ... 18, 19, 20  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Sep 27, 2004 8:19 pm    Post subject: Reply with quote

gnome-light viene segnato correttamente per l'eliminazione. :)

cmq ora all'appello mancano:
Code:

dev-libs/glib-2.4.5
media-libs/audiofile-0.2.6-r1
media-libs/fontconfig-2.2.2
media-sound/esound-0.2.34


il fatto che glib non ci sia in Dep system purtroppo non risolve molto.
Che sia in Dep world e' corretto.

prova a lanciare

Code:

for x in dev-libs/glib-2.4.5 media-libs/audiofile-0.2.6-r1 media-libs/fontconfig-2.2.2 media-sound/esound-0.2.34; do echo "Processo "$x; ./unclepine -db -f -cu -su $x; done


il tuo file virtuals mi sembra un po' scarno...
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Sep 27, 2004 8:22 pm    Post subject: Reply with quote

Il comando da
Code:
# for x in dev-libs/glib-2.4.5 media-libs/audiofile-0.2.6-r1 media-libs/fontconfig-2.2.2 media-sound/esound-0.2.34; do echo "Processo "$x; ./unclepine -db -f -cu -su $x; done

Processo dev-libs/glib-2.4.5
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task


Processo media-libs/audiofile-0.2.6-r1
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task


Processo media-libs/fontconfig-2.2.2
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task


Processo media-sound/esound-0.2.34
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task



xchris wrote:
il tuo file virtuals mi sembra un po' scarno...

ti ho detto ho messo in piedi una macchina con 2Gb di hd solo per unclepine :D . Non ho installato quasi nulla.
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Sep 27, 2004 8:29 pm    Post subject: Reply with quote

chiedo scusa per l'errore :S

Code:

for x in dev-libs/glib-2.4.5 media-libs/audiofile-0.2.6-r1 media-libs/fontconfig-2.2.2 media-sound/esound-0.2.34; do echo "Processo "$x; ./unclepine -db -f -cu -su =$x; done



una macchina per unclepine? Ti devo fare una statua oraa.... arg :D
10x
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Sep 27, 2004 8:34 pm    Post subject: Reply with quote

Ecco qui.. si pero' anche io potevo capire che qualcosa non aveva funzionato
Code:
# for x in dev-libs/glib-2.4.5 media-libs/audiofile-0.2.6-r1 media-libs/fontconfig-2.2.2 media-sound/esound-0.2.34; do echo "Processo "$x; ./unclepine -db -f -cu -su =$x; done
Processo dev-libs/glib-2.4.5
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task

dev-libs/glib-2.4.5
NEEDED BY:
        * =dev-libs/atk-1.6.1
        * =dev-libs/libIDL-0.8.3
        * =dev-libs/libcroco-0.5.1
        * =dev-python/pygtk-2.2.0
        * =gnome-base/eel-2.6.2
        * =gnome-base/gconf-2.6.2
        * =gnome-base/gnome-keyring-0.2.1
        * =gnome-base/gnome-light-2.6.2
        * =gnome-base/gnome-vfs-2.6.1.1
        * =gnome-base/libbonobo-2.6.2
        * =gnome-base/libbonoboui-2.6.1
        * =gnome-base/libglade-2.4.0
        * =gnome-base/libgnome-2.6.1.1-r1
        * =gnome-base/librsvg-2.6.5
        * =gnome-base/nautilus-2.6.3
        * =gnome-base/orbit-2.10.3
        * =gnome-extra/libgsf-1.9.0
        * =x11-libs/gtk+-2.4.9-r1
        * =x11-libs/pango-1.4.1
        * =x11-libs/vte-0.11.11
        * =x11-misc/shared-mime-info-0.14
        * SYSTEM PROFILE (or dependency)


Processo media-libs/audiofile-0.2.6-r1
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task

media-libs/audiofile-0.2.6-r1
NEEDED BY:
        * =gnome-base/libgnome-2.6.1.1-r1
        * =gnome-base/libgnomeui-2.6.1.1
        * =media-sound/esound-0.2.34


Processo media-libs/fontconfig-2.2.2
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task

media-libs/fontconfig-2.2.2
NEEDED BY:
        * =gnome-base/control-center-2.6.1
        * =x11-base/xorg-x11-6.7.0
        * =x11-libs/pango-1.4.1


Processo media-sound/esound-0.2.34
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHI'S ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps
>>> Starting Task

media-sound/esound-0.2.34
NEEDED BY:
        * =gnome-base/control-center-2.6.1
        * =gnome-base/gnome-session-2.6.2
        * =gnome-base/libgnome-2.6.1.1-r1
        * =gnome-base/libgnomeui-2.6.1.1
        * =gnome-base/nautilus-2.6.3
        * =media-libs/libao-0.8.5
        * =media-video/mplayer-1.0_pre4



xchris wrote:
una macchina per unclepine? Ti devo fare una statua oraa.... arg :D

Avevo detto che avrei fatto il tester :D
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Sep 27, 2004 8:49 pm    Post subject: Reply with quote

ok ora e' + chiaro!

glib non lo toglie perche si confonde (:lol:) con il solito glib ed e' un bravo bimbo e non cancella.
Lo sistemo domani.

esound dipende da da audiofile
mplayer dipende da esound

mplayer -> esound ->audiofile

ma esd e' settata?
aiuto mi perdo :)

font-config serve a xorg....
in teoria doveva gia' esserci!

aiuuuto mi sto incasinando :D

ciauz
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Sep 27, 2004 8:52 pm    Post subject: Reply with quote

Beh penso che questi problemi (del tutto normali) erano risolti da debian con il programma deborphan.
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Sep 27, 2004 9:08 pm    Post subject: Reply with quote

sei stato gentilissimo!

direi che cmq e' gia' un ottimo risultato.
Tieni conto che stavamo provando con un ebuild non semplice.

Faro' altri test su mia macchina in locale...
magari proprio con gnome-light :D

starto l'emerge :)
denghiu ;)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Sep 27, 2004 9:10 pm    Post subject: Reply with quote

Se hai ancora bisogno batti un colpo la macchina la lascio up con gnome-light installato (cosi' lo provo anche :) )
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Mon Sep 27, 2004 9:23 pm    Post subject: Reply with quote

:)

cmq c'e' qc che non mi quadra..

fontconfig e' una dipendenza di xorg.
come mai non c'era?? mmm

e poi xorg doveva settarti qualche virtual... da quanto visto dal PROVIDE del ebuild.

ma la macchina era proprio clean?

vado a letto con il dubbio :D

ciauz
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Sep 27, 2004 9:25 pm    Post subject: Reply with quote

xchris wrote:
ma la macchina era proprio clean?

Si partito da 0 stage1 macchina rasenta. Ora provo a lanciare fixvirtuals
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Sep 27, 2004 9:32 pm    Post subject: Reply with quote

Ok il virtuals ora e' cambiato
Code:
virtual/xft x11-base/xorg-x11
virtual/gzip app-arch/gzip
virtual/glu x11-base/xorg-x11
virtual/x11 x11-base/xorg-x11
virtual/libc sys-libs/glibc
virtual/cron sys-apps/vixie-cron
virtual/modutils sys-apps/modutils sys-apps/module-init-tools
virtual/glibc sys-libs/glibc
virtual/bootloader sys-boot/grub
virtual/opengl media-video/nvidia-glx x11-base/xorg-x11
virtual/linux-sources sys-kernel/gentoo-dev-sources
virtual/textbrowser net-www/links
virtual/dhcpc net-misc/dhcpcd
virtual/logger app-admin/syslog-ng
virtual/editor app-editors/nano
virtual/dev-manager sys-fs/devfsd
virtual/os-headers sys-kernel/linux-headers
virtual/python dev-lang/python
virtual/kernel sys-kernel/linux-headers
virtual/alsa sys-kernel/gentoo-dev-sources
virtual/ssh net-misc/openssh
virtual/mta mail-mta/ssmtp

E unclepine ora mi da
Code:
Fake World removal: gnome-base/gnome-light-2.6.2


Packages that can be removed: 67

        * app-admin/fam-2.7.0
        * app-text/build-docbook-catalog-1.2
        * app-text/docbook-dsssl-stylesheets-1.77-r2
        * app-text/docbook-sgml-dtd-3.0-r1
        * app-text/docbook-sgml-dtd-3.1-r1
        * app-text/docbook-sgml-dtd-4.0-r1
        * app-text/docbook-sgml-dtd-4.1-r1
        * app-text/docbook-sgml-utils-0.6.12
        * app-text/docbook-xml-dtd-4.1.2-r5
        * app-text/docbook-xml-dtd-4.3
        * app-text/docbook-xml-simple-dtd-4.1.2.4
        * app-text/docbook-xsl-stylesheets-1.65.1
        * app-text/openjade-1.3.2-r1
        * app-text/opensp-1.5-r1
        * app-text/scrollkeeper-0.3.14
        * app-text/sgml-common-0.6.3-r4
        * dev-libs/atk-1.6.1
        * dev-libs/libIDL-0.8.3
        * dev-libs/libcroco-0.5.1
        * dev-libs/libxml2-2.6.11
        * dev-libs/libxslt-1.1.8
        * dev-perl/SGMLSpm-1.03-r5
        * dev-python/pygtk-2.2.0
        * dev-util/indent-2.2.9-r1
        * gnome-base/control-center-2.6.1
        * gnome-base/eel-2.6.2
        * gnome-base/gail-1.6.6
        * gnome-base/gconf-2.6.2
        * gnome-base/gnome-desktop-2.6.2
        * gnome-base/gnome-keyring-0.2.1
        * gnome-base/gnome-light-2.6.2
        * gnome-base/gnome-mime-data-2.4.1
        * gnome-base/gnome-panel-2.6.2
        * gnome-base/gnome-session-2.6.2
        * gnome-base/gnome-vfs-2.6.1.1
        * gnome-base/libbonobo-2.6.2
        * gnome-base/libbonoboui-2.6.1
        * gnome-base/libglade-2.4.0
        * gnome-base/libgnome-2.6.1.1-r1
        * gnome-base/libgnomecanvas-2.6.1.1
        * gnome-base/libgnomeui-2.6.1.1
        * gnome-base/librsvg-2.6.5
        * gnome-base/nautilus-2.6.3
        * gnome-base/orbit-2.10.3
        * gnome-extra/libgsf-1.9.0
        * gnome-extra/libgtkhtml-2.6.0
        * gnome-extra/yelp-2.6.1
        * media-libs/imlib-1.9.14-r2
        * media-libs/libao-0.8.5
        * media-libs/libart_lgpl-2.3.16
        * media-sound/vorbis-tools-1.0.1
        * net-misc/curl-7.11.0
        * net-nds/portmap-5b-r8
        * sys-apps/eject-2.0.13
        * x11-libs/gtk+-2.4.9-r1
        * x11-libs/libwnck-2.6.2.1
        * x11-libs/libxklavier-1.02
        * x11-libs/pango-1.4.1
        * x11-libs/startup-notification-0.6
        * x11-libs/vte-0.11.11
        * x11-misc/shared-mime-info-0.14
        * x11-terms/gnome-terminal-2.6.1
        * x11-themes/gnome-icon-theme-1.2.3
        * x11-themes/gnome-themes-2.6.2
        * x11-themes/gtk-engines-2.2.0
        * x11-themes/hicolor-icon-theme-0.5
        * x11-wm/metacity-2.8.1

_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Sep 28, 2004 6:26 am    Post subject: Reply with quote

domandina...
hai per caso modificato le use o e' tutto clean?

la useflag esd e' settata?
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Sep 28, 2004 8:40 am    Post subject: Reply with quote

ho riguardato il tutto a mente fresca.

che non ti segni glib 2.4... mi sta anche bene :)
nel senso che cmq e' una libreria un po' particolare...quindi anche se non la elimina non e' male. (e poi questo e' un caso abbastanza limite)
Meglio che il tool sia conservativo! Solitamente si lasciano in gira migliaia di cadaveri per il sistema...per cosi' poco non e' il caso di rischiare :)

Per fontconfig ,e audiofile esound direi invece che unclepine mi sembra si comporti bene.
Mi rimane il dubbio sul motivo per cui xorg non te lo aveva messo. (fontconfig)
E pure audiofile....come mai mplayer non te lo aveva messo? hai per caso aggiunto la useflag esd?
Mi posti un emerge info | grep USE ?

Magari un problema di virtuals...mmm non lo so... qualcuno ha un idea?

Nessuno ha voglia di testare?

Grazie :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Tue Sep 28, 2004 8:42 am    Post subject: Reply with quote

xchris wrote:
Mi posti un emerge info | grep USE ?

Ti fa niente se posto domani o stasera? La macchina ora e' occupata
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Sep 28, 2004 8:49 am    Post subject: Reply with quote

ci mancherebbe :lol:

cmq ho scoperto l'arcano :)

ci sono useflag ereditate!!

http://www.gentoo.org/doc/it/handbook/handbook-x86.xml?part=2&chap=1
cerca "Ereditare"

la flag esd viene ereditata!!!

E quindi a quel punto audiofile,esound dipendono da mplayer!

Vedo se c'e' soluzione...
Forse facendo la ricerca con le sole useflag di compilazione risolviamo.
Anche se non dovessimo... l'importante e' che deep-unmerge sia conservativo.

Gia' rilevare 67 pacchetti non e' male... che dici?
ciao


EDIT:riprova quando puoi commentando la riga 485 :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
doom.it
Guru
Guru


Joined: 23 May 2003
Posts: 430
Location: Pavia, Italy

PostPosted: Tue Sep 28, 2004 9:24 am    Post subject: Reply with quote

volevo proprio testare.... ma il link giusto da cui scaricare l'ultima versione è quello a pagina 1 di sto topic?

Io ho scaricato da li, e pare non riconoscere --deep-unmerge .... o sono scemo io (cosa probabile) o il link è un altro :)
_________________
I have discovered photography. Now I can kill myself. I have nothing else to learn.
Pablo Picasso
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Sep 28, 2004 10:32 am    Post subject: Reply with quote

grazie per la segnalazione...
il link era sparso per il thread. :)

ora e' in cima :)
grazie per i test
ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
doom.it
Guru
Guru


Joined: 23 May 2003
Posts: 430
Location: Pavia, Italy

PostPosted: Tue Sep 28, 2004 5:12 pm    Post subject: Reply with quote

ottimo, se uno avesse da subito un:

IOError: [Errno 2] No such file or directory: '/var/db/pkg/x11-plugins/wmCalClock-1.25-r1/DEPEND'

Come deve fare per fixare ?
_________________
I have discovered photography. Now I can kill myself. I have nothing else to learn.
Pablo Picasso
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Tue Sep 28, 2004 6:15 pm    Post subject: Reply with quote

bhe per iniziare lo script non dovrebbe inchiodarsi ;)
cmq....fix a parte

riemerge con

emerge --oneshot pacchetto

cosi' non intacca il world file

ciao :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2959
Location: Milano, Italy

PostPosted: Wed Sep 29, 2004 7:15 am    Post subject: Reply with quote

Ecco il mio contributo:
Code:
root@INSPIRON8600 # ./unclepine -u
* Psyco not enabled
>>> Considering Build time Use

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHIS ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps


ERROR -

DEBUG INFO:

:jpeg:
Error with : media-libs/libquicktime-0.9.2_pre1
['sys-apps/sed-4.0.9', 'media-libs/libdv-0.99-r1', 'x11-libs/gtk+-1.2.10-r11', 'media-libs/libpng-1.2.7', 'media-libs/libpng-1.2.7', 'media-libs/jpeg-6b-r3', 'media-libs/libvorbis-1.0.1-r2']


ERROR -

DEBUG INFO:

:hotplug-base:
Error with : sys-apps/hotplug-20040401
['sys-apps/pciutils-2.1.11-r1', 'sys-apps/usbutils-0.11-r3', 'sys-apps/usbutils-0.11-r3']
>>> Starting Task

Showing unlinked packages

#Iteration
* =x11-themes/gtk-engines-thinice-2.0.2-r1
* =dev-util/gtk-doc-1.1
* =dev-perl/Audio-Wav-0.02
* =x11-themes/gnome-themes-2.6.2
* =app-shells/tcsh-6.12-r3
* =media-libs/sdl-image-1.2.3
* =media-libs/sdl-ttf-2.0.6
* =media-sound/mpg123-0.59s-r2
* =dev-java/blackdown-jre-1.4.1
* =media-video/xanim-2.80.1-r4
* =dev-libs/libunicode-0.4-r1
* =gnome-base/gail-1.6.0
* =net-libs/gnet-2.0.5
* =sys-apps/hotplug-base-20040401
* =app-text/aspell-0.50.5-r4
* =games-util/uz2unpack-0.1
* =dev-perl/MP3-Info-1.02-r1
* =dev-util/yacc-1.9.1-r2
* =dev-perl/libvorbis-perl-0.04
* =sys-kernel/config-kernel-0.3.3
* =dev-libs/fribidi-0.10.4
* =sys-fs/xfsprogs-2.3.9
* =dev-util/pccts-1.33.33
* =sys-fs/jfsutils-1.1.3
* =app-text/ghostscript-7.07.1-r1
* =net-mail/mailwrapper-0.1
* =media-gfx/xloadimage-4.1-r1
* =dev-python/pyxml-0.8.3
#Iteration
* =dev-perl/Audio-Tools-0.01
* =x11-themes/gtk-engines-2.2.0
#Iteration
Che accidente vogliono dire quei 2 errori all'inizio?

Cmq complimenti![/code]
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Sep 29, 2004 7:31 am    Post subject: Reply with quote

allora...inziamo con un grazie per i test! :)

unclepine -u e' un po' "rischioso" nel senso che elenca spesso pacchetti utili. (magari solo per la compilazione)

Consiglio di usarlo cosi':

unclepine -u -f -pd -cu -su

ovvero:

unlinked (la funzione principale)
depend file (considera anche il file Depend..altrimenti solo RDEPEND)
pdepend file (considera pdepend)
compile-use (considera le use utilizzate in fase di compilazione)
system-use (considera le use correnti)

in questo modo e' gia' + affidabile

In futuro metto flag --safe che include tutto!


Gli errori significano che probabilmente quei pacchetti non hanno tutti i file necessari e obbligatori.....cioe' hai dei file corrotti sotto /var/db/pkg

Ti consiglio di riemergerli con --oneshot!
Dovrebbero sparire gli errori.

Sarebbe interessante provare anche le opzioni:
--db -- come qpkg -q -I
--df -- elenca le dipendenze dirette

e poi --deep-unmerge che si spiega da solo :)

quando fai un test valuta tu (io non posso saperlo :)) se i risultati sono attendibili!

Se un pacchetto da errore (come a te) non verranno considerate le sue dipendenze!!!!

ciao :)
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2959
Location: Milano, Italy

PostPosted: Wed Sep 29, 2004 7:52 am    Post subject: Reply with quote

Grazie per le spiegazioni, ma
xchris wrote:
Ti consiglio di riemergerli con --oneshot!
perchè proprio con oneshot? Se li installo normalmente che cosa cambia? Che "rischio"?
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824
Location: 45.488291,9.186094

PostPosted: Wed Sep 29, 2004 7:55 am    Post subject: Reply with quote

te li mette nel worldfile! (senza oneshot)

e se li mette ne world file saranno sempre considerati come pacchetti "desiderati" e non dipendenze di altro.
In questo modo emerge --depclean o similari e unclepine non vorranno mai troglierli :)

ciao
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Wed Sep 29, 2004 7:58 am    Post subject: Reply with quote

xchris wrote:
te li mette nel worldfile! (senza oneshot)

OK ma il comendo regenworld crea un world file corretto?
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Ty[L]eR
Apprentice
Apprentice


Joined: 18 May 2004
Posts: 189
Location: it

PostPosted: Wed Sep 29, 2004 8:00 am    Post subject: Reply with quote

ecco il mio di test:

Code:

./unclepine -u -f -pd -cu -su
* Psyco not enabled
>>> Considering System Use
>>> Considering Build time Use
>>> Considering also PDEPEND files
>>> Considering also DEPEND files

WARNING!! EXPERIMENTAL! USE AT YOUR OWN RISK!!!!!
THIS IS A REALLY BAD ALPHA VERSION FOR GECHIS ONLY! ;)
A LOT OF WORK MUST BE DONE!!!
VIRTUALS NOT WORKING PERFECTLY!!! (problems with double entry virtual)
>>> Reading files
>>> Resolving deps


ERROR -

DEBUG INFO:

:gdbm:


ERROR -

DEBUG INFO:

:gdbm:
Error with : net-mail/courier-imap-3.0.7
['sys-libs/glibc-2.3.3.20040420-r1', 'dev-libs/openssl-0.9.7d-r1', 'sys-libs/pam-0.77', 'sys-libs/db-4.1.25_p1-r3', 'sys-libs/db-1.85-r1', 'sys-libs/db-4.1.25_p1-r3', 'sys-libs/db-1.85-r1', 'sys-libs/gdbm-1.8.0-r5', 'dev-db/mysql-4.0.20-r1', 'dev-tcltk/expect-5.37.1-r2', 'sys-libs/glibc-2.3.3.20040420-r1', 'dev-libs/openssl-0.9.7d-r1', 'sys-libs/pam-0.77', 'sys-libs/db-4.1.25_p1-r3', 'sys-libs/db-1.85-r1', 'sys-libs/db-4.1.25_p1-r3', 'sys-libs/db-1.85-r1', 'sys-libs/gdbm-1.8.0-r5', 'dev-db/mysql-4.0.20-r1', 'dev-tcltk/expect-5.37.1-r2', 'sys-apps/sed-4.0.9', 'dev-lang/perl-5.8.4-r1', 'sys-apps/procps-3.2.3-r1', 'sys-devel/patch-2.5.9', 'sys-devel/gnuconfig-20040214']
>>> Starting Task

Showing unlinked packages

#Iteration


tutti quegli errori mi fanno un po' paura... e sotto #iteration non ha mostrato nulla :O
cmq complimenti :D
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2, 3, 4, 5 ... 18, 19, 20  Next
Page 4 of 20

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum