Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"Alt Gr"-tangenten funkar inte...?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
frippz
Guru
Guru


Joined: 22 Aug 2002
Posts: 460
Location: Malmö, Sweden

PostPosted: Fri Nov 15, 2002 8:00 am    Post subject: "Alt Gr"-tangenten funkar inte...? Reply with quote

Upptäckte nyligen att jag inte kan skriva tecken som kräver att jag håller alt gr intryckt. Jag har aldrig reflekterat över om det fungerat innan eller ej, så nu är jag lite förvirrad... :?

Det fungerar i skalet, men inte när jag startat x-servern.
Är det någon som har/har haft ett liknande problem som vet vad som är på tok? Vet inte riktigt vart jag ska börja ens med felsökningen. Hur som haver börjar det bli jobbigt att inte kunna skriva t.ex e-mailadresser numera pga detta. :(

Edit: Upptäckte nu ett felmeddelande i konsollen efter att x-servern stängts ner:
Code:

The XKEYBOARD keymap compiler (xkbcomp) reports:
>Error:        Can't find file "caps" for types include
>              Exiting
>              Abandoning keytypes file "default"
Errors from from xkbcomp are not fatal to the X server
Couldn't load XKB keymap, falling back to pre-XKB keymap
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!

När jag kikade i XF86Config var inställningarna för tangentbordet följande:
Code:

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"

    Identifier  "Keyboard1"
    Driver      "Keyboard"
# For most OSs the protocol can be omitted (it defaults to "Standard").
# When using XQUEUE (only for SVR3 and SVR4, but not Solaris),
# uncomment the following line.

#    Option     "Protocol"      "Xqueue"

    Option "AutoRepeat" "500 30"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#    Option     "Xleds"      "1 2 3"

#    Option "LeftAlt"     "Meta"
#    Option "RightAlt"    "ModeShift"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#    Option "XkbModel"    "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#    Option "XkbModel"    "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#    Option "XkbLayout"   "de"
# or:
#    Option "XkbLayout"   "de"
#    Option "XkbVariant"  "nodeadkeys"
    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "se"
    Option "XkbOptions" "grp:win_switch,ctrl:ctrl_aa,caps:shift_nocancel,altwin:menu"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"

# These are the default XKB settings for XFree86
#    Option "XkbRules"    "xfree86"
#    Option "XkbModel"    "pc101"
#    Option "XkbLayout"   "us"
#    Option "XkbVariant"  ""
#    Option "XkbOptions"  ""

#    Option "XkbDisable"

    Option "XkbRules"   "xfree86"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "se"
    Option "XkbOptions" "grp:win_switch,ctrl:ctrl_aa,caps:shift_nocancel,altwin:menu"

EndSection

Back to top
View user's profile Send private message
Yarrick
Bodhisattva
Bodhisattva


Joined: 05 Jun 2002
Posts: 304
Location: Malmö, Sweden

PostPosted: Sat Nov 16, 2002 5:22 pm    Post subject: Reply with quote

fungerar det utan dina special-XkbOptions?
Back to top
View user's profile Send private message
frippz
Guru
Guru


Joined: 22 Aug 2002
Posts: 460
Location: Malmö, Sweden

PostPosted: Sun Nov 17, 2002 2:23 pm    Post subject: Reply with quote

Hmmm, vilka syftar du på?
:? Jag kör såsom filen varit från scratch. Har inte lagt till nåt special mig vetligt...
Back to top
View user's profile Send private message
frippz
Guru
Guru


Joined: 22 Aug 2002
Posts: 460
Location: Malmö, Sweden

PostPosted: Sun Nov 17, 2002 11:55 pm    Post subject: Reply with quote

Ok, nu förstod jag vad du syftade på.
Jag kommenterade den raden och tog bort dubletterna och allting fungerar nu som det ska! :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum