Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cedilla in GTK applications
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Tue Sep 07, 2004 4:49 pm    Post subject: cedilla in GTK applications Reply with quote

Hello,

Is there a way to configure GTK-apps so that they use cedilla as the default input method?

I need it for the cedilla (ç) key. In gaim I can use it by clicking the right mouse button on a text box and selecting cedilla as the input method.

Thanks for the help,
Marcelo
_________________
Hello.
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Fri Sep 10, 2004 11:34 pm    Post subject: Reply with quote

Help?
_________________
Hello.
Back to top
View user's profile Send private message
revertex
l33t
l33t


Joined: 23 Apr 2003
Posts: 806

PostPosted: Sat Sep 11, 2004 3:24 am    Post subject: Reply with quote

what is your keyboard layout? abnt2 or us?
if your keyboard is properly configured in X cedilla will work for all apps.
with my us keyboard i can compose a cedilla just typing a dead acute plus c, no matter if tk, gtk, qt or console.

bye
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sat Sep 11, 2004 4:45 pm    Post subject: Reply with quote

Thanks for your reply,

I'm using an American (us) keyboard. Cedilla works fine in qt-apps, but not in GTK-apps.

This is what I have in my xorg.conf:
Code:

    Option "XkbRules"   "xorg"
    Option "XkbModel"   "pc105"
    Option "XkbLayout"  "us_intl"


Any ideas?
_________________
Hello.
Back to top
View user's profile Send private message
revertex
l33t
l33t


Joined: 23 Apr 2003
Posts: 806

PostPosted: Sun Sep 12, 2004 12:00 am    Post subject: Reply with quote

Vanquirius, my keyboard is a us keyboard too, and my xorg looks exactly like yours, however i have a a entry
Code:
export LC_ALL="pt_BR"
in my /etc/profile to convert everything to brazilian portugese, my native language.
my /etc/rc.conf have a entry KEYMAP="br-latin1-us", but i think it's only needed for use cedilla in console.
cedilla works out of box in all my gtk apps like gvim, gaim, abiword, gnumeric, gftp, gnomemeeting, xchat, etc...
stupid question, but did you follow gentoo localization guide?

i hope it can help you.
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sun Sep 12, 2004 4:04 pm    Post subject: Reply with quote

The problem is, I don't want to have my system in Portuguese.
I have read the localization guide, but it is not much help for I wanted to do.

I was hoping there was a way to have GTK-apps autoselect the cedilla input method the same way one would configure it to autoselect the japanese input method or cyrillic for example.

Thanks for your attention, though.
_________________
Hello.
Back to top
View user's profile Send private message
revertex
l33t
l33t


Joined: 23 Apr 2003
Posts: 806

PostPosted: Sun Sep 12, 2004 8:54 pm    Post subject: Reply with quote

Vanquirius wrote:
The problem is, I don't want to have my system in Portuguese.

Vanquirius, a system in portuguese seem a problem to me, english is the solution :)

you can add this to your /etc/profile

Quote:
export LC_CTYPE=pt_BR.ISO-8859-1


man setlocale will give you a better idea.

annother way is use xmodmap, the unfriendly manpage should help you.

localization is a pain in the arse, i just use portugese because some illiterate people use my box eventually :twisted:
Back to top
View user's profile Send private message
Vanquirius
Retired Dev
Retired Dev


Joined: 14 Jun 2002
Posts: 1297
Location: Ethereal plains

PostPosted: Sun Sep 12, 2004 11:07 pm    Post subject: Reply with quote

Quote:
export LC_CTYPE=pt_BR.ISO-8859-1


That's what I had been looking for! :-)
Thanks a lot, it all works perfectly now!
_________________
Hello.
Back to top
View user's profile Send private message
freitass
n00b
n00b


Joined: 04 May 2011
Posts: 5

PostPosted: Wed May 04, 2011 6:28 pm    Post subject: Finally! Reply with quote

Quote:
export LC_CTYPE=pt_BR

That worked for me too! (I have chosen to leave the encoding unset)
This situation could be an example of the locale man page.

Thanks! ;)
Back to top
View user's profile Send private message
ahgblopes
Tux's lil' helper
Tux's lil' helper


Joined: 16 Oct 2011
Posts: 102
Location: Brazil :(

PostPosted: Sun Aug 26, 2012 3:45 am    Post subject: Re: Finally! Reply with quote

freitass wrote:
Quote:
export LC_CTYPE=pt_BR

That worked for me too! (I have chosen to leave the encoding unset)
This situation could be an example of the locale man page.

Thanks! ;)


I've already done all of this, but i still with ćććććć..... :evil:

How can i check if i have the gtk-immodules installed? there isn't any package with this name...
Back to top
View user's profile Send private message
ferreirafm
Guru
Guru


Joined: 28 Jul 2005
Posts: 487
Location: Sao Paulo, Brazil

PostPosted: Mon Mar 17, 2014 9:25 pm    Post subject: Reply with quote

This is a definitive cedilla solution for GTK applications using a us keyboard:
1) open /etc/gtk-2.0/i686-pc-linux-gnu/gtk.immodules
2) search for "Cedilla" and add "en" to the corresponding line so as line:
"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"
will become to:
"cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:en:fr:gv:oc:pt:sq:tr:wa"
3) This edit will be removed at boot time. So, put the following script in your your /etc/local.d
Code:
#!/bin/bash
# rewrite gtk.immodules to fix cedilla in gtk apps
sed -i 's/az:ca:co:fr/az:ca:co:en:fr/' /etc/gtk-2.0/i686-pc-linux-gnu/gtk.immodules

Additional information on locale:
Code:
mephisto local.d # locale
LANG=pt_BR.utf8
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
LC_ALL=


xorg configure is as follows:
Code:
mephisto xorg.conf.d # pwd
/etc/X11/xorg.conf.d
mephisto xorg.conf.d # more 97-evdev.conf
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.


Section "InputClass"
   Identifier "mouse-all"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "AutoServerLayout" "on"
EndSection


Section "InputClass"
        Identifier "keyboard-all"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
        Option "xkb_layout" "us"
        Option "xkb_variant" "intl"
        Option "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Hope it helps.
Best.
Back to top
View user's profile Send private message
ferreirafm
Guru
Guru


Joined: 28 Jul 2005
Posts: 487
Location: Sao Paulo, Brazil

PostPosted: Mon Sep 01, 2014 9:00 pm    Post subject: Reply with quote

For whom it may interest,
This is the cedilla configuration for US international keyboards.
I've recently move to systemd and Gnome3.12 so as, additionally to the procedures pointed in my last post above, its also necessary to export GTK_IM_MODULES and QT_IM_MODULES variables into the file /etc/environment as follows:
Code:
#
# This file is parsed by pam_env module
#ed
# Syntax: simple "KEY=VAL" pairs on separate lines
#
GTK_IM_MODULE=cedilla
QT_IM_MODULES=cedilla

Best.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4547

PostPosted: Tue Sep 02, 2014 5:05 am    Post subject: Reply with quote

Why not take the least complicated approach?
* Search for a key you never use. Like "Menu" or "Right Windows".
* Look for its Key sym, e.g. use xev
* set that sym to Multi_key using xmodmap
* Compose umlauts/accents as you like by hitting "Multi_key -> [accent] -> key" in a row, not at the same time
(Multi_key AFAIK is called "Compose" key)
e.g.:
Compose ` e -> è
Compose " a -> ä
Compose " i -> ï
Compose o a -> å
Compose , c -> ç (That's what you want.)

You may want to search a "Compose table", I found this, but don't know how complete it is - it's enough for my needs ;)

I set it to "Menu" and my .xmodmap looks like this:
Code:
$ cat .xmodmap
keysym Menu = Multi_key


You can also try it by running
Code:
xmodmap -e "keysym Menu = Multi_key"

but a config is more ... persistent ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum