Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[alsa] Son à 0 à chaque reboot (résolu)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Wed Sep 08, 2004 12:58 am    Post subject: Reply with quote

sireyessire wrote:
le plus propre c'est de faire marcher alsasound

Mais alsasound fonctionne très bien ! :)

Je viens de me casser le neurone sur le même problème en configurant le PC de ma femme.
Après des heures de camboui, déboulonnage d'alsasound, tripotage d'alsamixer et mise à plat de tout le système son, je me suis rendu compte que le problème venait finalement de KDE !!!
Si on boote en xdm, ça passe totalement inaperçu :(
C'est en le désactivant temporairement que je suis tombé sur le pot aux roses.
En fait, le cher mastodonte a son propre petit mixer (kmix) qui, par défaut (du moins dans le 3.3.0), restaure lui aussi tous les niveaux au démarrage.
Et comme, par défaut, ses niveaux sont à zéro, ben il remet la carte à zéro, sans tenir compte de /etc/asound.state.
Evidemment, au shutdown, si on ne s'est aperçu de rien, alsasound enregistre les valeurs actuelles qui sont ... à zéro et ça n'arrange pas les choses.

Bref, la soluce, c'est soit de désactiver Artsd dans la config KDE, soit désactiver le restore des niveaux dans kmix, soit de mettre les niveaux de kmix à des valeurs convenables...
Back to top
View user's profile Send private message
sebaf
n00b
n00b


Joined: 13 Apr 2004
Posts: 30
Location: Liège, Belgique

PostPosted: Wed Sep 08, 2004 1:22 am    Post subject: Reply with quote

En effet, je viens d'essayer de remonter le son de kmix et d'enlever mes bricolages. Je reboot et... miracle !
C'etait donc cela chez moi aussi... :?
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Wed Sep 08, 2004 7:33 am    Post subject: Reply with quote

ghoti wrote:
sireyessire wrote:
le plus propre c'est de faire marcher alsasound

Mais alsasound fonctionne très bien ! :)

Mais j'en suis convaincu, je l'utilise depuis que j'ai décidé d'avoir du son sous linux ce qui a du se produire 2 semaines après la première install gentoo (1.4rc2) :wink: , c'est pas moi qui disait que ça fonctionnait pas. :D
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Wed Sep 08, 2004 8:21 am    Post subject: Reply with quote

sireyessire wrote:
c'est pas moi qui disait que ça fonctionnait pas. :D

Si j'ai "quoté" ta remarque c'est parce que je m'étais focalisé sur alsasound en pensant que le problème ne pouvait venir que de là.
Ta remarque résumait donc ma propre conviction : il valait mieux faire marcher alsasound correctement plutôt que de recourir à des subterfuges plus ou moins "propres" ! ;)
... jusqu'à ce que je découvre qu'alsasound n'est finalement pas le problème ...

A toutes fins utiles, je viens aussi de découvrir que alsasound vient d'être modifié :
changelog alsa-utils wrote:
# ChangeLog for media-sound/alsa-utils
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.67 2004/08/30 07:30:22 eradicator Exp $

29 Aug 2004; Jeremy Huddleston files/alsasound,
+files/alsasound.confd:
Added SAVE_ON_STOP option to init script thanks to Kalin KOZHUHAROV
in bug #61130.

La nouvelle variable SAVE_ON_STOP est située dans /etc/conf.d/alsasound et permet d'empêcher l'écrasement de /etc/asound.state suite aux agissements des petits comiques comme kmix ! ;)
C'est vrai qu'une fois configurés par alsamixer, les niveaux n'ont en principe pas besoin d'être sauvegardés encore une fois au shutdown !

Pour en bénéficier, il faut réemerger alsa-utils (le n° de version de l'ebuild n'a pas été modifié !)
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Wed Sep 08, 2004 2:39 pm    Post subject: Reply with quote

Pour démarrer X au démarrage, si tu veux un gestionnaire de session avec tu n'as qu faire faire un
Code:
vim /etc/rc.conf
et modifier
Code:
DISPLAYMANAGER=gdm ou kdm ou entrance
puis un petit
Code:
rc-update add xdm ou default
.
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !


Last edited by Talosectos on Wed Sep 08, 2004 4:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Sep 08, 2004 2:40 pm    Post subject: Reply with quote

Talosectos wrote:
Si tu ne veux pas de gestionnaire de sessions et directement lancer ton bureau, vérfie que dans /etc/rc.conf tu as bien la variable XSESSION correspondant à ton bureau et puis un petit
Code:
echo "startx" > /etc/conf.d/local.start
en root et ce devrait etre bon


Euh ca lance pas la session X de root ca par hasard ?
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Wed Sep 08, 2004 4:10 pm    Post subject: Reply with quote

kernel_sensei wrote:


Euh ca lance pas la session X de root ca par hasard ?


Autant pour moi

c rectifié (je sais pas où j'avais la tête)
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Wed Sep 08, 2004 4:15 pm    Post subject: Reply with quote

Talosectos wrote:
kernel_sensei wrote:


Euh ca lance pas la session X de root ca par hasard ?


Autant pour moi

c rectifié (je sais pas où j'avais la tête)


Au temps pour moi !!!

http://www.academie-francaise.fr/langue/questions.html#au_temps
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Wed Sep 08, 2004 10:46 pm    Post subject: Reply with quote

kernel_sensei wrote:
Talosectos wrote:
Autant pour moi

Au temps pour moi !!!
http://www.academie-francaise.fr/langue/questions.html#au_temps

WARNING : TROLL DETECTED !!!!
beep beep beep beep beep
lakademyefrensseize wrote:
la graphie Autant pour moi est courante aujourd’hui, mais rien ne la justifie

http://www.langue-fr.net/index/A/au_temps-autant.htm (exemple au hasard, cfr google ;) )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum