Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub not compiling
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 03 May 2002
Posts: 92
Location: Carleton College - Northfield, MN

PostPosted: Fri May 10, 2002 7:51 am    Post subject: Grub not compiling Reply with quote

I'm having a rather odd problem compiling grub. A while ago I posted about trying to put Gentoo on an old Pentium 'pooter. I'm trying to do that now. My Athlon XP system is now running Gentoo quite happily (yay!) and doing a fresh install in a chroot-ville (which I intend to tarball and transfer to the Pentium). I'm currently trying to "emerge system." Everything works great until I get to compiling grub:

make  all-am
make[3]: Entering directory `/var/tmp/portage/grub-0.90-r7/work/grub-0.90/stage2'
rm -f libgrub.a
ar cru libgrub.a libgrub_a-boot.o libgrub_a-builtins.o libgrub_a-common.o libgrub_a-char_io.o libgrub_a-cmdline.o libgrub_a-disk_io.o libgrub_a-gunzip.o libgrub_a-fsys_ffs.o libgrub_a-fsys_ext2fs.o libgrub_a-fsys_fat.o libgrub_a-fsys_minix.o libgrub_a-fsys_reiserfs.o libgrub_a-fsys_jfs.o libgrub_a-fsys_xfs.o libgrub_a-fsys_vstafs.o libgrub_a-stage2.o libgrub_a-md5.o
ranlib libgrub.a
gcc -Os -DVGA16=1 -fno-builtin -nostdinc  -DSUPPORT_SERIAL=1 -DSUPPORT_HERCULES=1 -DHAVE_CONFIG_H -I. -I. -I.. -I../stage1 -Wall -Wmissing-prototypes -Wunused    -Wshadow -malign-jumps=1 -malign-loops=1    -malign-functions=1 -Wundef -g -c -o start_exec-start.o `test -f start.S || echo './'`start.S
/tmp/ccIZEAH4.s: Assembler messages:
/tmp/ccIZEAH4.s:931: Error: missing ')'
/tmp/ccIZEAH4.s:931: Warning: rest of line ignored; first ignored character is `K'
make[3]: *** [start_exec-start.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/grub-0.90-r7/work/grub-0.90/stage2'make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/grub-0.90-r7/work/grub-0.90/stage2'make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/grub-0.90-r7/work/grub-0.90'
make: *** [all] Error 2

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_compile, Line 16, Exitcode 2
!!! Building failed.

!!! emerge aborting on  /usr/portage/sys-apps/grub/grub-0.90-r7.ebuild .
kryptonitespoon / #

This puzzled me, as I compiled from stage1 without difficulty for my Athlon box. I tried every single ebuild script for grub (including several 0.90-r?'s and 0.91-r3), with the same error. Weirder, grub has the exact same difficulty if I try the compile outside the chroot-ville (different toolchain entirely, but /usr/portage is "mount --bind"ed as per README.maintainers). I've tried deleting /usr/portage/sys-apps/grub/* and /usr/portage/distfiles/grub* and re-"emerge rsync"ing before trying again, to no avail (in chroot or out).

I can't find any posts on the boards about problems compiling grub (but plenty about using it :)). What on Earth is going on? It's not a random hardware thing (I've tried at least a dozen times by now, with the same outcome). It's probably not a USE keyword problem; the USE lines are quite different (the Athlon box is a standard GNOME setup and the Pentium system will be a firewall, i.e. no graphics whatsoever).

I'm stumped. Any ideas? (Thanks in advance for anyone who can help me shed this poor thing of the massive beast that is Red Hat 7.2 ...)

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum